aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-11-19 18:09:29 +0800
committerosa <osa@FreeBSD.org>2009-11-19 18:09:29 +0800
commit115ffcc47d6180106d803502e3301ef14782ed6b (patch)
tree24749c01e2035faa4cf00ad730c846fdcd795f02
parent7021841d15048f02d6a19074d505fd840cfb8435 (diff)
downloadfreebsd-ports-graphics-115ffcc47d6180106d803502e3301ef14782ed6b.tar.gz
freebsd-ports-graphics-115ffcc47d6180106d803502e3301ef14782ed6b.tar.zst
freebsd-ports-graphics-115ffcc47d6180106d803502e3301ef14782ed6b.zip
Update from 0.8.24 to 0.8.27.
<ChangeLog> Changes with nginx 0.8.27 *) Bugfix: regular expressions did work in nginx/Windows; the bug had appeared in 0.8.25. Changes with nginx 0.8.26 *) Bugfix: in captures usage in "rewrite" directive; the bug had appeared in 0.8.25. *) Bugfix: nginx could not be built without the --with-debug option; the bug had appeared in 0.8.25. Changes with nginx 0.8.25 *) Change: now no message is written in an error log if a variable is not found by $r->variable() method. *) Feature: the ngx_http_degradation_module. *) Feature: regular expression named captures. *) Feature: now URI part is not required a "proxy_pass" directive if variables are used. *) Feature: now the "msie_padding" directive works for Chrome too. *) Bugfix: a segmentation fault occurred in a worker process on low memory condition; the bug had appeared in 0.8.18. *) Bugfix: nginx sent gzipped responses to clients those do not support gzip, if "gzip_static on" and "gzip_vary off"; the bug had appeared in 0.8.16. </ChangeLog>
-rw-r--r--www/nginx-devel/Makefile10
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_redis_module.c20
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_upload_module.c48
4 files changed, 80 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index c8c4f69a74d..d24ce3608d6 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.8.24
+PORTVERSION= 0.8.27
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -364,6 +364,14 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_notice_module.c
.endif
+.if defined(WITH_HTTP_REDIS_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_redis_module.c
+.endif
+.if defined(WITH_HTTP_UPLOAD_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_upload_module.c
+.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 0ed8b8d202a..00f5e9db159 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.8.24.tar.gz) = 42c1d389c0122930790c8565fd882650
-SHA256 (nginx-0.8.24.tar.gz) = 5dd8466fed7bd5733ae1413b6ebc5fa770e9ec476b67f67242b5d2beaaad71db
-SIZE (nginx-0.8.24.tar.gz) = 613202
+MD5 (nginx-0.8.27.tar.gz) = d172c9dce43423dff5eaa48f4d699d60
+SHA256 (nginx-0.8.27.tar.gz) = d37763285cd5bbe21a005b969cb3d64bb1c6474dd2c6b73956e315ad4fc2ff9e
+SIZE (nginx-0.8.27.tar.gz) = 615382
MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_redis_module.c b/www/nginx-devel/files/extra-patch-ngx_http_redis_module.c
new file mode 100644
index 00000000000..102094fe8a2
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_redis_module.c
@@ -0,0 +1,20 @@
+--- ../ngx_http_redis-0.2.0/ngx_http_redis_module.c.orig 2009-11-19 11:21:17.000000000 +0300
++++ ../ngx_http_redis-0.2.0/ngx_http_redis_module.c 2009-11-19 11:21:57.000000000 +0300
+@@ -244,7 +244,7 @@
+ vv[0] = ngx_http_get_indexed_variable(r, rlcf->db);
+
+ if (vv[0] == NULL || vv[0]->not_found || vv[0]->len == 0) {
+- ngx_log_debug1(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_debug0(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
+ "select 0 redis database" );
+ len = sizeof("select 0") - 1;
+ } else {
+@@ -287,7 +287,7 @@
+ ctx->key.data = b->last;
+
+ if (vv[0] == NULL || vv[0]->not_found || vv[0]->len == 0) {
+- ngx_log_debug1(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_debug0(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
+ "select 0 redis database" );
+ *b->last++ = '0';
+ } else {
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c b/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c
new file mode 100644
index 00000000000..d0d8679e996
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c
@@ -0,0 +1,48 @@
+--- ../nginx_upload_module-2.0.10/ngx_http_upload_module.c.orig 2009-11-19 12:10:09.000000000 +0300
++++ ../nginx_upload_module-2.0.10/ngx_http_upload_module.c 2009-11-19 12:52:53.000000000 +0300
+@@ -1558,9 +1595,14 @@
+
+ ngx_str_t *value;
+ #if (NGX_PCRE)
++#if defined nginx_version && nginx_version >= 8025
++ ngx_regex_compile_t rc;
++ u_char errstr[NGX_MAX_CONF_ERRSTR];
++#else
+ ngx_int_t n;
+ ngx_str_t err;
+ #endif
++#endif
+ ngx_http_upload_field_filter_t *f;
+
+ value = cf->args->elts;
+@@ -1579,6 +1621,22 @@
+ }
+
+ #if (NGX_PCRE)
++#if defined nginx_version && nginx_version >= 8025
++ ngx_memzero(&rc, sizeof(ngx_regex_compile_t));
++
++ rc.pattern = value[1];
++ rc.pool = cf->pool;
++ rc.err.len = NGX_MAX_CONF_ERRSTR;
++ rc.err.data = errstr;
++
++ if(ngx_regex_compile(&rc) != NGX_OK) {
++ ngx_conf_log_error(NGX_LOG_EMERG, cf, 0, "%V", &rc.err);
++ return NGX_CONF_ERROR;
++ }
++
++ f->regex = rc.regex;
++ f->ncaptures = rc.captures;
++#else
+ f->regex = ngx_regex_compile(&value[1], 0, cf->pool, &err);
+
+ if (f->regex == NULL) {
+@@ -1596,6 +1654,7 @@
+ }
+
+ f->ncaptures = n;
++#endif
+ #else
+ f->text.len = value[1].len;
+ f->text.data = value[1].data;