aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-05-02 03:26:24 +0800
committermezz <mezz@FreeBSD.org>2004-05-02 03:26:24 +0800
commit11e598c6299505366c7bc9e290f96b8a49dc1efe (patch)
treed8a558510e31868a8e68169ff1ae38529f01ffd2
parent3210eaad98f0f5143747a11c434ea6ca5f14bb57 (diff)
downloadfreebsd-ports-graphics-11e598c6299505366c7bc9e290f96b8a49dc1efe.tar.gz
freebsd-ports-graphics-11e598c6299505366c7bc9e290f96b8a49dc1efe.tar.zst
freebsd-ports-graphics-11e598c6299505366c7bc9e290f96b8a49dc1efe.zip
x11-toolkits/ruby-gtkglext:
-Mark it as INGORE on FreeBSD 4.x. x11/ruby-gnome2-all: -Disable the x11-toolkits/ruby-gtkglext depend on FreeBSD 4.x. The issue is that the ruby can't be mix with and without threads (libc and libc_r) in the same place on FreeBSD 4.x. FreeBSD 5.x doesn't has any of problem. Approved by: adamw (mentor) Discussed with: knu
-rw-r--r--x11-toolkits/ruby-gtkglext/Makefile10
-rw-r--r--x11/ruby-gnome2-all/Makefile9
2 files changed, 14 insertions, 5 deletions
diff --git a/x11-toolkits/ruby-gtkglext/Makefile b/x11-toolkits/ruby-gtkglext/Makefile
index 6c12a77c2bb..809ea65bdd5 100644
--- a/x11-toolkits/ruby-gtkglext/Makefile
+++ b/x11-toolkits/ruby-gtkglext/Makefile
@@ -21,8 +21,6 @@ LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
${RUBY_SITEARCHLIBDIR}/opengl.so:${PORTSDIR}/graphics/ruby-opengl
-BROKEN= Broken dependency
-
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_XLIB= yes
@@ -35,6 +33,12 @@ INSTALL_TARGET= site-install
DOCS= ChangeLog \
README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Does not work on FreeBSD 4.x, because of thread issue with ruby-opengl and ruby-gnome2-all"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -45,4 +49,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/ruby-gnome2-all/Makefile b/x11/ruby-gnome2-all/Makefile
index d44a01edcb5..4ce70372c1f 100644
--- a/x11/ruby-gnome2-all/Makefile
+++ b/x11/ruby-gnome2-all/Makefile
@@ -23,7 +23,6 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gtkhtml2.so:${PORTSDIR}/www/ruby-gtkhtml2
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gnomevfs.so:${PORTSDIR}/devel/ruby-gnomevfs
#RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gst.so:${PORTSDIR}/multimedia/ruby-gst
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/libgda.so:${PORTSDIR}/databases/ruby-libgda
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gtkglext.so:${PORTSDIR}/x11-toolkits/ruby-gtkglext
# ruby-gst, wait for update to support gstreamer 0.8 API/ABI.
@@ -33,7 +32,13 @@ USE_RUBY= yes
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gtkglext.so:${PORTSDIR}/x11-toolkits/ruby-gtkglext
+.endif
+
do-install:
@${DO_NADA}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>