aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-03-26 20:32:16 +0800
committersem <sem@FreeBSD.org>2006-03-26 20:32:16 +0800
commit1449c60866effc453d87566cd2f19c8713942e34 (patch)
tree623e690c5e8ad8d63c66d5cca136bf8b14cd7849
parente64de0dfe9a6a2d4c844656a8831c96c9232dcfb (diff)
downloadfreebsd-ports-graphics-1449c60866effc453d87566cd2f19c8713942e34.tar.gz
freebsd-ports-graphics-1449c60866effc453d87566cd2f19c8713942e34.tar.zst
freebsd-ports-graphics-1449c60866effc453d87566cd2f19c8713942e34.zip
Anti-bruteforce PAM module for authentification services. It can be used to
prevent brute-force attacks on services like SSH or Telnet. It's highly configurable and very fast. WWW: http://mbsd.msk.ru/pam_af.html PR: ports/94113 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
-rw-r--r--security/Makefile1
-rw-r--r--security/pam_af/Makefile32
-rw-r--r--security/pam_af/distinfo3
-rw-r--r--security/pam_af/pkg-descr5
-rw-r--r--security/pam_af/pkg-plist4
5 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 33ecbf10efa..865b26e1fdb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -425,6 +425,7 @@
SUBDIR += pad
SUBDIR += pam-mysql
SUBDIR += pam-pgsql
+ SUBDIR += pam_af
SUBDIR += pam_alreadyloggedin
SUBDIR += pam_bsdbioapi
SUBDIR += pam_krb5
diff --git a/security/pam_af/Makefile b/security/pam_af/Makefile
new file mode 100644
index 00000000000..70556ad8e89
--- /dev/null
+++ b/security/pam_af/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pam_af
+# Date created: 5 Marth 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_af
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://mbsd.msk.ru/dist/
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Anti-bruteforce PAM module
+
+USE_BZIP2= yes
+
+MAN8= pam_af.8 pam_af_tool.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pam_af.so ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/pam_af_tool/pam_af_tool ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/pam_af.8 ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/pam_af_tool/pam_af_tool.8 ${PREFIX}/man/man8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pam_af/distinfo b/security/pam_af/distinfo
new file mode 100644
index 00000000000..d0a6e8967c2
--- /dev/null
+++ b/security/pam_af/distinfo
@@ -0,0 +1,3 @@
+MD5 (pam_af-1.0.tar.bz2) = 572b800442558b6bbcc86e75b7a13b93
+SHA256 (pam_af-1.0.tar.bz2) = 799ba4f22606896f7c70c3c20e6055751d5de45174ea01049418bd70e4bdf8ce
+SIZE (pam_af-1.0.tar.bz2) = 17884
diff --git a/security/pam_af/pkg-descr b/security/pam_af/pkg-descr
new file mode 100644
index 00000000000..902d794a6c9
--- /dev/null
+++ b/security/pam_af/pkg-descr
@@ -0,0 +1,5 @@
+Anti-bruteforce PAM module for authentification services. It can be used to
+prevent brute-force attacks on services like SSH or Telnet. It's highly
+configurable and very fast.
+
+WWW: http://mbsd.msk.ru/pam_af.html
diff --git a/security/pam_af/pkg-plist b/security/pam_af/pkg-plist
new file mode 100644
index 00000000000..ceae60064fc
--- /dev/null
+++ b/security/pam_af/pkg-plist
@@ -0,0 +1,4 @@
+lib/pam_af.so
+sbin/pam_af_tool
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%