aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-06-12 02:11:39 +0800
committerjbeich <jbeich@FreeBSD.org>2015-06-12 02:11:39 +0800
commit14c7f7ac9c3a1c8c4f3bdc31942c469000fae285 (patch)
tree253bbaee6f2d31d3a44f3d91f50dd474fd20fb93
parentdd3c40beac25d2eab27ac74abee3ce35adc3ab95 (diff)
downloadfreebsd-ports-graphics-14c7f7ac9c3a1c8c4f3bdc31942c469000fae285.tar.gz
freebsd-ports-graphics-14c7f7ac9c3a1c8c4f3bdc31942c469000fae285.tar.zst
freebsd-ports-graphics-14c7f7ac9c3a1c8c4f3bdc31942c469000fae285.zip
devel/android-tools-fastboot: install protocol documentation
-rw-r--r--devel/android-tools-fastboot/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/android-tools-fastboot/Makefile b/devel/android-tools-fastboot/Makefile
index f41408f6fc0..a8016e2e803 100644
--- a/devel/android-tools-fastboot/Makefile
+++ b/devel/android-tools-fastboot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= android-tools-fastboot
DISTVERSIONPREFIX= android-
DISTVERSION= 5.1.1_r4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://anonscm.debian.org/cgit/android-tools/android-tools.git/plain/debian/:manpage
DISTFILES= fastboot.1?id=706e754:manpage
@@ -31,6 +32,9 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/fastboot \
man/man1/fastboot.1.gz
+PORTDOCS= fastboot_protocol.txt
+
+OPTIONS_DEFINE= DOCS
post-extract:
# Adjust paths relative to core
@@ -40,5 +44,7 @@ post-extract:
post-install:
${INSTALL_MAN} ${_DISTDIR}/${DISTFILES:M*\:manpage:C/:.*//} \
${STAGEDIR}${MAN1PREFIX}/man/man1/fastboot.1
+ (cd ${INSTALL_WRKSRC} && ${COPYTREE_SHARE} \
+ "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>