aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-29 22:26:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-29 22:26:57 +0800
commit1542cd95db0971648c35a3068226f43a15b54d23 (patch)
treed7d9232cc5f2d7f634b5c46b8b7ea1a0d76abaa8
parent19845ba7228ca4a1a707796b9b2d1fad1681ed4a (diff)
downloadfreebsd-ports-graphics-1542cd95db0971648c35a3068226f43a15b54d23.tar.gz
freebsd-ports-graphics-1542cd95db0971648c35a3068226f43a15b54d23.tar.zst
freebsd-ports-graphics-1542cd95db0971648c35a3068226f43a15b54d23.zip
- Add LICENSE
- Add NO_ARCH - Depend on tk through USES - Switch to options helpers
-rw-r--r--editors/tpad/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/tpad/Makefile b/editors/tpad/Makefile
index a92256b742c..94238227d62 100644
--- a/editors/tpad/Makefile
+++ b/editors/tpad/Makefile
@@ -13,10 +13,12 @@ MASTER_SITES= SF/tclpad/tclpad/${PORTVERSION} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Windows XP (TM) enhanced Notepad clone written in Tcl/Tk
-RUN_DEPENDS= wish8.4:x11-toolkits/tk84
+LICENSE= GPLv2+
NO_BUILD= yes
+NO_ARCH= yes
+USES= tk:84,run
PORTDOCS= ChangeLog bug.html conf.html embed.html index.html intro.html \
keys.html log.html mouse.html tidy.html tidy.png todo tpad.html
PLIST_SUB= LIBDIR=lib/tpad${PORTVERSION}
@@ -36,10 +38,12 @@ do-install:
(cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s tpad tview)
${INSTALL_MAN} ${WRKDIR}/man/man1/tpad.1 ${STAGEDIR}${MANPREFIX}/man/man1
(cd ${STAGEDIR}${MANPREFIX}/man/man1 && ${LN} -s tpad.1.gz tview.1.gz)
+ ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf \
+ ${STAGEDIR}${PREFIX}/etc/tpad.conf.sample
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKDIR}/share/doc/tpad && ${INSTALL_DATA} ${PORTDOCS} \
${STAGEDIR}${DOCSDIR})
- ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf \
- ${STAGEDIR}${PREFIX}/etc/tpad.conf.sample
.include <bsd.port.mk>