aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-22 22:29:17 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-22 22:29:17 +0800
commit16fbdcd1f31505c3d14cc26712452f3eb63c106d (patch)
tree1eb4a8f5d261cb3c8325af70c691c3e6ba208f66
parentdb86d86f582b2d0c8c72d98d18ecc4780c1e373f (diff)
downloadfreebsd-ports-graphics-16fbdcd1f31505c3d14cc26712452f3eb63c106d.tar.gz
freebsd-ports-graphics-16fbdcd1f31505c3d14cc26712452f3eb63c106d.tar.zst
freebsd-ports-graphics-16fbdcd1f31505c3d14cc26712452f3eb63c106d.zip
imake(1) thinks that the first place where to look for a compiler on FreeBSD
is /usr/local/bin/gcc, which simply is not true. Correct it. Bump PORTREVISION for imake-4 port (XFree86-4-libraries isn't bumped because this port doesn't install its own imake binary, but builds it for internal consumption only). No reply from: MAINTAINERs
-rw-r--r--devel/imake-4/Makefile1
-rw-r--r--devel/imake-4/files/patch-imake::imake.c14
-rw-r--r--x11/XFree86-4-libraries/files/patch-t0118
3 files changed, 30 insertions, 3 deletions
diff --git a/devel/imake-4/Makefile b/devel/imake-4/Makefile
index 71d43c7f818..76064162726 100644
--- a/devel/imake-4/Makefile
+++ b/devel/imake-4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= imake
PORTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_XFREE} \
ftp://psych.psy.uq.oz.au/pub/X11R5/:wrap \
diff --git a/devel/imake-4/files/patch-imake::imake.c b/devel/imake-4/files/patch-imake::imake.c
new file mode 100644
index 00000000000..c44270e175c
--- /dev/null
+++ b/devel/imake-4/files/patch-imake::imake.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- imake/imake.c 2002/05/10 23:41:31 1.1
++++ imake/imake.c 2002/05/10 23:42:02
+@@ -1161,7 +1161,7 @@
+ get_gcc_incdir(FILE *inFile)
+ {
+ static char* gcc_path[] = {
+-#if defined(linux) || defined(__OpenBSD__) || defined (__GNU__)
++#if defined(linux) || defined(__OpenBSD__) || defined (__GNU__) || defined(__FreeBSD__)
+ "/usr/bin/cc", /* for Linux PostIncDir */
+ #endif
+ "/usr/local/bin/gcc",
diff --git a/x11/XFree86-4-libraries/files/patch-t01 b/x11/XFree86-4-libraries/files/patch-t01
index dc971232b5f..227a9671b3f 100644
--- a/x11/XFree86-4-libraries/files/patch-t01
+++ b/x11/XFree86-4-libraries/files/patch-t01
@@ -1,6 +1,18 @@
---- config/imake/imake.c.ORIG Mon Dec 18 14:54:34 2000
-+++ config/imake/imake.c Mon Dec 18 14:55:25 2000
-@@ -1208,6 +1208,19 @@
+
+$FreeBSD$
+
+--- config/imake/imake.c.orig Fri Dec 14 21:53:18 2001
++++ config/imake/imake.c Sat May 11 03:03:51 2002
+@@ -1161,7 +1161,7 @@
+ get_gcc_incdir(FILE *inFile)
+ {
+ static char* gcc_path[] = {
+-#if defined(linux) || defined(__OpenBSD__) || defined (__GNU__)
++#if defined(linux) || defined(__OpenBSD__) || defined (__GNU__) || defined(__FreeBSD__)
+ "/usr/bin/cc", /* for Linux PostIncDir */
+ #endif
+ "/usr/local/bin/gcc",
+@@ -1207,6 +1207,19 @@
if (uname(&name) < 0)
LogFatal("Cannot invoke uname", "");