aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-21 22:59:48 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-21 22:59:48 +0800
commit186f26257ecabf4d69671effa5f34999c3dceac0 (patch)
treedb91a5bb5b2eae73ed11e47d83b857cfdee91775
parent5312252c25877976ebc45291d40c9c1150db2658 (diff)
downloadfreebsd-ports-graphics-186f26257ecabf4d69671effa5f34999c3dceac0.tar.gz
freebsd-ports-graphics-186f26257ecabf4d69671effa5f34999c3dceac0.tar.zst
freebsd-ports-graphics-186f26257ecabf4d69671effa5f34999c3dceac0.zip
add mp3stat 2.5.2
Read information about mp3s and oggs bitstream
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3stat/Makefile29
-rw-r--r--audio/mp3stat/distinfo1
-rw-r--r--audio/mp3stat/pkg-comment1
-rw-r--r--audio/mp3stat/pkg-descr13
-rw-r--r--audio/mp3stat/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f69ffb08d88..571a880da02 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -139,6 +139,7 @@
SUBDIR += mp3info
SUBDIR += mp3mover
SUBDIR += mp3rename
+ SUBDIR += mp3stat
SUBDIR += mpegaudio
SUBDIR += mpg123
SUBDIR += mpg123.el
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
new file mode 100644
index 00000000000..41f00b7deab
--- /dev/null
+++ b/audio/mp3stat/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: mp3stat
+# Date created: Mar 20, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3stat
+PORTVERSION= 2.5.2
+CATEGORIES= audio
+MASTER_SITES= http://safemode.homeip.net/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GTK= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,glib-config,${GLIB_CONFIG},g ; \
+ s,gtk-config,${GTK_CONFIG},g ; \
+ s,^CXXFLAGS *=,CXXFLAGS+=,g" ${WRKSRC}/Makefile
+# current vorbis support is broken, dont know how to fix
+ @${PERL} -pi -e "s,^VORBIS,#VORBIS,g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/audio/mp3stat/distinfo b/audio/mp3stat/distinfo
new file mode 100644
index 00000000000..5a9fd03b59b
--- /dev/null
+++ b/audio/mp3stat/distinfo
@@ -0,0 +1 @@
+MD5 (mp3stat_2.5.2.tar.gz) = 1d8aac1dd78928cea869b2d8165ce601
diff --git a/audio/mp3stat/pkg-comment b/audio/mp3stat/pkg-comment
new file mode 100644
index 00000000000..de79d9310c8
--- /dev/null
+++ b/audio/mp3stat/pkg-comment
@@ -0,0 +1 @@
+Read information about mp3s and oggs bitstream
diff --git a/audio/mp3stat/pkg-descr b/audio/mp3stat/pkg-descr
new file mode 100644
index 00000000000..35ebcc3611f
--- /dev/null
+++ b/audio/mp3stat/pkg-descr
@@ -0,0 +1,13 @@
+Mp3stat is a utility to read information about mp3s and oggs bitstream. Most
+specifically, how certain bitrates have been placed in the bitstream by the
+encoder. Not only does mp3stat give you a graphical representation of the
+average bitrate per 1/500th of the file in a linear bar graph to allow you to
+compare encoders and settings, it also has a batch file mode. The batch file
+mode allows you to use mp3stat as a script utility instead of gui, for use in
+your own programs and or scripts. The batch mode can trivially be extended to
+give just as much info as the gui version but now defaults to a configurable
+output of 3 pieces of info, name, runtime, avgerage bitrate. The batch mode
+can take mp3s and oggs in the same directory but it cannot (not yet at least)
+recursively run into subdirectories.
+
+WWW: http://safemode.homeip.net/
diff --git a/audio/mp3stat/pkg-plist b/audio/mp3stat/pkg-plist
new file mode 100644
index 00000000000..2f3e0044c11
--- /dev/null
+++ b/audio/mp3stat/pkg-plist
@@ -0,0 +1 @@
+bin/mp3stat