aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-04-07 23:04:44 +0800
committervanilla <vanilla@FreeBSD.org>2004-04-07 23:04:44 +0800
commit1e621e5612ddee7520c1235a6a44895838b0e09a (patch)
tree8db08604e13cd16783fd99e66fbd29f55a9bf78e
parent0252d012f58604aab4b14a2a7292a9f9eba0976e (diff)
downloadfreebsd-ports-graphics-1e621e5612ddee7520c1235a6a44895838b0e09a.tar.gz
freebsd-ports-graphics-1e621e5612ddee7520c1235a6a44895838b0e09a.tar.zst
freebsd-ports-graphics-1e621e5612ddee7520c1235a6a44895838b0e09a.zip
Add p5-Net-Gopher 1.05, net::Gopher is the Perl Gopher/Gopher+ API.
PR: ports/64972 Submitted by: Toni Viemero <toni.viemero@iki.fi>
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Gopher/Makefile37
-rw-r--r--net/p5-Net-Gopher/distinfo2
-rw-r--r--net/p5-Net-Gopher/files/patch-Makefile.PL11
-rw-r--r--net/p5-Net-Gopher/pkg-descr4
-rw-r--r--net/p5-Net-Gopher/pkg-plist16
6 files changed, 71 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8ce8cbb4565..58f2323fda9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -418,6 +418,7 @@
SUBDIR += p5-Net-Divert
SUBDIR += p5-Net-Finger
SUBDIR += p5-Net-Google
+ SUBDIR += p5-Net-Gopher
SUBDIR += p5-Net-ICQ2000
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-Jabber
diff --git a/net/p5-Net-Gopher/Makefile b/net/p5-Net-Gopher/Makefile
new file mode 100644
index 00000000000..6b31cdf2509
--- /dev/null
+++ b/net/p5-Net-Gopher/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Net-Gopher
+# Date created: 2004-03-31
+# Whom: Toni Viemero <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Gopher
+PORTVERSION= 1.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Net::Gopher is the Perl Gopher/Gopher+ API
+
+RUN_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Gopher.3 \
+ Net::Gopher::Constants.3 \
+ Net::Gopher::Request.3 \
+ Net::Gopher::Response.3 \
+ Net::Gopher::Response::InformationBlock.3 \
+ Net::Gopher::Response::MenuItem.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket.pm:${PORTSDIR}/devel/p5-IO
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Gopher/distinfo b/net/p5-Net-Gopher/distinfo
new file mode 100644
index 00000000000..9a32ad72fc6
--- /dev/null
+++ b/net/p5-Net-Gopher/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Gopher-1.05.tar.gz) = 20f3c1628fed59a2b626c13d5de3589f
+SIZE (Net-Gopher-1.05.tar.gz) = 90018
diff --git a/net/p5-Net-Gopher/files/patch-Makefile.PL b/net/p5-Net-Gopher/files/patch-Makefile.PL
new file mode 100644
index 00000000000..db3b16598d5
--- /dev/null
+++ b/net/p5-Net-Gopher/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Sun Mar 21 19:09:20 2004
++++ Makefile.PL Wed Apr 7 22:56:11 2004
+@@ -7,7 +7,7 @@
+ # don't prompt the user if we're not being called interactively (e.g., if we're
+ # being called from cron or some such program instead of directly by the user):
+ my $interactive = 1;
+-$interactive = 1 if (-t STDIN and -t STDOUT);
++$interactive = 0 if (-t STDIN and -t STDOUT);
+
+ # first, make sure the line endings in the test items are correct:
+ my %files_and_newlines = (
diff --git a/net/p5-Net-Gopher/pkg-descr b/net/p5-Net-Gopher/pkg-descr
new file mode 100644
index 00000000000..77d407f4d52
--- /dev/null
+++ b/net/p5-Net-Gopher/pkg-descr
@@ -0,0 +1,4 @@
+Net::Gopher is the Perl Gopher/Gopher+ API. This library will enable you to
+communicate with Gopher and Gopher+ servers using Perl.
+
+ WWW: http://search.cpan.org/dist/Net-Gopher/
diff --git a/net/p5-Net-Gopher/pkg-plist b/net/p5-Net-Gopher/pkg-plist
new file mode 100644
index 00000000000..46a1e11a2e8
--- /dev/null
+++ b/net/p5-Net-Gopher/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Net/Gopher.pm
+%%SITE_PERL%%/Net/Gopher/Constants.pm
+%%SITE_PERL%%/Net/Gopher/Debugging.pm
+%%SITE_PERL%%/Net/Gopher/Exception.pm
+%%SITE_PERL%%/Net/Gopher/Request.pm
+%%SITE_PERL%%/Net/Gopher/Response.pm
+%%SITE_PERL%%/Net/Gopher/Response/InformationBlock.pm
+%%SITE_PERL%%/Net/Gopher/Response/MenuItem.pm
+%%SITE_PERL%%/Net/Gopher/Utility.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gopher/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gopher
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/Gopher/Response
+@dirrm %%SITE_PERL%%/Net/Gopher
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true