aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-09-10 04:17:39 +0800
committeritetcu <itetcu@FreeBSD.org>2006-09-10 04:17:39 +0800
commit1e7eaf6e308bf08085a70b8b1a9faa0985a2d5c5 (patch)
treee05dfb2a3e8b872cea038545c1b8a9799a5482ad
parent11fc37bd1e837c5e9d1a372f8605dd0230706a73 (diff)
downloadfreebsd-ports-graphics-1e7eaf6e308bf08085a70b8b1a9faa0985a2d5c5.tar.gz
freebsd-ports-graphics-1e7eaf6e308bf08085a70b8b1a9faa0985a2d5c5.tar.zst
freebsd-ports-graphics-1e7eaf6e308bf08085a70b8b1a9faa0985a2d5c5.zip
- upgrade to 1.39.22-20060908
PR: ports/103064 Submitted by: Dan Langille (maintaainer)
-rw-r--r--sysutils/bacula-server-devel/Makefile49
-rw-r--r--sysutils/bacula-server-devel/distinfo6
-rw-r--r--sysutils/bacula-server-devel/files/bacula-dir.sh.in5
-rw-r--r--sysutils/bacula-server-devel/files/bacula-fd.sh.in5
-rw-r--r--sysutils/bacula-server-devel/files/bacula-sd.sh.in7
-rw-r--r--sysutils/bacula-server-devel/files/patch-configure21
-rw-r--r--sysutils/bacula-server-devel/files/patch-scripts-Makefile.in33
-rw-r--r--sysutils/bacula-server-devel/files/pkg-message.in24
-rw-r--r--sysutils/bacula-server-devel/pkg-message17
-rw-r--r--sysutils/bacula-server-devel/pkg-plist33
10 files changed, 92 insertions, 108 deletions
diff --git a/sysutils/bacula-server-devel/Makefile b/sysutils/bacula-server-devel/Makefile
index a72bd993773..dad1eae68f0 100644
--- a/sysutils/bacula-server-devel/Makefile
+++ b/sysutils/bacula-server-devel/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= bacula
-DISTVERSION= 1.38.10-beta1-20060606
+DISTVERSION= 1.39.22-20060908
+
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@@ -21,6 +22,8 @@ UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
USE_RC_SUBR?= bacula-dir.sh bacula-sd.sh
+SUB_FILES+= pkg-message
+
# The user/group IDs below are registered, see
# http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#DADS-UID
#
@@ -84,8 +87,6 @@ USE_GNOME= libgnome
PLIST_SUB+= BACULA_DIR=${BACULA_DIR}
-MAN8= bacula.8
-
.include <bsd.port.pre.mk>
#DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
@@ -160,7 +161,18 @@ CONFIGURE_ARGS+= --with-openssl
.endif
.if defined(WITH_CLIENT_ONLY)
-MAN8=bacula.8
+MAN8=bacula-fd.8 bconsole.8
+.else
+MAN8=bacula-dir.8 bacula-sd.8 bacula.8 bcopy.8 bextract.8 bls.8 bscan.8 btape.8 dbcheck.8
+MAN1=bsmtp.1
+.endif
+
+.if defined(WITH_GNOMECONSOLE)
+ MAN1+=bacula-console-gnome.1
+.endif
+
+.if defined(WITH_WXCONSOLE)
+ MAN1+=bacula-wxconsole.1
.endif
pre-everything::
@@ -220,6 +232,18 @@ pre-install:
.endif
post-install:
+.if defined(MAN8)
+. for manpage in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/manpages/${manpage} ${PREFIX}/man/man8/${manpage}
+. endfor
+.endif
+
+.if defined(MAN1)
+. for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/manpages/${manpage} ${PREFIX}/man/man1/${manpage}
+. endfor
+.endif
+
.if defined(WITH_CLIENT_ONLY)
# Extend only /etc/services
@ ${SETENV} PKG_PREFIX=${PREFIX} \
@@ -227,8 +251,10 @@ post-install:
# Console stuff
if [ -f ${PREFIX}/etc/bconsole.conf.new ]; then \
${ECHO_CMD} "etc/bconsole.conf.new" >> ${TMPPLIST}; \
+ ${CHGRP} bacula ${PREFIX}/etc/bconsole.conf.new; \
elif [ -f ${PREFIX}/etc/bconsole.conf ]; then \
${MV} ${PREFIX}/etc/bconsole.conf ${PREFIX}/etc/bconsole.conf.sample; \
+ ${CHGRP} bacula ${PREFIX}/etc/bconsole.conf.sample; \
${ECHO_CMD} "etc/bconsole.conf.sample" >> ${TMPPLIST}; \
fi
.if defined(WITH_WXCONSOLE)
@@ -248,12 +274,8 @@ post-install:
fi
.endif
-.if defined(WITH_CLIENT_ONLY)
- ${INSTALL_MAN} ${WRKSRC}/scripts/bacula.man ${PREFIX}/man/man8/bacula.8
-.endif
-
# Documentation is only installed in -client port
-.if defined(WITH_DOCS)
+.if !defined(NOPORTDOCS) && defined(WITH_DOCS)
for na in manual bacula-web; do \
${MKDIR} ${DOCSDIR}/$$na ;\
cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && ${FIND} $$na | \
@@ -265,6 +287,8 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/kernstodo ${DOCSDIR}
.endif
+# ensure that users in the bacula group can run bconsole
+ ${CHGRP} bacula ${PREFIX}/sbin/bconsole
.else
# Install config files and preserve existing ones
${INSTALL_SCRIPT} ${FILESDIR}/chio-bacula ${PREFIX}/sbin
@@ -278,6 +302,7 @@ post-install:
# chmod of bsmtp program so bacula can use it with dropped down permissions
${CHMOD} o+x ${PREFIX}/sbin/bsmtp
${CHOWN} -R bacula:bacula ${PREFIX}/share/bacula
+
.endif
# Install leaves existing conf files untouched. Respect this here!
for na in ${CONFFILES}; do \
@@ -339,14 +364,10 @@ post-install:
@${ECHO_MSG} "For USB support read the bacula manual!! It could be necessary"
@${ECHO_MSG} "to configure/compile a new kernel!"
@${ECHO_MSG} ""
- @${ECHO_MSG} "Look at $PREFIX/share/bacula/update_bacula_tables for"
+ @${ECHO_MSG} "Look at ${PREFIX}/share/bacula/update_bacula_tables for"
@${ECHO_MSG} "database update procedure. Details can be found in the"
@${ECHO_MSG} "ReleaseNotes"
.endif
@${ECHO_MSG} "*********************************************************************"
-.if !defined(WITH_CLIENT_ONLY)
- ${CAT} pkg-message
-.endif
-
.include <bsd.port.post.mk>
diff --git a/sysutils/bacula-server-devel/distinfo b/sysutils/bacula-server-devel/distinfo
index f2baab6ac8c..170585a7e14 100644
--- a/sysutils/bacula-server-devel/distinfo
+++ b/sysutils/bacula-server-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (bacula-1.38.10-beta1-20060606.tar.gz) = 2b13e72f29b7e266ffc20df53845752c
-SHA256 (bacula-1.38.10-beta1-20060606.tar.gz) = cf0edbdbf48ce57890d1e29987b6055e11517ed84af9cc8b9278f1114929c086
-SIZE (bacula-1.38.10-beta1-20060606.tar.gz) = 2071197
+MD5 (bacula-1.39.22-20060908.tar.gz) = 9ec36e6c22f8baf086a54407aa18d8e5
+SHA256 (bacula-1.39.22-20060908.tar.gz) = bc6269751d99dcb9a3f2cca8e707b0b2ead85f7282182edce595160d39f02b45
+SIZE (bacula-1.39.22-20060908.tar.gz) = 2359307
diff --git a/sysutils/bacula-server-devel/files/bacula-dir.sh.in b/sysutils/bacula-server-devel/files/bacula-dir.sh.in
index 0c2dc532e66..b91a06eacc7 100644
--- a/sysutils/bacula-server-devel/files/bacula-dir.sh.in
+++ b/sysutils/bacula-server-devel/files/bacula-dir.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-dir.sh.in,v 1.2 2006-04-07 16:34:48 garga Exp $
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-dir.sh.in,v 1.3 2006-09-09 20:17:39 itetcu Exp $
#
# PROVIDE: utility
# REQUIRE: DAEMON %%REQ_MYSQL%% %%REQ_PGSQL%%
@@ -19,10 +19,11 @@
name="bacula_dir"
rcvar=${name}_enable
command=%%PREFIX%%/sbin/bacula-dir
-pidfile="${bacula_dir_pidfile}"
load_rc_config $name
+pidfile="${bacula_dir_pidfile}"
+
: ${bacula_dir_enable="NO"}
: ${bacula_dir_flags=" -u bacula -g bacula -v -c %%PREFIX%%/etc/bacula-dir.conf"}
: ${bacula_dir_pidfile="/var/run/bacula-dir.9101.pid"}
diff --git a/sysutils/bacula-server-devel/files/bacula-fd.sh.in b/sysutils/bacula-server-devel/files/bacula-fd.sh.in
index 845dd93fce4..46c422689ca 100644
--- a/sysutils/bacula-server-devel/files/bacula-fd.sh.in
+++ b/sysutils/bacula-server-devel/files/bacula-fd.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-fd.sh.in,v 1.1 2006-04-01 23:06:24 garga Exp $
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-fd.sh.in,v 1.2 2006-09-09 20:17:39 itetcu Exp $
#
# PROVIDE: utility
# REQUIRE: DAEMON
@@ -19,10 +19,11 @@
name="bacula_fd"
rcvar=${name}_enable
command=/usr/local/sbin/bacula-fd
-pidfile="${bacula_fd_pidfile}"
load_rc_config $name
+pidfile="${bacula_fd_pidfile}"
+
: ${bacula_fd_enable="NO"}
: ${bacula_fd_flags=" -u root -g wheel -v -c /usr/local/etc/bacula-fd.conf"}
: ${bacula_fd_pidfile="/var/run/bacula-fd.9102.pid"}
diff --git a/sysutils/bacula-server-devel/files/bacula-sd.sh.in b/sysutils/bacula-server-devel/files/bacula-sd.sh.in
index 3ced68ab7f7..c4dddc19d4b 100644
--- a/sysutils/bacula-server-devel/files/bacula-sd.sh.in
+++ b/sysutils/bacula-server-devel/files/bacula-sd.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-sd.sh.in,v 1.2 2006-04-07 16:34:48 garga Exp $
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-sd.sh.in,v 1.3 2006-09-09 20:17:39 itetcu Exp $
#
# PROVIDE: utility
# REQUIRE: DAEMON
@@ -19,12 +19,13 @@
name="bacula_sd"
rcvar=`set_rcvar`
command=/usr/local/sbin/bacula-sd
-pidfile="${bacula_sd_pidfile}"
load_rc_config $name
+pidfile="${bacula_sd_pidfile}"
+
: ${bacula_sd_enable="NO"}
-: ${bacula_sd_flags=" -u bacula -g operator -v -c /usr/local/etc/bacula-sd.conf"}
+: ${bacula_sd_flags=" -u bacula -g bacula -v -c /usr/local/etc/bacula-sd.conf"}
: ${bacula_sd_pidfile="/var/run/bacula-sd.9103.pid"}
run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/patch-configure b/sysutils/bacula-server-devel/files/patch-configure
deleted file mode 100644
index f370488bbc4..00000000000
--- a/sysutils/bacula-server-devel/files/patch-configure
+++ /dev/null
@@ -1,21 +0,0 @@
-*** configure.org Sun Mar 6 16:46:54 2005
---- configure Sun Mar 6 16:49:20 2005
-***************
-*** 29490,29497 ****
- DISTVER=`uname -a |awk '{print $3}'`
- VER=`echo $DISTVER | cut -c 1`
- if test x$VER = x4 ; then
-! PTHREAD_LIB="-pthread"
-! CFLAGS="${CFLAGS} -pthread"
- fi
- lld="qd"
- llu="qu"
---- 21037,21044 ----
- DISTVER=`uname -a |awk '{print $3}'`
- VER=`echo $DISTVER | cut -c 1`
- if test x$VER = x4 ; then
-! PTHREAD_LIB="${PTHREAD_LIBS}"
-! CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
- fi
- lld="qd"
- llu="qu"
diff --git a/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in b/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in
deleted file mode 100644
index eeb841f253d..00000000000
--- a/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- scripts/Makefile.in.orig Sat Mar 25 10:37:41 2006
-+++ scripts/Makefile.in Thu Mar 30 13:01:21 2006
-@@ -33,14 +33,6 @@
- $(MKDIR) $(DESTDIR)$(mandir)
-
- install: installdirs
-- $(INSTALL_SCRIPT) startmysql $(DESTDIR)$(scriptdir)/startmysql
-- $(INSTALL_SCRIPT) stopmysql $(DESTDIR)$(scriptdir)/stopmysql
-- $(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
-- $(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
-- $(INSTALL_SCRIPT) bacula $(DESTDIR)$(scriptdir)/bacula
-- $(INSTALL_SCRIPT) bacula-ctl-dir $(DESTDIR)$(scriptdir)/bacula-ctl-dir
-- $(INSTALL_SCRIPT) bacula-ctl-fd $(DESTDIR)$(scriptdir)/bacula-ctl-fd
-- $(INSTALL_SCRIPT) bacula-ctl-sd $(DESTDIR)$(scriptdir)/bacula-ctl-sd
- @if test -f ${DESTDIR}${scriptdir}/mtx-changer; then \
- echo " ==> Saving existing mtx-changer to mtx-changer.old"; \
- $(MV) -f ${DESTDIR}${scriptdir}/mtx-changer ${DESTDIR}${scriptdir}/mtx-changer.old; \
-@@ -56,14 +48,7 @@
- $(MV) -f ${DESTDIR}${scriptdir}/dvd-handler ${DESTDIR}${scriptdir}/dvd-handler.old; \
- fi
- $(INSTALL_SCRIPT) dvd-handler $(DESTDIR)$(scriptdir)/dvd-handler
-- $(INSTALL_DATA) btraceback.gdb $(DESTDIR)$(scriptdir)/btraceback.gdb
-- $(INSTALL_DATA) btraceback.dbx $(DESTDIR)$(scriptdir)/btraceback.dbx
-- chmod 0644 $(DESTDIR)$(scriptdir)/btraceback.gdb \
-- $(DESTDIR)$(scriptdir)/btraceback.dbx
-- $(INSTALL_SCRIPT) btraceback $(DESTDIR)$(sbindir)/btraceback
-- gzip <bacula.man >bacula.8.gz
-- $(INSTALL_DATA) bacula.8.gz $(DESTDIR)$(mandir)/bacula.8.gz
-- @rm -f bacula.8.gz
-+ $(INSTALL_DATA) bacula.man $(DESTDIR)$(mandir)/bacula.8
-
-
- uninstall:
diff --git a/sysutils/bacula-server-devel/files/pkg-message.in b/sysutils/bacula-server-devel/files/pkg-message.in
new file mode 100644
index 00000000000..90be917c612
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/pkg-message.in
@@ -0,0 +1,24 @@
+################################################################################
+ Please read this file:
+
+ %%DOCSDIR%%/ReleaseNotes
+
+ for the upgrade procedure!
+
+ IF YOU IGNORE THIS you may !! LOSE DATA !!
+
+IMPORTANT UPGRADE NOTES:
+
+- A database upgrade is required.
+- Your Director and SD must be simultaneously upgraded.
+- The "Accept Any Volume" directive has been removed.
+
+- Lots of new features
+
+Read the ReleaseNotes for further information.
+
+ Please note that bacula-server no longer installs the client
+ and that the documentation can be optionally installed with the
+ client port (sysutils/bacula-client).
+
+################################################################################
diff --git a/sysutils/bacula-server-devel/pkg-message b/sysutils/bacula-server-devel/pkg-message
deleted file mode 100644
index f0f0db38894..00000000000
--- a/sysutils/bacula-server-devel/pkg-message
+++ /dev/null
@@ -1,17 +0,0 @@
-################################################################################
- Please read the file"
-
- ${DOCSDIR}/ReleaseNotes"
-
- for the upgrade procedure!
-
- IF YOU IGNORE THIS you may !! LOSE DATA !!
-
- For USB support read the manual. It could be necessary
- to configure/compile a new kernel!
-
- Please note that bacula-server-devel no longer installs the client
- and that the documentation could be optional installed with the
- client port (see port sysutils/bacula-client-devel)!
-
-################################################################################
diff --git a/sysutils/bacula-server-devel/pkg-plist b/sysutils/bacula-server-devel/pkg-plist
index 9f07f77ff5c..a3d67015b39 100644
--- a/sysutils/bacula-server-devel/pkg-plist
+++ b/sysutils/bacula-server-devel/pkg-plist
@@ -1,5 +1,3 @@
-%%DATADIR%%/query.sql
-sbin/chio-bacula
sbin/bacula-dir
sbin/bacula-sd
sbin/bcopy
@@ -7,31 +5,40 @@ sbin/bextract
sbin/bls
sbin/bregex
sbin/bscan
+sbin/bsmtp
sbin/btape
+sbin/btraceback
sbin/bwild
-%%WXCONS%%sbin/wx-console
-%%GNOMECONS%%sbin/gnome-console
+sbin/chio-bacula
sbin/dbcheck
-sbin/bsmtp
-@unexec if cmp -s %D/share/bacula/mtx-changer.old %D/share/bacula/mtx-changer; then rm -f %D/share/bacula/mtx-changer.old; fi
-@unexec if cmp -s %D/share/bacula/disk-changer.old %D/share/bacula/disk-changer; then rm -f %D/share/bacula/disk-changer.old; fi
-%%DATADIR%%/mtx-changer
+%%DATADIR%%/bacula
+%%DATADIR%%/bacula-ctl-dir
+%%DATADIR%%/bacula-ctl-fd
+%%DATADIR%%/bacula-ctl-sd
+%%DATADIR%%/bconsole
+%%DATADIR%%/btraceback.gdb
+%%DATADIR%%/btraceback.dbx
%%DATADIR%%/create_bacula_database
%%DATADIR%%/create_%%DBTYPE%%_database
+%%DATADIR%%/delete_catalog_backup
+%%DATADIR%%/disk-changer
%%DATADIR%%/drop_bacula_database
-%%DATADIR%%/drop_%%DBTYPE%%_database
%%DATADIR%%/drop_bacula_tables
+%%DATADIR%%/drop_%%DBTYPE%%_database
%%DATADIR%%/drop_%%DBTYPE%%_tables
+%%DATADIR%%/dvd-handler
+%%DATADIR%%/gconsole
%%DATADIR%%/grant_bacula_privileges
%%DATADIR%%/grant_%%DBTYPE%%_privileges
%%DATADIR%%/make_bacula_tables
+%%DATADIR%%/make_catalog_backup
%%DATADIR%%/make_%%DBTYPE%%_tables
+%%DATADIR%%/mtx-changer
+%%DATADIR%%/query.sql
+%%DATADIR%%/startmysql
+%%DATADIR%%/stopmysql
%%DATADIR%%/update_bacula_tables
%%DATADIR%%/update_%%DBTYPE%%_tables
-%%DATADIR%%/delete_catalog_backup
-%%DATADIR%%/make_catalog_backup
-%%DATADIR%%/dvd-handler
-%%DATADIR%%/disk-changer
@dirrm %%DATADIR%%
@unexec /usr/bin/killall bacula-sd > /dev/null 2>&1 || true