aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-19 18:02:33 +0800
committermakc <makc@FreeBSD.org>2010-12-19 18:02:33 +0800
commit1ea64d8cd32634add03b26dd742fe898e3a4a857 (patch)
tree27245007a7399423d0e09ee0a665b1b30448f292
parent1bd57fbcf1e592844b91e841df9df0b9fae1cb03 (diff)
downloadfreebsd-ports-graphics-1ea64d8cd32634add03b26dd742fe898e3a4a857.tar.gz
freebsd-ports-graphics-1ea64d8cd32634add03b26dd742fe898e3a4a857.tar.zst
freebsd-ports-graphics-1ea64d8cd32634add03b26dd742fe898e3a4a857.zip
Remove IGNORE, scilab port was fixed.
Add patch to fix build with OpenCV 2.1 Remove md5 checksum
-rw-r--r--math/scilab-toolbox-sivp/Makefile2
-rw-r--r--math/scilab-toolbox-sivp/distinfo1
-rw-r--r--math/scilab-toolbox-sivp/files/patch-sci_gateway__c__detectforeground.c11
3 files changed, 11 insertions, 3 deletions
diff --git a/math/scilab-toolbox-sivp/Makefile b/math/scilab-toolbox-sivp/Makefile
index 95d20bb8797..e9c570f152d 100644
--- a/math/scilab-toolbox-sivp/Makefile
+++ b/math/scilab-toolbox-sivp/Makefile
@@ -18,8 +18,6 @@ BUILD_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
LIB_DEPENDS= cv.2:${PORTSDIR}/graphics/opencv
RUN_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
-IGNORE= touches ${LOCALBASE}/share/scilab when building under superuser
-
USE_ZIP= yes
SCILAB_CMD= ${LOCALBASE}/bin/scilab
diff --git a/math/scilab-toolbox-sivp/distinfo b/math/scilab-toolbox-sivp/distinfo
index bfd2f0e762e..00eda8626a4 100644
--- a/math/scilab-toolbox-sivp/distinfo
+++ b/math/scilab-toolbox-sivp/distinfo
@@ -1,3 +1,2 @@
-MD5 (sivp-0.5.2.zip) = bfcd9c4d5c45f8759018e97dacecc046
SHA256 (sivp-0.5.2.zip) = cf3106d42861d54e434806840170f370cfbc3e023602d095c20032c3de8957a4
SIZE (sivp-0.5.2.zip) = 5769590
diff --git a/math/scilab-toolbox-sivp/files/patch-sci_gateway__c__detectforeground.c b/math/scilab-toolbox-sivp/files/patch-sci_gateway__c__detectforeground.c
new file mode 100644
index 00000000000..da5423de525
--- /dev/null
+++ b/math/scilab-toolbox-sivp/files/patch-sci_gateway__c__detectforeground.c
@@ -0,0 +1,11 @@
+--- ./sci_gateway/c/detectforeground.c.orig 2010-01-31 15:21:14.000000000 +0300
++++ ./sci_gateway/c/detectforeground.c 2010-12-19 12:25:28.752039065 +0300
+@@ -93,7 +93,7 @@
+ //foreground detection
+ else
+ {
+- cvUpdateBGStatModel(pSrcImg, bg_model);
++ cvUpdateBGStatModel(pSrcImg, bg_model, -1);
+
+ IplImg2Mat(bg_model->foreground, Rhs+1);
+ }