aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-31 22:58:33 +0800
committermarino <marino@FreeBSD.org>2014-05-31 22:58:33 +0800
commit1eb279e9778511bf480aa44cfd3a7dd4113ef3d3 (patch)
tree303e0f512266ab0de90690df1a9fae5abe400481
parent451d9e12fd71c4903aecd310f484607d3af2dab4 (diff)
downloadfreebsd-ports-graphics-1eb279e9778511bf480aa44cfd3a7dd4113ef3d3.tar.gz
freebsd-ports-graphics-1eb279e9778511bf480aa44cfd3a7dd4113ef3d3.tar.zst
freebsd-ports-graphics-1eb279e9778511bf480aa44cfd3a7dd4113ef3d3.zip
devel/cvs2svn: Replace EXTRACT_CMD with TAR
This port has distfiles of two formats: .tar.bz2 and .tar.gz. The TAR command handles both of them, so explicit specify this tool to ensure the port continues to work in the future. As a comment, it's strange that a custom extract target is needed to overcome a possible deficiency in the standard extract target.
-rw-r--r--devel/cvs2svn/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/cvs2svn/Makefile b/devel/cvs2svn/Makefile
index 7f60406f326..5b3f1eec666 100644
--- a/devel/cvs2svn/Makefile
+++ b/devel/cvs2svn/Makefile
@@ -81,7 +81,7 @@ do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
@-for f in ${EXTRACT_ONLY}; do \
- if ! (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS});\
+ if ! (cd ${WRKDIR} && ${TAR} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS});\
then \
exit 1; \
fi; \