aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-10-12 19:33:38 +0800
committermat <mat@FreeBSD.org>2004-10-12 19:33:38 +0800
commit1fa3c9eefb862f0706867794eb8de2f1c3aec732 (patch)
tree5d0829819d53e218e722b8eb5273d8504e6f0cd0
parent603f1015cedff2ef90d2a085d063270691b34c7c (diff)
downloadfreebsd-ports-graphics-1fa3c9eefb862f0706867794eb8de2f1c3aec732.tar.gz
freebsd-ports-graphics-1fa3c9eefb862f0706867794eb8de2f1c3aec732.tar.zst
freebsd-ports-graphics-1fa3c9eefb862f0706867794eb8de2f1c3aec732.zip
Add p5-MasonX-Profiler 0.06, mason per-component profiler.
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-MasonX-Profiler/Makefile33
-rw-r--r--www/p5-MasonX-Profiler/distinfo2
-rw-r--r--www/p5-MasonX-Profiler/pkg-descr18
-rw-r--r--www/p5-MasonX-Profiler/pkg-plist5
5 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 56058129606..528ad678be2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -499,6 +499,7 @@
SUBDIR += p5-LWP-Authen-Wsse
SUBDIR += p5-MasonX-Apache2Handler
SUBDIR += p5-MasonX-Interp-WithCallbacks
+ SUBDIR += p5-MasonX-Profiler
SUBDIR += p5-MasonX-Request-WithApacheSession
SUBDIR += p5-Maypole
SUBDIR += p5-Maypole-Authentication-UserSessionCookie
diff --git a/www/p5-MasonX-Profiler/Makefile b/www/p5-MasonX-Profiler/Makefile
new file mode 100644
index 00000000000..352d5e063ee
--- /dev/null
+++ b/www/p5-MasonX-Profiler/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-MasonX-Profiler
+# Date created: 20 Sep 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= MasonX-Profiler
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MasonX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Mason per-component profiler
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MasonX::Profiler.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-Class-Container whichs needs perl 5.6.x or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-MasonX-Profiler/distinfo b/www/p5-MasonX-Profiler/distinfo
new file mode 100644
index 00000000000..69e82f63045
--- /dev/null
+++ b/www/p5-MasonX-Profiler/distinfo
@@ -0,0 +1,2 @@
+MD5 (MasonX-Profiler-0.06.tar.gz) = b6ee67e94723ea6041d8efac6c09832e
+SIZE (MasonX-Profiler-0.06.tar.gz) = 10858
diff --git a/www/p5-MasonX-Profiler/pkg-descr b/www/p5-MasonX-Profiler/pkg-descr
new file mode 100644
index 00000000000..4035f88eee7
--- /dev/null
+++ b/www/p5-MasonX-Profiler/pkg-descr
@@ -0,0 +1,18 @@
+This module prints per-component profiling information to STDERR (usually
+ directed to the Apache error log). Its output looks like this:
+
+ =Mason= 127.0.0.1 - /NoAuth/webrt.css BEGINS {{{
+ =Mason= 127.0.0.1 - /NoAuth/webrt.css {{{
+ =Mason= 127.0.0.1 - /Elements/Callback {{{
+ =Mason= 127.0.0.1 - /Elements/Callback }}} 0.0008
+ =Mason= 127.0.0.1 - /NoAuth/webrt.css }}} 0.0072
+ =Mason= 127.0.0.1 - /NoAuth/webrt.css }}} ENDS
+
+Each row contains five whitespace-separated fields: =Mason=, remote IP address,
+-, indented component name, and how many seconds did it take to process that
+component, including all subcomponents called by it.
+
+The beginning and end of the initial request is represented by the special time
+fields BEGINS and ENDS.
+
+WWW: http://search.cpan.org/dist/MasonX-Profiler/
diff --git a/www/p5-MasonX-Profiler/pkg-plist b/www/p5-MasonX-Profiler/pkg-plist
new file mode 100644
index 00000000000..8faa3d9086b
--- /dev/null
+++ b/www/p5-MasonX-Profiler/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/MasonX/Profiler.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MasonX/Profiler/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MasonX/Profiler
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/MasonX 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/MasonX 2>/dev/null || true