aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-23 23:44:05 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-23 23:44:05 +0800
commit21aa839afbab917226a1e153462a52298ec959e2 (patch)
tree7121fc2d344db74aa569be9292f456650fed99ba
parent76e9b13e8de24d96fa87d9134059e60c086a8105 (diff)
downloadfreebsd-ports-graphics-21aa839afbab917226a1e153462a52298ec959e2.tar.gz
freebsd-ports-graphics-21aa839afbab917226a1e153462a52298ec959e2.tar.zst
freebsd-ports-graphics-21aa839afbab917226a1e153462a52298ec959e2.zip
- Add nghttp2 0.3.1
nghttp2 - HTTP/2.0 C Library This is an experimental implementation of Hypertext Transfer Protocol version 2.0. WWW: http://tatsuhiro-t.github.io/nghttp2/
-rw-r--r--www/Makefile1
-rw-r--r--www/nghttp2/Makefile44
-rw-r--r--www/nghttp2/distinfo2
-rw-r--r--www/nghttp2/pkg-descr6
-rw-r--r--www/nghttp2/pkg-plist11
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 31dd843cc61..7d444ae83aa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -566,6 +566,7 @@
SUBDIR += netstiff
SUBDIR += netsurf
SUBDIR += newsbeuter
+ SUBDIR += nghttp2
SUBDIR += nginx
SUBDIR += nginx-devel
SUBDIR += nibbleblog
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
new file mode 100644
index 00000000000..f2e6e8367cc
--- /dev/null
+++ b/www/nghttp2/Makefile
@@ -0,0 +1,44 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nghttp2
+PORTVERSION= 0.3.1
+CATEGORIES= www net
+MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= HTTP/2.0 C Library
+
+LICENSE= MIT
+
+LIB_DEPENDS= libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
+ libjansson.so:${PORTSDIR}/devel/jansson \
+ libspdylay.so:${PORTSDIR}/www/spdylay
+
+CONFIGURE_ARGS= --disable-python-bindings \
+ --enable-app \
+ --enable-examples
+CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
+ ZLIB_CFLAGS="-I${INCLUDEDIR}" \
+ ZLIB_LIBS="-L${LIBDIR} -lz"
+GNU_CONFIGURE= yes
+USE_CXXSTD= c++11
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+USE_XZ= yes
+USES= compiler:c++11-lang pathfix pkgconfig
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
+IGNORE= nghttp2 requires OpenSSL 1.0.1+
+.endif
+
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/lib/.libs/libnghttp2.so.2
+
+.include <bsd.port.post.mk>
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
new file mode 100644
index 00000000000..d03245619c5
--- /dev/null
+++ b/www/nghttp2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nghttp2-0.3.1.tar.xz) = 3ee03cc6fe9f01fd0e95dccca14158ab7fecb9ff623fe4f436bdd8d9eb91de60
+SIZE (nghttp2-0.3.1.tar.xz) = 699464
diff --git a/www/nghttp2/pkg-descr b/www/nghttp2/pkg-descr
new file mode 100644
index 00000000000..f50bb283892
--- /dev/null
+++ b/www/nghttp2/pkg-descr
@@ -0,0 +1,6 @@
+nghttp2 - HTTP/2.0 C Library
+
+This is an experimental implementation of Hypertext Transfer Protocol version
+2.0.
+
+WWW: http://tatsuhiro-t.github.io/nghttp2/
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
new file mode 100644
index 00000000000..2b293642eed
--- /dev/null
+++ b/www/nghttp2/pkg-plist
@@ -0,0 +1,11 @@
+bin/nghttp
+bin/nghttpd
+bin/nghttpx
+include/nghttp2/nghttp2.h
+include/nghttp2/nghttp2ver.h
+lib/libnghttp2.a
+lib/libnghttp2.la
+lib/libnghttp2.so
+lib/libnghttp2.so.2
+libdata/pkgconfig/libnghttp2.pc
+@dirrm include/nghttp2