aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-08-07 14:48:38 +0800
committerskv <skv@FreeBSD.org>2003-08-07 14:48:38 +0800
commit21fd1ddbae8d74a64b587a03f554901789dae03a (patch)
treee1845272263365f778c42f989ca6ae2a3dfb08e2
parent35f8817120ae17ee36fdc049e8679ac36dded4a5 (diff)
downloadfreebsd-ports-graphics-21fd1ddbae8d74a64b587a03f554901789dae03a.tar.gz
freebsd-ports-graphics-21fd1ddbae8d74a64b587a03f554901789dae03a.tar.zst
freebsd-ports-graphics-21fd1ddbae8d74a64b587a03f554901789dae03a.zip
Add p5-Sys-Mmap 0.11, map in a file as a Perl variable using mmap(2).
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sys-Mmap/Makefile22
-rw-r--r--devel/p5-Sys-Mmap/distinfo1
-rw-r--r--devel/p5-Sys-Mmap/pkg-descr13
-rw-r--r--devel/p5-Sys-Mmap/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ee224bce4e9..8dcda45bb67 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -724,6 +724,7 @@
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
SUBDIR += p5-Sub-Uplevel
+ SUBDIR += p5-Sys-Mmap
SUBDIR += p5-System2
SUBDIR += p5-Term-ANSIColor
SUBDIR += p5-Term-ANSIScreen
diff --git a/devel/p5-Sys-Mmap/Makefile b/devel/p5-Sys-Mmap/Makefile
new file mode 100644
index 00000000000..37942d73780
--- /dev/null
+++ b/devel/p5-Sys-Mmap/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Sys-Mmap
+# Date created: 25 July 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Mmap
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Map in a file as a Perl variable using mmap(2)
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Mmap.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sys-Mmap/distinfo b/devel/p5-Sys-Mmap/distinfo
new file mode 100644
index 00000000000..bcd94981960
--- /dev/null
+++ b/devel/p5-Sys-Mmap/distinfo
@@ -0,0 +1 @@
+MD5 (Sys-Mmap-0.11.tar.gz) = a060000bf162555fb7151ae5f2bf79f3
diff --git a/devel/p5-Sys-Mmap/pkg-descr b/devel/p5-Sys-Mmap/pkg-descr
new file mode 100644
index 00000000000..59238920b67
--- /dev/null
+++ b/devel/p5-Sys-Mmap/pkg-descr
@@ -0,0 +1,13 @@
+The Mmap module lets you use mmap to map in a file as a Perl variable
+rather than reading the file into dynamically allocated memory.
+
+The advantage of this is that several processes may share one copy of
+the file or string, saving memory, and concurrently making changes to
+portions of the file or string. When not used with a file, it is an
+alternative to SysV shared memory that places no arbitrary size limits
+on the shared memory area, and efficiently handles sparse memory usage.
+
+WWW: http://search.cpan.org/dist/Sys-Mmap/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Sys-Mmap/pkg-plist b/devel/p5-Sys-Mmap/pkg-plist
new file mode 100644
index 00000000000..c7c2b455825
--- /dev/null
+++ b/devel/p5-Sys-Mmap/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Mmap/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Sys/Mmap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Mmap/Mmap.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Mmap/Mmap.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Mmap
+@unexec rmdir %D/%%SITE_PERL%%/Sys 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys 2>/dev/null || true