aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2006-12-09 05:50:20 +0800
committeralexbl <alexbl@FreeBSD.org>2006-12-09 05:50:20 +0800
commit2345d5819866e18257c97d92f95d297a3881f414 (patch)
treee5aeeee38a7c952cb59cf8045f7e925ba8b93799
parent0b9acaedb5ca4c4895e77ec5962c54337476b866 (diff)
downloadfreebsd-ports-graphics-2345d5819866e18257c97d92f95d297a3881f414.tar.gz
freebsd-ports-graphics-2345d5819866e18257c97d92f95d297a3881f414.tar.zst
freebsd-ports-graphics-2345d5819866e18257c97d92f95d297a3881f414.zip
- Mark devel/py-ctypes IGNORE with Python 2.5 [1]
- add a PYCTYPES dependency macro to bsd.python.mk to unbreak ctypes using ports on Python 2.5 [2] - Update two of the four ports using ctypes to this macro [3] PR: 104587 [1] Submitted by: Marcus von Appen <mva@sysfault.org> [1] Approved by: portmgr (pav, linimon) [2], myself [3]
-rw-r--r--Mk/bsd.python.mk12
-rw-r--r--audio/py-libtunepimp/Makefile4
-rw-r--r--audio/py-musicbrainz2/Makefile4
-rw-r--r--devel/py-ctypes/Makefile8
4 files changed, 23 insertions, 5 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 1e5e354fdd0..6c02eb096d7 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -104,6 +104,12 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYXML - Dependency line for the XML extension. As of Python-2.0,
# this extension is in the base distribution.
#
+# PYEXPAT - Dependency line for the Expat XML Parser. As of Python-2.3.2,
+# this module is in the base distribution.
+#
+# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -429,6 +435,12 @@ PYEXPAT= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
PYEXPAT= ${PYTHON_LIBDIR}/lib-dynload/pyexpat.so:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
+.else
+PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__py:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO
diff --git a/audio/py-libtunepimp/Makefile b/audio/py-libtunepimp/Makefile
index e0a7406185d..53fbcb5e279 100644
--- a/audio/py-libtunepimp/Makefile
+++ b/audio/py-libtunepimp/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Python bindings for libtunepimp
-BUILD_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
-RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
+BUILD_DEPENDS= ${PYCTYPES}
+RUN_DEPENDS= ${PYCTYPES}
LIB_DEPENDS= tunepimp.5:${PORTSDIR}/audio/libtunepimp
USE_PYTHON= yes
diff --git a/audio/py-musicbrainz2/Makefile b/audio/py-musicbrainz2/Makefile
index d540709333a..fbc3907a290 100644
--- a/audio/py-musicbrainz2/Makefile
+++ b/audio/py-musicbrainz2/Makefile
@@ -15,8 +15,8 @@ DISTNAME= python-musicbrainz2-${DISTVERSION}
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Next Generation Python bindings for MusicBrainz
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
+BUILD_DEPENDS= ${PYCTYPES}
+RUN_DEPENDS= ${PYCTYPES}
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
USE_PYTHON= yes
diff --git a/devel/py-ctypes/Makefile b/devel/py-ctypes/Makefile
index a1b9a5ab54a..f88f0284f76 100644
--- a/devel/py-ctypes/Makefile
+++ b/devel/py-ctypes/Makefile
@@ -19,4 +19,10 @@ USE_PYDISTUTILS=yes
ONLY_FOR_ARCHS= i386 amd64 alpha powerpc sparc64
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 250
+IGNORE= ctypes ships with Python 2.5.x
+.endif
+
+.include <bsd.port.post.mk>