aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-15 22:04:12 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-15 22:04:12 +0800
commit2389ff8883f8140451584813c36573a1a87d43f4 (patch)
tree1940d4393aa81eced1bbd43b7fdcaf48feee026f
parent4511a210dc4f3e2277d59ea2084b30fe6a68b63f (diff)
downloadfreebsd-ports-graphics-2389ff8883f8140451584813c36573a1a87d43f4.tar.gz
freebsd-ports-graphics-2389ff8883f8140451584813c36573a1a87d43f4.tar.zst
freebsd-ports-graphics-2389ff8883f8140451584813c36573a1a87d43f4.zip
1: Stagify.
2: add depends to perl5. Approved by: portmgr@
-rw-r--r--games/gnarr/Makefile6
-rw-r--r--games/gnarr/files/patch-Makefile21
-rw-r--r--games/gnarr/pkg-plist1
3 files changed, 25 insertions, 3 deletions
diff --git a/games/gnarr/Makefile b/games/gnarr/Makefile
index 3e7ac88d115..c38563fe74e 100644
--- a/games/gnarr/Makefile
+++ b/games/gnarr/Makefile
@@ -3,15 +3,15 @@
PORTNAME= gnarr
PORTVERSION= 3
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.volny.cz/nakamura/gnarr/
MAINTAINER= daniel.ryslink@dialtelecom.cz
COMMENT= Program for generating battle cries
-MAN6= gnarr.6
-
NO_BUILD= yes
+USES= perl5 shebangfix
+SHEBANG_FILES= gnarr
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/gnarr/files/patch-Makefile b/games/gnarr/files/patch-Makefile
new file mode 100644
index 00000000000..c34d2f50a85
--- /dev/null
+++ b/games/gnarr/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2014-06-15 18:04:50.966372146 +0800
++++ Makefile 2014-06-15 18:05:31.349376790 +0800
+@@ -20,12 +20,12 @@ RM ?= rm -f
+ all:
+
+ install:
+- ${MKDIR} ${BINDIR}
+- ${INSTALL_PROGRAM} gnarr ${BINDIR}
+- ${MKDIR} ${ETCDIR}
+- ${INSTALL_DATA} etc/gnarr/* ${ETCDIR}
+- ${MKDIR} ${MAN6DIR}
+- ${INSTALL_DATA} gnarr.6 ${MAN6DIR}
++ ${MKDIR} $(DESTDIR)${BINDIR}
++ ${INSTALL_PROGRAM} gnarr $(DESTDIR)${BINDIR}
++ ${MKDIR} $(DESTDIR)${ETCDIR}
++ ${INSTALL_DATA} etc/gnarr/* $(DESTDIR)${ETCDIR}
++ ${MKDIR} $(DESTDIR)${MAN6DIR}
++ ${INSTALL_DATA} gnarr.6 $(DESTDIR)${MAN6DIR}
+
+ clean:
+
diff --git a/games/gnarr/pkg-plist b/games/gnarr/pkg-plist
index 7b5b1a7caa6..7b4cc06e043 100644
--- a/games/gnarr/pkg-plist
+++ b/games/gnarr/pkg-plist
@@ -15,4 +15,5 @@ etc/gnarr/place
etc/gnarr/templates
etc/gnarr/time
etc/gnarr/weapon
+man/man6/gnarr.6.gz
@dirrm etc/gnarr