aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-29 20:22:41 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-29 20:22:41 +0800
commit23aac5734c76114bc0bb997aeb68ff4a8a3d1f2b (patch)
tree5d97a2d1a13090258047b002935583b222610df1
parentfd0c0170147168ad77b5dd5c17b60c481a7ec95e (diff)
downloadfreebsd-ports-graphics-23aac5734c76114bc0bb997aeb68ff4a8a3d1f2b.tar.gz
freebsd-ports-graphics-23aac5734c76114bc0bb997aeb68ff4a8a3d1f2b.tar.zst
freebsd-ports-graphics-23aac5734c76114bc0bb997aeb68ff4a8a3d1f2b.zip
- backout last fix
Acording to submitter the last version does not work. Submitted by: Dominic Fandrey
-rw-r--r--graphics/imlib2/Makefile2
-rw-r--r--graphics/imlib2/files/patch-loader_png.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index d482b1c1dca..24055314dc3 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.4.1.000
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
diff --git a/graphics/imlib2/files/patch-loader_png.c b/graphics/imlib2/files/patch-loader_png.c
index 12496196943..5444c6260ba 100644
--- a/graphics/imlib2/files/patch-loader_png.c
+++ b/graphics/imlib2/files/patch-loader_png.c
@@ -5,7 +5,7 @@
/* if we haven't read the header before, set the header data */
fread(buf, 1, PNG_BYTES_TO_CHECK, f);
- if (!png_check_sig(buf, PNG_BYTES_TO_CHECK))
-+ if (png_check_sig(buf, 0, PNG_BYTES_TO_CHECK))
++ if (png_check_sig(buf, 0, PNG_BYTES_TO_CHECK) != 0)
{
fclose(f);
return 0;