aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-12 03:55:42 +0800
committererwin <erwin@FreeBSD.org>2006-07-12 03:55:42 +0800
commit264cdbf9cb630200462d3e34b8c953f94e19323e (patch)
tree90de53f38bace25820986d2456cb5b948e38cada
parent50df95cfff76ce0b1e64b385f03a915a84c98e72 (diff)
downloadfreebsd-ports-graphics-264cdbf9cb630200462d3e34b8c953f94e19323e.tar.gz
freebsd-ports-graphics-264cdbf9cb630200462d3e34b8c953f94e19323e.tar.zst
freebsd-ports-graphics-264cdbf9cb630200462d3e34b8c953f94e19323e.zip
A module to use your computer beeper in fancy ways.
Author: Giulio Motta <giulienk@cpan.org> WWW: http://search.cpan.org/dist/Audio-Beep/ PR: ports/100092 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-Audio-Beep/Makefile28
-rw-r--r--audio/p5-Audio-Beep/distinfo3
-rw-r--r--audio/p5-Audio-Beep/pkg-descr4
-rw-r--r--audio/p5-Audio-Beep/pkg-plist10
5 files changed, 46 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5d14c8603c6..942065f9c6a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -399,6 +399,7 @@
SUBDIR += orpheus
SUBDIR += osalp
SUBDIR += p5-Audio
+ SUBDIR += p5-Audio-Beep
SUBDIR += p5-Audio-CD
SUBDIR += p5-Audio-Scrobbler
SUBDIR += p5-Audio-TagLib
diff --git a/audio/p5-Audio-Beep/Makefile b/audio/p5-Audio-Beep/Makefile
new file mode 100644
index 00000000000..86c705bb676
--- /dev/null
+++ b/audio/p5-Audio-Beep/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Audio-Beep
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-Beep
+PORTVERSION= 0.11
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Audio
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A module to use your computer beeper in fancy ways
+
+PERL_CONFIGURE= yes
+
+MAN3= Audio::Beep.3 Audio::Beep::BSD::beep.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/p5-Audio-Beep/distinfo b/audio/p5-Audio-Beep/distinfo
new file mode 100644
index 00000000000..838c65622e4
--- /dev/null
+++ b/audio/p5-Audio-Beep/distinfo
@@ -0,0 +1,3 @@
+MD5 (Audio-Beep-0.11.tar.gz) = 6956a8749c8dbdcbd44577f7900e85dc
+SHA256 (Audio-Beep-0.11.tar.gz) = 6f965e66f16b93496b16063c7cd98289c50c429e4f4ac5bd5f199c39e5e93124
+SIZE (Audio-Beep-0.11.tar.gz) = 34318
diff --git a/audio/p5-Audio-Beep/pkg-descr b/audio/p5-Audio-Beep/pkg-descr
new file mode 100644
index 00000000000..e4042c8b76e
--- /dev/null
+++ b/audio/p5-Audio-Beep/pkg-descr
@@ -0,0 +1,4 @@
+A module to use your computer beeper in fancy ways.
+
+Author: Giulio Motta <giulienk@cpan.org>
+WWW: http://search.cpan.org/dist/Audio-Beep/
diff --git a/audio/p5-Audio-Beep/pkg-plist b/audio/p5-Audio-Beep/pkg-plist
new file mode 100644
index 00000000000..15090a5a270
--- /dev/null
+++ b/audio/p5-Audio-Beep/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Beep/.packlist
+%%SITE_PERL%%/Audio/Beep.pm
+%%SITE_PERL%%/Audio/Beep.pod
+%%SITE_PERL%%/Audio/Beep/BSD/beep.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Beep
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio
+@dirrmtry %%SITE_PERL%%/Audio/Beep/BSD
+@dirrmtry %%SITE_PERL%%/Audio/Beep
+@dirrmtry %%SITE_PERL%%/Audio