aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2008-04-15 03:10:08 +0800
committerbrooks <brooks@FreeBSD.org>2008-04-15 03:10:08 +0800
commit270024244e56048a1061192b6f32c48fea2dcedf (patch)
tree4b1c5311e1471edba7948b1523c302281e02ea93
parent5f2e1ea39725a57d71937349cb4adff4e52d138d (diff)
downloadfreebsd-ports-graphics-270024244e56048a1061192b6f32c48fea2dcedf.tar.gz
freebsd-ports-graphics-270024244e56048a1061192b6f32c48fea2dcedf.tar.zst
freebsd-ports-graphics-270024244e56048a1061192b6f32c48fea2dcedf.zip
Add an option to replace qsh with a script that prints an error message
and exist with an error code. This is useful on clusters where qsh is not supported (common since it requires xterm to be installed on each node). Since I did not changed the default, I did not bump PORTREVISION.
-rw-r--r--sysutils/sge61/Makefile6
-rw-r--r--sysutils/sge61/files/qsh-disabled.sh3
-rw-r--r--sysutils/sge62/Makefile6
-rw-r--r--sysutils/sge62/files/qsh-disabled.sh3
4 files changed, 16 insertions, 2 deletions
diff --git a/sysutils/sge61/Makefile b/sysutils/sge61/Makefile
index 540dda68309..24dae6100d2 100644
--- a/sysutils/sge61/Makefile
+++ b/sysutils/sge61/Makefile
@@ -30,7 +30,8 @@ FETCH_CMD= wget -c
OPTIONS= BDB "Use DB based spooler" on \
JAVA "Support Java DRMAA API" on \
- X11 "Qmon X11 GUI" on
+ X11 "Qmon X11 GUI" on \
+ QSH "Enable qsh (requires xterm on exec hosts)" on
LATEST_LINK= sge61
CONFLICTS= sge-6.[02-9]* sge-5* sgeee-[0-9]* sge-0.*
@@ -182,6 +183,9 @@ do-build:
@${MKDIR} ${TMP_SGE_ROOT}
@cd ${WRKSRC} && ${SETENV} SGE_ROOT=${TMP_SGE_ROOT} \
./scripts/distinst -local -libs ${SGE_ARCH} -- ${INST_PROGS}
+.if defined(WITHOUT_QSH)
+ ${INSTALL_SCRIPT} ${FILESDIR}/qsh-disabled.sh ${TMP_SGE_ROOT}/bin/${SGE_ARCH}/qsh
+.endif
.if !defined(WITH_X11)
@${RM} ${TMP_SGE_ROOT}/catman/cat/cat1/qmon.1
@${RM} -r ${TMP_SGE_ROOT}/3rd_party/qmon
diff --git a/sysutils/sge61/files/qsh-disabled.sh b/sysutils/sge61/files/qsh-disabled.sh
new file mode 100644
index 00000000000..1398eec061d
--- /dev/null
+++ b/sysutils/sge61/files/qsh-disabled.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+echo "qsh is not supported on this system" 1>&2
+exit 1
diff --git a/sysutils/sge62/Makefile b/sysutils/sge62/Makefile
index 540dda68309..24dae6100d2 100644
--- a/sysutils/sge62/Makefile
+++ b/sysutils/sge62/Makefile
@@ -30,7 +30,8 @@ FETCH_CMD= wget -c
OPTIONS= BDB "Use DB based spooler" on \
JAVA "Support Java DRMAA API" on \
- X11 "Qmon X11 GUI" on
+ X11 "Qmon X11 GUI" on \
+ QSH "Enable qsh (requires xterm on exec hosts)" on
LATEST_LINK= sge61
CONFLICTS= sge-6.[02-9]* sge-5* sgeee-[0-9]* sge-0.*
@@ -182,6 +183,9 @@ do-build:
@${MKDIR} ${TMP_SGE_ROOT}
@cd ${WRKSRC} && ${SETENV} SGE_ROOT=${TMP_SGE_ROOT} \
./scripts/distinst -local -libs ${SGE_ARCH} -- ${INST_PROGS}
+.if defined(WITHOUT_QSH)
+ ${INSTALL_SCRIPT} ${FILESDIR}/qsh-disabled.sh ${TMP_SGE_ROOT}/bin/${SGE_ARCH}/qsh
+.endif
.if !defined(WITH_X11)
@${RM} ${TMP_SGE_ROOT}/catman/cat/cat1/qmon.1
@${RM} -r ${TMP_SGE_ROOT}/3rd_party/qmon
diff --git a/sysutils/sge62/files/qsh-disabled.sh b/sysutils/sge62/files/qsh-disabled.sh
new file mode 100644
index 00000000000..1398eec061d
--- /dev/null
+++ b/sysutils/sge62/files/qsh-disabled.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+echo "qsh is not supported on this system" 1>&2
+exit 1