aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-12-01 04:45:55 +0800
committerclement <clement@FreeBSD.org>2004-12-01 04:45:55 +0800
commit274a17ef287bd59f4e124a0f1eec95c89a3be62d (patch)
tree27a84ed02ed172d70fe42509ac7361e97a94e442
parentba8d0a99add29436e43e53517a3549afb9503db5 (diff)
downloadfreebsd-ports-graphics-274a17ef287bd59f4e124a0f1eec95c89a3be62d.tar.gz
freebsd-ports-graphics-274a17ef287bd59f4e124a0f1eec95c89a3be62d.tar.zst
freebsd-ports-graphics-274a17ef287bd59f4e124a0f1eec95c89a3be62d.zip
- Add mod_shapvh 1.0, Apache module that provides virtual hosts from a
MySQL database. http://www.crazygreek.co.uk/content/mod_shapvh PR: ports/74038 Submitted by: Steven Looman <steven@krx.nl>
-rw-r--r--CVSROOT/modules1
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_shapvh/Makefile32
-rw-r--r--www/mod_shapvh/distinfo2
-rw-r--r--www/mod_shapvh/pkg-descr6
-rw-r--r--www/mod_shapvh/pkg-plist3
6 files changed, 45 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index 78b4eb6d34d..5741a183bb6 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -5636,6 +5636,7 @@ mod_scgi ports/www/mod_scgi
mod_security ports/www/mod_security
mod_sed ports/www/mod_sed
mod_sequester ports/www/mod_sequester
+mod_shapvh ports/www/mod_shapvh
mod_snake ports/www/mod_snake
mod_sqlinclude ports/www/mod_sqlinclude
mod_throttle ports/www/mod_throttle
diff --git a/www/Makefile b/www/Makefile
index e1179cb7d32..792930ba91c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -314,6 +314,7 @@
SUBDIR += mod_security
SUBDIR += mod_sed
SUBDIR += mod_sequester
+ SUBDIR += mod_shapvh
SUBDIR += mod_snake
SUBDIR += mod_sqlinclude
SUBDIR += mod_throttle
diff --git a/www/mod_shapvh/Makefile b/www/mod_shapvh/Makefile
new file mode 100644
index 00000000000..04b59e69663
--- /dev/null
+++ b/www/mod_shapvh/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mod_shapvh
+# Date created: 17 Nov 2004
+# Whom: Steven Looman <steven@krx.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_shapvh
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.crazygreek.co.uk/downloads/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= steven@krx.nl
+COMMENT= Apache module that provides virtual hosts from a database
+
+USE_APACHE= yes
+USE_MYSQL= yes
+NO_WRKSUBDIR= yes
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c -l mysqlclient -I ${PREFIX}/include -L ${PREFIX}/lib/mysql ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/^mod_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_shapvh/distinfo b/www/mod_shapvh/distinfo
new file mode 100644
index 00000000000..8ce2c94eb30
--- /dev/null
+++ b/www/mod_shapvh/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_shapvh.c) = 6be3fa980c7710c2739dd4cdd3ff79e7
+SIZE (mod_shapvh.c) = 14712
diff --git a/www/mod_shapvh/pkg-descr b/www/mod_shapvh/pkg-descr
new file mode 100644
index 00000000000..d1fe88116cd
--- /dev/null
+++ b/www/mod_shapvh/pkg-descr
@@ -0,0 +1,6 @@
+Shared Apache VirtualHost module.
+
+This module allows you to store your virtual hosts in a database
+and extract them on the fly.
+
+WWW: http://www.crazygreek.co.uk/content/mod_shapvh
diff --git a/www/mod_shapvh/pkg-plist b/www/mod_shapvh/pkg-plist
new file mode 100644
index 00000000000..3b8b695e367
--- /dev/null
+++ b/www/mod_shapvh/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_shapvh.so
+@exec %D/sbin/apxs -e -A -n shapvh %D/%F
+@unexec %D/sbin/apxs -e -A -n shapvh %D/%F