aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-30 05:37:47 +0800
committermiwi <miwi@FreeBSD.org>2008-04-30 05:37:47 +0800
commit288dc564b1c7ed195c57e972ec601a66a3a3e787 (patch)
tree18a99e3cc705152389ceddee42a843fdea6bcc84
parent138f70877f80cfac73647ae09b7b86ec177342cb (diff)
downloadfreebsd-ports-graphics-288dc564b1c7ed195c57e972ec601a66a3a3e787.tar.gz
freebsd-ports-graphics-288dc564b1c7ed195c57e972ec601a66a3a3e787.tar.zst
freebsd-ports-graphics-288dc564b1c7ed195c57e972ec601a66a3a3e787.zip
Rawstudio is an open-source program to read and manipulate
RAW images from most digital cameras. Rawstudio will convert your RAW files into JPEG, PNG or TIF images which you can then print or send to friends and clients. It has a graphical user interface, so you can simply open a RAW file and experiment with the controls to see how they effect the image. WWW: http://rawstudio.org PR: ports/123025 Submitted by: Alex Samorukov <samm at os2.kiev.ua>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rawstudio/Makefile28
-rw-r--r--graphics/rawstudio/distinfo3
-rw-r--r--graphics/rawstudio/pkg-descr8
-rw-r--r--graphics/rawstudio/pkg-plist34
5 files changed, 74 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 04b37e7991d..8e1f294a052 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -655,6 +655,7 @@
SUBDIR += quesa
SUBDIR += qvplay
SUBDIR += raster3d
+ SUBDIR += rawstudio
SUBDIR += ray++
SUBDIR += rayshade
SUBDIR += reallyslick
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
new file mode 100644
index 00000000000..d9de0ad5ab4
--- /dev/null
+++ b/graphics/rawstudio/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rawstudio
+# Date created: 2008-04-23
+# Whom: Alex Samorukov <samm@os2.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rawstudio
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= http://rawstudio.org/files/release/
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Rawstudio is an open-source program to read and manipulate RAW images
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ lcms.1:${PORTSDIR}/graphics/lcms \
+ dbus-1.3:${PORTSDIR}/devel/dbus
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETTEXT= yes
+USE_XLIB= yes
+USE_GNOME= gtk20 libxml2 gconf2
+
+.include <bsd.port.mk>
diff --git a/graphics/rawstudio/distinfo b/graphics/rawstudio/distinfo
new file mode 100644
index 00000000000..5c0ec4e0b42
--- /dev/null
+++ b/graphics/rawstudio/distinfo
@@ -0,0 +1,3 @@
+MD5 (rawstudio-1.0.tar.gz) = 26ddd38ccb5d74f7c7c6759dae13b7ad
+SHA256 (rawstudio-1.0.tar.gz) = 707429a3e1335d03f5d2196ee105d7fb8bf2db6e3c6bdd08c9d1a75e7ec493a9
+SIZE (rawstudio-1.0.tar.gz) = 430154
diff --git a/graphics/rawstudio/pkg-descr b/graphics/rawstudio/pkg-descr
new file mode 100644
index 00000000000..ecdb8b3004e
--- /dev/null
+++ b/graphics/rawstudio/pkg-descr
@@ -0,0 +1,8 @@
+Rawstudio is an open-source program to read and manipulate
+RAW images from most digital cameras. Rawstudio will convert
+your RAW files into JPEG, PNG or TIF images which you can then
+print or send to friends and clients. It has a graphical user
+interface, so you can simply open a RAW file and experiment with
+the controls to see how they effect the image.
+
+WWW: http://rawstudio.org
diff --git a/graphics/rawstudio/pkg-plist b/graphics/rawstudio/pkg-plist
new file mode 100644
index 00000000000..f8b4776bc2a
--- /dev/null
+++ b/graphics/rawstudio/pkg-plist
@@ -0,0 +1,34 @@
+bin/rawstudio
+share/applications/rawstudio.desktop
+share/icons/rawstudio.png
+share/locale/cz/LC_MESSAGES/rawstudio.mo
+share/locale/da/LC_MESSAGES/rawstudio.mo
+share/locale/de/LC_MESSAGES/rawstudio.mo
+share/locale/en/LC_MESSAGES/rawstudio.mo
+share/locale/es/LC_MESSAGES/rawstudio.mo
+share/locale/fi/LC_MESSAGES/rawstudio.mo
+share/locale/fr/LC_MESSAGES/rawstudio.mo
+share/locale/it/LC_MESSAGES/rawstudio.mo
+share/locale/nb/LC_MESSAGES/rawstudio.mo
+share/locale/pl/LC_MESSAGES/rawstudio.mo
+share/locale/ru/LC_MESSAGES/rawstudio.mo
+share/pixmaps/rawstudio/overlay_deleted.png
+share/pixmaps/rawstudio/overlay_exported.png
+share/pixmaps/rawstudio/overlay_priority1.png
+share/pixmaps/rawstudio/overlay_priority2.png
+share/pixmaps/rawstudio/overlay_priority3.png
+share/pixmaps/rawstudio/transform_180.png
+share/pixmaps/rawstudio/transform_270.png
+share/pixmaps/rawstudio/transform_90.png
+share/pixmaps/rawstudio/transform_flip.png
+share/pixmaps/rawstudio/transform_mirror.png
+%%DATADIR%%/rawstudio.gtkrc
+%%DATADIR%%/ui.xml
+@dirrm %%DATADIR%%
+@dirrm share/pixmaps/rawstudio
+@dirrmtry share/locale/cz/LC_MESSAGES
+@dirrmtry share/locale/cz
+@dirrm share/icons
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true