aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-05-24 04:31:00 +0800
committerbeech <beech@FreeBSD.org>2011-05-24 04:31:00 +0800
commit297922349110fc284693912b84f5757b816ab4b9 (patch)
treeb8755c3c03017203d76e29e973f6213d0eefef55
parent55feba30999b583d43fcb62ba5b435fa957ba119 (diff)
downloadfreebsd-ports-graphics-297922349110fc284693912b84f5757b816ab4b9.tar.gz
freebsd-ports-graphics-297922349110fc284693912b84f5757b816ab4b9.tar.zst
freebsd-ports-graphics-297922349110fc284693912b84f5757b816ab4b9.zip
This package provides an Image utility API, with backends for: * GD * GIF * PNG
* SVG * SWF * ImageMagick convert command line tool * Imagick Extension Approved by: itetcu (mentor)(implicit)
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/horde4-image/Makefile43
-rw-r--r--graphics/horde4-image/distinfo2
-rw-r--r--graphics/horde4-image/files/pkg-message.in7
-rw-r--r--graphics/horde4-image/pkg-descr4
-rw-r--r--graphics/horde4-image/pkg-plist61
6 files changed, 118 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2367b40a725..d6f92f69a11 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -323,6 +323,7 @@
SUBDIR += gwenview
SUBDIR += gx
SUBDIR += hobbes-icons-xpm
+ SUBDIR += horde4-image
SUBDIR += hppsmtools
SUBDIR += hs-cairo
SUBDIR += hs-HGL
diff --git a/graphics/horde4-image/Makefile b/graphics/horde4-image/Makefile
new file mode 100644
index 00000000000..fc7aeac0c46
--- /dev/null
+++ b/graphics/horde4-image/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: horde4-image
+# Date created: Mon May 23, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= image
+PORTVERSION= 1.0.1
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= graphics www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= Horde_Image-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Horde Image API, with backends for various image formats
+
+USE_HORDE= base
+USE_GETTEXT= yes
+
+EXTRACT_SUFX= .tgz
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && touch ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${INSTALL} -d ${HORDIR}/
+ @${CP} ${WRKSRC}/lib/Horde/Image.php ${HORBAS}/
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Image/ ${HORDIR}/
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/graphics/horde4-image/distinfo b/graphics/horde4-image/distinfo
new file mode 100644
index 00000000000..773f84c42cc
--- /dev/null
+++ b/graphics/horde4-image/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde_Image-1.0.1.tgz) = 15a1c559434330981ed8bcebdb99c47ea1754ea4989d835e4478645c0aeb7305
+SIZE (Horde_Image-1.0.1.tgz) = 541756
diff --git a/graphics/horde4-image/files/pkg-message.in b/graphics/horde4-image/files/pkg-message.in
new file mode 100644
index 00000000000..61b7771a271
--- /dev/null
+++ b/graphics/horde4-image/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Image has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/graphics/horde4-image/pkg-descr b/graphics/horde4-image/pkg-descr
new file mode 100644
index 00000000000..c5c19cac65d
--- /dev/null
+++ b/graphics/horde4-image/pkg-descr
@@ -0,0 +1,4 @@
+This package provides an Image utility API, with backends for: * GD * GIF * PNG
+* SVG * SWF * ImageMagick convert command line tool * Imagick Extension
+
+WWW: http://www.horde.org
diff --git a/graphics/horde4-image/pkg-plist b/graphics/horde4-image/pkg-plist
new file mode 100644
index 00000000000..fbec203cb41
--- /dev/null
+++ b/graphics/horde4-image/pkg-plist
@@ -0,0 +1,61 @@
+%%HORBAS%%/Image.php
+%%HORDIR%%/Base.php
+%%HORDIR%%/Effect.php
+%%HORDIR%%/Effect/Border.php
+%%HORDIR%%/Effect/Gd/DropShadow.php
+%%HORDIR%%/Effect/Gd/RoundCorners.php
+%%HORDIR%%/Effect/Gd/TextWatermark.php
+%%HORDIR%%/Effect/Gd/Unsharpmask.php
+%%HORDIR%%/Effect/Im/Border.php
+%%HORDIR%%/Effect/Im/CenterCrop.php
+%%HORDIR%%/Effect/Im/Composite.php
+%%HORDIR%%/Effect/Im/DropShadow.php
+%%HORDIR%%/Effect/Im/LiquidResize.php
+%%HORDIR%%/Effect/Im/PhotoStack.php
+%%HORDIR%%/Effect/Im/PolaroidImage.php
+%%HORDIR%%/Effect/Im/RoundCorners.php
+%%HORDIR%%/Effect/Im/TextWatermark.php
+%%HORDIR%%/Effect/Im/Unsharpmask.php
+%%HORDIR%%/Effect/Imagick/Border.php
+%%HORDIR%%/Effect/Imagick/CenterCrop.php
+%%HORDIR%%/Effect/Imagick/Composite.php
+%%HORDIR%%/Effect/Imagick/DropShadow.php
+%%HORDIR%%/Effect/Imagick/LiquidResize.php
+%%HORDIR%%/Effect/Imagick/PhotoStack.php
+%%HORDIR%%/Effect/Imagick/PolaroidImage.php
+%%HORDIR%%/Effect/Imagick/RoundCorners.php
+%%HORDIR%%/Effect/Imagick/SmartCrop.php
+%%HORDIR%%/Effect/Imagick/TextWatermark.php
+%%HORDIR%%/Effect/Imagick/Unsharpmask.php
+%%HORDIR%%/Exception.php
+%%HORDIR%%/Exif.php
+%%HORDIR%%/Exif/Base.php
+%%HORDIR%%/Exif/Bundled.php
+%%HORDIR%%/Exif/Exiftool.php
+%%HORDIR%%/Exif/Parser/Base.php
+%%HORDIR%%/Exif/Parser/Canon.php
+%%HORDIR%%/Exif/Parser/Fujifilm.php
+%%HORDIR%%/Exif/Parser/Gps.php
+%%HORDIR%%/Exif/Parser/Nikon.php
+%%HORDIR%%/Exif/Parser/Olympus.php
+%%HORDIR%%/Exif/Parser/Panasonic.php
+%%HORDIR%%/Exif/Parser/Sanyo.php
+%%HORDIR%%/Exif/Php.php
+%%HORDIR%%/Gd.php
+%%HORDIR%%/Im.php
+%%HORDIR%%/Imagick.php
+%%HORDIR%%/Png.php
+%%HORDIR%%/Svg.php
+%%HORDIR%%/Swf.php
+%%HORDIR%%/Translation.php
+%%HORDIR%%/rgb.php
+@dirrm %%HORDIR%%/Exif/Parser
+@dirrm %%HORDIR%%/Exif/
+@dirrm %%HORDIR%%/Exif
+@dirrm %%HORDIR%%/Effect/Imagick
+@dirrm %%HORDIR%%/Effect/Im
+@dirrm %%HORDIR%%/Effect/Gd
+@dirrm %%HORDIR%%/Effect
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%
+