aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-03-04 23:48:52 +0800
committerroam <roam@FreeBSD.org>2001-03-04 23:48:52 +0800
commit29e411519b56641141df23b26a072df5db2aaf8a (patch)
tree3e69b95079afa253b919c91b281f1b40e6bf0ab6
parente4738c13dd250a41cc59e8285b205bee82542a5f (diff)
downloadfreebsd-ports-graphics-29e411519b56641141df23b26a072df5db2aaf8a.tar.gz
freebsd-ports-graphics-29e411519b56641141df23b26a072df5db2aaf8a.tar.zst
freebsd-ports-graphics-29e411519b56641141df23b26a072df5db2aaf8a.zip
Add aggregate, a utility for optimizing a list of network prefixes.
PR: 25143 Submitted by: Joe Abley <jabley@automagic.org>
-rw-r--r--net-mgmt/aggregate/Makefile17
-rw-r--r--net-mgmt/aggregate/distinfo1
-rw-r--r--net-mgmt/aggregate/files/patch-aa16
-rw-r--r--net-mgmt/aggregate/pkg-comment1
-rw-r--r--net-mgmt/aggregate/pkg-descr16
-rw-r--r--net-mgmt/aggregate/pkg-plist2
-rw-r--r--net/Makefile1
-rw-r--r--net/aggregate/Makefile17
-rw-r--r--net/aggregate/distinfo1
-rw-r--r--net/aggregate/files/patch-aa16
-rw-r--r--net/aggregate/pkg-comment1
-rw-r--r--net/aggregate/pkg-descr16
-rw-r--r--net/aggregate/pkg-plist2
13 files changed, 107 insertions, 0 deletions
diff --git a/net-mgmt/aggregate/Makefile b/net-mgmt/aggregate/Makefile
new file mode 100644
index 00000000000..1722af35e89
--- /dev/null
+++ b/net-mgmt/aggregate/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: aggregate
+# Date created: 16 Feb 2001
+# Whom: jabley
+#
+# $FreeBSD$
+#
+
+PORTNAME= aggregate
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= http://www.mfnx.net/public/
+
+MAINTAINER= jabley@automagic.org
+
+MAN1= aggregate.1 aggregate-ios.1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/aggregate/distinfo b/net-mgmt/aggregate/distinfo
new file mode 100644
index 00000000000..7c395337870
--- /dev/null
+++ b/net-mgmt/aggregate/distinfo
@@ -0,0 +1 @@
+MD5 (aggregate-1.1.tar.gz) = 6371136a8bef3f56da08c2a58c35f5ce
diff --git a/net-mgmt/aggregate/files/patch-aa b/net-mgmt/aggregate/files/patch-aa
new file mode 100644
index 00000000000..b90dbc3c7e9
--- /dev/null
+++ b/net-mgmt/aggregate/files/patch-aa
@@ -0,0 +1,16 @@
+--- aggregate-1.1/Makefile Fri Feb 16 11:31:55 2001
++++ Makefile Fri Feb 16 13:27:38 2001
+@@ -27,9 +27,9 @@
+ rm aggregate
+
+ install: aggregate aggregate.1
+- install -c -g wheel -m 0755 -o root aggregate /usr/local/bin/
+- install -c -g wheel -m 0644 -o root aggregate.1 /usr/local/man/man1/
+- install -c -g wheel -m 0755 -o root aggregate-ios /usr/local/bin/
+- install -c -g wheel -m 0644 -o root aggregate-ios.1 /usr/local/man/man1/
++ install -c -g wheel -m 0755 -o root aggregate ${PREFIX}/bin/
++ install -c -g wheel -m 0644 -o root aggregate.1 ${PREFIX}/man/man1/
++ install -c -g wheel -m 0755 -o root aggregate-ios ${PREFIX}/bin/
++ install -c -g wheel -m 0644 -o root aggregate-ios.1 ${PREFIX}/man/man1/
+
+ aggregate: aggregate.c
diff --git a/net-mgmt/aggregate/pkg-comment b/net-mgmt/aggregate/pkg-comment
new file mode 100644
index 00000000000..de03ea10fd0
--- /dev/null
+++ b/net-mgmt/aggregate/pkg-comment
@@ -0,0 +1 @@
+Optimise a list of route prefixes to help make nice short filters
diff --git a/net-mgmt/aggregate/pkg-descr b/net-mgmt/aggregate/pkg-descr
new file mode 100644
index 00000000000..cb78b828e22
--- /dev/null
+++ b/net-mgmt/aggregate/pkg-descr
@@ -0,0 +1,16 @@
+akes a list of prefixes in conventional format on stdin,
+and performs two optimisations to attempt to reduce the
+length of the prefix list.
+
+The first optimisation is to remove any supplied prefixes
+which are supurfluous because they are already included in
+another supplied prefix. For example, 203.97.2.0/24 would
+be removed if 203.97.0.0/17 was also supplied.
+
+The second optimisation identifies adjacent prefixes that
+can be combined under a single, shorter-length prefix. For
+example, 203.97.2.0/24 and 203.97.3.0/24 can be combined
+into the single prefix 203.97.2.0/23.
+
+
+jabley@automagic.org
diff --git a/net-mgmt/aggregate/pkg-plist b/net-mgmt/aggregate/pkg-plist
new file mode 100644
index 00000000000..c64c92d4a00
--- /dev/null
+++ b/net-mgmt/aggregate/pkg-plist
@@ -0,0 +1,2 @@
+bin/aggregate
+bin/aggregate-ios
diff --git a/net/Makefile b/net/Makefile
index 5b1e0ec83f1..92a411523d4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -7,6 +7,7 @@
SUBDIR += SSLtelnet
SUBDIR += adasockets
SUBDIR += adns
+ SUBDIR += aggregate
SUBDIR += aim
SUBDIR += airport
SUBDIR += amcl
diff --git a/net/aggregate/Makefile b/net/aggregate/Makefile
new file mode 100644
index 00000000000..1722af35e89
--- /dev/null
+++ b/net/aggregate/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: aggregate
+# Date created: 16 Feb 2001
+# Whom: jabley
+#
+# $FreeBSD$
+#
+
+PORTNAME= aggregate
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= http://www.mfnx.net/public/
+
+MAINTAINER= jabley@automagic.org
+
+MAN1= aggregate.1 aggregate-ios.1
+
+.include <bsd.port.mk>
diff --git a/net/aggregate/distinfo b/net/aggregate/distinfo
new file mode 100644
index 00000000000..7c395337870
--- /dev/null
+++ b/net/aggregate/distinfo
@@ -0,0 +1 @@
+MD5 (aggregate-1.1.tar.gz) = 6371136a8bef3f56da08c2a58c35f5ce
diff --git a/net/aggregate/files/patch-aa b/net/aggregate/files/patch-aa
new file mode 100644
index 00000000000..b90dbc3c7e9
--- /dev/null
+++ b/net/aggregate/files/patch-aa
@@ -0,0 +1,16 @@
+--- aggregate-1.1/Makefile Fri Feb 16 11:31:55 2001
++++ Makefile Fri Feb 16 13:27:38 2001
+@@ -27,9 +27,9 @@
+ rm aggregate
+
+ install: aggregate aggregate.1
+- install -c -g wheel -m 0755 -o root aggregate /usr/local/bin/
+- install -c -g wheel -m 0644 -o root aggregate.1 /usr/local/man/man1/
+- install -c -g wheel -m 0755 -o root aggregate-ios /usr/local/bin/
+- install -c -g wheel -m 0644 -o root aggregate-ios.1 /usr/local/man/man1/
++ install -c -g wheel -m 0755 -o root aggregate ${PREFIX}/bin/
++ install -c -g wheel -m 0644 -o root aggregate.1 ${PREFIX}/man/man1/
++ install -c -g wheel -m 0755 -o root aggregate-ios ${PREFIX}/bin/
++ install -c -g wheel -m 0644 -o root aggregate-ios.1 ${PREFIX}/man/man1/
+
+ aggregate: aggregate.c
diff --git a/net/aggregate/pkg-comment b/net/aggregate/pkg-comment
new file mode 100644
index 00000000000..de03ea10fd0
--- /dev/null
+++ b/net/aggregate/pkg-comment
@@ -0,0 +1 @@
+Optimise a list of route prefixes to help make nice short filters
diff --git a/net/aggregate/pkg-descr b/net/aggregate/pkg-descr
new file mode 100644
index 00000000000..cb78b828e22
--- /dev/null
+++ b/net/aggregate/pkg-descr
@@ -0,0 +1,16 @@
+akes a list of prefixes in conventional format on stdin,
+and performs two optimisations to attempt to reduce the
+length of the prefix list.
+
+The first optimisation is to remove any supplied prefixes
+which are supurfluous because they are already included in
+another supplied prefix. For example, 203.97.2.0/24 would
+be removed if 203.97.0.0/17 was also supplied.
+
+The second optimisation identifies adjacent prefixes that
+can be combined under a single, shorter-length prefix. For
+example, 203.97.2.0/24 and 203.97.3.0/24 can be combined
+into the single prefix 203.97.2.0/23.
+
+
+jabley@automagic.org
diff --git a/net/aggregate/pkg-plist b/net/aggregate/pkg-plist
new file mode 100644
index 00000000000..c64c92d4a00
--- /dev/null
+++ b/net/aggregate/pkg-plist
@@ -0,0 +1,2 @@
+bin/aggregate
+bin/aggregate-ios