aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-05-24 23:03:47 +0800
committeracm <acm@FreeBSD.org>2009-05-24 23:03:47 +0800
commit2c8c9ca0d998cf25ffdb255ac51077667a66cc79 (patch)
treee25ef4b28792c572487c278f96ca09c662a7528e
parent7ca14474a9585ae53dbc7f1682bf24770c3daa66 (diff)
downloadfreebsd-ports-graphics-2c8c9ca0d998cf25ffdb255ac51077667a66cc79.tar.gz
freebsd-ports-graphics-2c8c9ca0d998cf25ffdb255ac51077667a66cc79.tar.zst
freebsd-ports-graphics-2c8c9ca0d998cf25ffdb255ac51077667a66cc79.zip
- New port: net-p2p/transmisson-remote-gui
Transmission Remote GUI is feature rich cross platform front-end to remotely control Transmission daemon via its RPC protocol. It is faster and has more functionality than build-in Transmission web interface. WWW: http://code.google.com/p/transmisson-remote-gui/
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/transmission-remote-gui/Makefile48
-rw-r--r--net-p2p/transmission-remote-gui/distinfo3
-rw-r--r--net-p2p/transmission-remote-gui/files/patch-main.lfm11
-rw-r--r--net-p2p/transmission-remote-gui/files/pkg-message.in16
-rw-r--r--net-p2p/transmission-remote-gui/pkg-descr5
-rw-r--r--net-p2p/transmisson-remote-gui/Makefile48
-rw-r--r--net-p2p/transmisson-remote-gui/distinfo3
-rw-r--r--net-p2p/transmisson-remote-gui/files/patch-main.lfm11
-rw-r--r--net-p2p/transmisson-remote-gui/files/pkg-message.in16
-rw-r--r--net-p2p/transmisson-remote-gui/pkg-descr5
11 files changed, 167 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 44b0a343660..daad08e010e 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -124,6 +124,7 @@
SUBDIR += transmission-cli
SUBDIR += transmission-daemon
SUBDIR += transmission-gtk2
+ SUBDIR += transmisson-remote-gui
SUBDIR += tribler
SUBDIR += tvrss
SUBDIR += unworkable
diff --git a/net-p2p/transmission-remote-gui/Makefile b/net-p2p/transmission-remote-gui/Makefile
new file mode 100644
index 00000000000..01df0eb0f84
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: transmisson-remote-gui
+# Date created: 2009-05-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmisson-remote-gui
+PORTVERSION= 1.1
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= transgui-${PORTVERSION}-src
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Remote GUI for transmission daemon
+
+BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus
+RUN_DEPENDS= transmission-daemon:${PORTSDIR}/net-p2p/transmission-daemon
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+USE_FPC= fcl-net
+
+WRKSRC= ${WRKDIR}/TransGUI
+PLIST_FILES= bin/transgui
+SUB_FILES= pkg-message
+
+LAZARUS_PROJECT_FILE= transgui.lpi
+LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/lazbuild)
+LCL_PLATFORM!= ${SED} -e 1d -e 's/^LCL_PLATFORM=\(.*\).*$$/\1/' ${LOCALBASE}/etc/lazbuild.cfg
+.endif
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${LAZBUILD_CMD} --ws=${LCL_PLATFORM} ${LAZARUS_PROJECT_FILE}
+
+do-install:
+ @cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} units/transgui ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/transmission-remote-gui/distinfo b/net-p2p/transmission-remote-gui/distinfo
new file mode 100644
index 00000000000..53634f3fad2
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/distinfo
@@ -0,0 +1,3 @@
+MD5 (transgui-1.1-src.zip) = 8c93e97e7ae5b528e5280976907ee2bc
+SHA256 (transgui-1.1-src.zip) = 179275083e65630d48b06b795048e7c271d80e45d1cb715d9e28e4c1f33102df
+SIZE (transgui-1.1-src.zip) = 411225
diff --git a/net-p2p/transmission-remote-gui/files/patch-main.lfm b/net-p2p/transmission-remote-gui/files/patch-main.lfm
new file mode 100644
index 00000000000..d6b5fa24557
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/files/patch-main.lfm
@@ -0,0 +1,11 @@
+--- main.lfm 2009-05-21 17:53:53.000000000 -0500
++++ main.lfm 2009-05-21 17:54:04.000000000 -0500
+@@ -214,8 +214,6 @@
+ Top = 26
+ Width = 772
+ Align = alClient
+- ClientHeight = 222
+- ClientWidth = 751
+ TabOrder = 0
+ OnResize = sbGenInfoResize
+ object panGeneralInfo: TPanel
diff --git a/net-p2p/transmission-remote-gui/files/pkg-message.in b/net-p2p/transmission-remote-gui/files/pkg-message.in
new file mode 100644
index 00000000000..46cfba4cc7c
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/files/pkg-message.in
@@ -0,0 +1,16 @@
+###############################################################################
+
+The Transmisson remote gui was installed
+
+1) You can run it using:
+
+ # transgui
+
+2) Don't forget that you need a transmission-daemon program configurated and
+ running before of use transgui.
+
+3) Run "transmission-daemon --help" for more configuration options
+
+4) Enjoy it ;)
+
+###############################################################################
diff --git a/net-p2p/transmission-remote-gui/pkg-descr b/net-p2p/transmission-remote-gui/pkg-descr
new file mode 100644
index 00000000000..0ceaff03a37
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/pkg-descr
@@ -0,0 +1,5 @@
+Transmission Remote GUI is feature rich cross platform front-end to remotely
+control Transmission daemon via its RPC protocol. It is faster and has more
+functionality than build-in Transmission web interface.
+
+WWW: http://code.google.com/p/transmisson-remote-gui/
diff --git a/net-p2p/transmisson-remote-gui/Makefile b/net-p2p/transmisson-remote-gui/Makefile
new file mode 100644
index 00000000000..01df0eb0f84
--- /dev/null
+++ b/net-p2p/transmisson-remote-gui/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: transmisson-remote-gui
+# Date created: 2009-05-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmisson-remote-gui
+PORTVERSION= 1.1
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= transgui-${PORTVERSION}-src
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Remote GUI for transmission daemon
+
+BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus
+RUN_DEPENDS= transmission-daemon:${PORTSDIR}/net-p2p/transmission-daemon
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+USE_FPC= fcl-net
+
+WRKSRC= ${WRKDIR}/TransGUI
+PLIST_FILES= bin/transgui
+SUB_FILES= pkg-message
+
+LAZARUS_PROJECT_FILE= transgui.lpi
+LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/lazbuild)
+LCL_PLATFORM!= ${SED} -e 1d -e 's/^LCL_PLATFORM=\(.*\).*$$/\1/' ${LOCALBASE}/etc/lazbuild.cfg
+.endif
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${LAZBUILD_CMD} --ws=${LCL_PLATFORM} ${LAZARUS_PROJECT_FILE}
+
+do-install:
+ @cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} units/transgui ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/transmisson-remote-gui/distinfo b/net-p2p/transmisson-remote-gui/distinfo
new file mode 100644
index 00000000000..53634f3fad2
--- /dev/null
+++ b/net-p2p/transmisson-remote-gui/distinfo
@@ -0,0 +1,3 @@
+MD5 (transgui-1.1-src.zip) = 8c93e97e7ae5b528e5280976907ee2bc
+SHA256 (transgui-1.1-src.zip) = 179275083e65630d48b06b795048e7c271d80e45d1cb715d9e28e4c1f33102df
+SIZE (transgui-1.1-src.zip) = 411225
diff --git a/net-p2p/transmisson-remote-gui/files/patch-main.lfm b/net-p2p/transmisson-remote-gui/files/patch-main.lfm
new file mode 100644
index 00000000000..d6b5fa24557
--- /dev/null
+++ b/net-p2p/transmisson-remote-gui/files/patch-main.lfm
@@ -0,0 +1,11 @@
+--- main.lfm 2009-05-21 17:53:53.000000000 -0500
++++ main.lfm 2009-05-21 17:54:04.000000000 -0500
+@@ -214,8 +214,6 @@
+ Top = 26
+ Width = 772
+ Align = alClient
+- ClientHeight = 222
+- ClientWidth = 751
+ TabOrder = 0
+ OnResize = sbGenInfoResize
+ object panGeneralInfo: TPanel
diff --git a/net-p2p/transmisson-remote-gui/files/pkg-message.in b/net-p2p/transmisson-remote-gui/files/pkg-message.in
new file mode 100644
index 00000000000..46cfba4cc7c
--- /dev/null
+++ b/net-p2p/transmisson-remote-gui/files/pkg-message.in
@@ -0,0 +1,16 @@
+###############################################################################
+
+The Transmisson remote gui was installed
+
+1) You can run it using:
+
+ # transgui
+
+2) Don't forget that you need a transmission-daemon program configurated and
+ running before of use transgui.
+
+3) Run "transmission-daemon --help" for more configuration options
+
+4) Enjoy it ;)
+
+###############################################################################
diff --git a/net-p2p/transmisson-remote-gui/pkg-descr b/net-p2p/transmisson-remote-gui/pkg-descr
new file mode 100644
index 00000000000..0ceaff03a37
--- /dev/null
+++ b/net-p2p/transmisson-remote-gui/pkg-descr
@@ -0,0 +1,5 @@
+Transmission Remote GUI is feature rich cross platform front-end to remotely
+control Transmission daemon via its RPC protocol. It is faster and has more
+functionality than build-in Transmission web interface.
+
+WWW: http://code.google.com/p/transmisson-remote-gui/