aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-08-31 06:24:52 +0800
committerpawel <pawel@FreeBSD.org>2011-08-31 06:24:52 +0800
commit2e1fee6df035c01731c1b15edd8ae244d80600b8 (patch)
treeedb8b12518a3f94d154d5782be8f09c5ed102eb7
parentea97ff0193ae29ce5a5d66618457a51f5f518621 (diff)
downloadfreebsd-ports-graphics-2e1fee6df035c01731c1b15edd8ae244d80600b8.tar.gz
freebsd-ports-graphics-2e1fee6df035c01731c1b15edd8ae244d80600b8.tar.zst
freebsd-ports-graphics-2e1fee6df035c01731c1b15edd8ae244d80600b8.zip
- fix plist [1]
- restrict python versions to 2.5-2.7 [1] - add x11-toolkits/py-gtk2 build/run dep for WITH_PYTHON [2] - add devel/qt4-moc build dep for WITH_QT4 [2] PR: ports/160182 Submitted by: [1] Oliver Heesakkers <dev2@heesakkers.info> (maintainer) [2] myself Approved by: miwi, wen (mentors implicit)
-rw-r--r--graphics/zbar/Makefile7
-rw-r--r--graphics/zbar/pkg-plist4
2 files changed, 6 insertions, 5 deletions
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index fab58ffcaf9..de7d7e54ba1 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -65,7 +65,8 @@ PLIST_SUB+= V4L="@comment "
.endif
.if defined(WITH_PYTHON)
-USE_PYTHON= any
+USE_PYTHON= 2.5-2.7
+USE_GNOME+= pygtk2
CONFIGURE_ARGS+= --with-python=yes
PLIST_SUB+= PYTHON=""
.else
@@ -74,7 +75,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_GTK2)
-USE_GNOME= gtk20
+USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-gtk=yes
PLIST_SUB+= GTK2=""
.else
@@ -84,7 +85,7 @@ PLIST_SUB+= GTK2="@comment "
.if defined(WITH_QT4)
USE_QT_VER= 4
-QT_COMPONENTS= gui
+QT_COMPONENTS= gui moc_build
CONFIGURE_ARGS+= --with-qt=yes
PLIST_SUB+= QT4=""
.else
diff --git a/graphics/zbar/pkg-plist b/graphics/zbar/pkg-plist
index 02545a97c0e..fbe05041a2c 100644
--- a/graphics/zbar/pkg-plist
+++ b/graphics/zbar/pkg-plist
@@ -39,7 +39,7 @@ libdata/pkgconfig/zbar.pc
%%PORTDOCS%%%%DOCSDIR%%/TODO
@dirrmtry share/zbar
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry lib/python2.6/site-packages
-@dirrmtry lib/python2.6
+@dirrmtry %%PYTHON_SITELIBDIR%%
+@dirrmtry lib/%%PYTHON_VERSION%%
@dirrmtry lib/pkgconfig
@dirrm include/zbar