aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-21 21:01:32 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-21 21:01:32 +0800
commit2e6aa66a788460c316af021af689be58f958f09e (patch)
tree5bbc21769c2be7871c2ae3f659aea9ae0bcb4d6b
parent75b13a3dbe90ce1667f732917e9129a3dcbcfe96 (diff)
downloadfreebsd-ports-graphics-2e6aa66a788460c316af021af689be58f958f09e.tar.gz
freebsd-ports-graphics-2e6aa66a788460c316af021af689be58f958f09e.tar.zst
freebsd-ports-graphics-2e6aa66a788460c316af021af689be58f958f09e.zip
VMware Command Line Tools
On this page, you'll find command line programs which can replace and/or supplement the VMware's official VMwareTools. These programs use VMware's undocumented and therefore not officially supported feature to communicate with VMware (see VMware Backdoor I/O Port). Information on these functions have come entirely from my personal research and quite a few contributions by fellow VMware users. These programs are intended partly as illustrative examples of how to use the VMware backdoor function and I have cut many corners writing them. * vmw: generic backdoor access program * vmshrink: virtual disk shrink program * vmftp: host-guest file transfer program WWW: http://chitchat.at.infoseek.co.jp/vmware/vmtools.html
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/vmw/Makefile40
-rw-r--r--emulators/vmw/distinfo3
-rw-r--r--emulators/vmw/pkg-descr18
4 files changed, 62 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 2443c187d45..21c5f4650e8 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -130,6 +130,7 @@
SUBDIR += visualos
SUBDIR += vmips
SUBDIR += vmsbackup
+ SUBDIR += vmw
SUBDIR += vmware-guestd3
SUBDIR += vmware-guestd4
SUBDIR += vmware-guestd5
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
new file mode 100644
index 00000000000..ccc91cb858f
--- /dev/null
+++ b/emulators/vmw/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: vmw
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmw
+PORTVERSION= 060510
+CATEGORIES= emulators
+MASTER_SITES= http://chitchat.at.infoseek.co.jp/vmware/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= VM Back Command Line Tools for VMware
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+USE_ICONV= yes
+
+SBINS= vmw vmshrink vmftp
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README-eucj.TXT README-sjis.TXT README.TXT
+.for i in ${SBINS}
+PORTDOCS+= ${i}-eucj.txt ${i}-sjis.txt ${i}.txt
+.endfor
+.endif
+.for i in ${SBINS}
+PLIST_FILES+= sbin/${i}
+.endfor
+
+do-install:
+.for i in ${SBINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/.. && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/vmw/distinfo b/emulators/vmw/distinfo
new file mode 100644
index 00000000000..898b12db94b
--- /dev/null
+++ b/emulators/vmw/distinfo
@@ -0,0 +1,3 @@
+MD5 (vmw-060510.tar.gz) = b9bf0f63e4cda07deda233919a3967c2
+SHA256 (vmw-060510.tar.gz) = 5bb4a60e5651b2c2f7be7e21e45c1de541cd31d5e56ed7b34c20a87429db8457
+SIZE (vmw-060510.tar.gz) = 518343
diff --git a/emulators/vmw/pkg-descr b/emulators/vmw/pkg-descr
new file mode 100644
index 00000000000..98415c33fc6
--- /dev/null
+++ b/emulators/vmw/pkg-descr
@@ -0,0 +1,18 @@
+VMware Command Line Tools
+
+On this page, you'll find command line programs which can replace and/or
+supplement the VMware's official VMwareTools.
+
+These programs use VMware's undocumented and therefore not officially
+supported feature to communicate with VMware (see VMware Backdoor I/O Port).
+Information on these functions have come entirely from my personal research
+and quite a few contributions by fellow VMware users.
+
+These programs are intended partly as illustrative examples of how to use the
+VMware backdoor function and I have cut many corners writing them.
+
+* vmw: generic backdoor access program
+* vmshrink: virtual disk shrink program
+* vmftp: host-guest file transfer program
+
+WWW: http://chitchat.at.infoseek.co.jp/vmware/vmtools.html