aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-27 04:43:13 +0800
committermarcus <marcus@FreeBSD.org>2004-03-27 04:43:13 +0800
commit323d9128a4a8b2ca0950bba6dde234b3f233a607 (patch)
tree7313c16842faf33c408ffdc3cc133452447a6ac4
parentd72cfb598ee6c32841a131832ad67fb997b539a3 (diff)
downloadfreebsd-ports-graphics-323d9128a4a8b2ca0950bba6dde234b3f233a607.tar.gz
freebsd-ports-graphics-323d9128a4a8b2ca0950bba6dde234b3f233a607.tar.zst
freebsd-ports-graphics-323d9128a4a8b2ca0950bba6dde234b3f233a607.zip
Update to 2.6.0
* Add some additional checks for USE_* variables included too late [1] * Add a check for SIZE in distinfo [2] * Fix a small style nit [2] * Warn is USE_SIZE is used in a port's Makefile * Check to see if a port supports WITHOUT_NLS if USE_GETTEXT is defined [3] Submitted by: eik [1] krion [2] Requested by: kris [3]
-rw-r--r--devel/portlint/Makefile2
-rw-r--r--devel/portlint/src/portlint.pl62
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl62
4 files changed, 104 insertions, 24 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 809b4852e6f..ee68a6f92ed 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.5.9
+PORTVERSION= 2.6.0
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index f89fc235205..74d0e4216c5 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.43 2004/03/21 07:31:33 marcus Exp $
+# $Id: portlint.pl,v 1.44 2004/03/26 20:42:32 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -39,8 +39,8 @@ $portdir = '.';
# version variables
my $major = 2;
-my $minor = 5;
-my $micro = 9;
+my $minor = 6;
+my $micro = 0;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -250,12 +250,13 @@ close(IN);
#
# check for files.
#
-my @checker = ($makevar{DESCR}, 'Makefile', $makevar{MD5_FILE});
+my @checker = ($makevar{DESCR}, 'Makefile', 'distinfo', $makevar{MD5_FILE});
my %checker = (
- $makevar{DESCR} => 'checkdescr',
- 'Makefile' => 'checkmakefile',
- $makevar{MD5_FILE} => 'TRUE'
- );
+ $makevar{DESCR} => 'checkdescr',
+ 'Makefile' => 'checkmakefile',
+ $makevar{MD5_FILE} => 'TRUE',
+ 'distinfo' => 'checkdistinfo',
+);
if ($extrafile) {
my @files = (
<$makevar{SCRIPTDIR}/*>,
@@ -493,6 +494,24 @@ if ($err || $warn) {
exit $err;
#
+# distinfo
+#
+sub checkdistinfo {
+ my($file) = @_;
+ my($sizefound) = 0;
+ open(IN, "< $file") || return 0;
+ while (<IN>) {
+ if ($_ =~ /^SIZE/) {
+ $sizefound = 1;
+ }
+ }
+ if (!$sizefound) {
+ &perror("WARN: $file: does not contain SIZE.");
+ }
+ close(IN);
+}
+
+#
# pkg-descr
#
sub checkdescr {
@@ -693,7 +712,7 @@ sub checkplist {
if ($_ =~ /^info\/dir$/) {
&perror("FATAL: $file [$.]: \"info/dir\" should not be listed.".
- "use install-info to add/remove ".
+ "Use install-info to add/remove ".
"an entry.");
$infooverwrite++;
}
@@ -1016,18 +1035,20 @@ sub checkmakefile {
print "OK: checking for USE_* used too late.\n" if ($verbose);
my @use_early = qw(
APACHE
+ BZIP2
GNUSTEP
IMAKE
JAVA
KDE(?:BASE|LIBS)_VER
- LIBRUBY
+ (?:LIB)?RUBY
LINUX_PREFIX
OPENSSL
+ PHP
PYTHON
QT2?
QT_VER
- RUBY
X_PREFIX
+ ZIP
);
my @other_early = qw(
@@ -1070,6 +1091,16 @@ sub checkmakefile {
}
#
+ # whole file: USE_SIZE
+ #
+ print "OK: checking USE_SIZE.\n" if ($verbose);
+ if ($whole =~ /\nUSE_SIZE/) {
+ my $lineno = &linenumber($`);
+ &perror("WARN: $file [$lineno]: use of USE_SIZE is no longer ".
+ "required.");
+ }
+
+ #
# whole file: MACHINE_ARCH
#
print "OK: checking MACHINE_ARCH.\n" if ($verbose);
@@ -1115,6 +1146,15 @@ sub checkmakefile {
}
#
+ # whole file: check for USE_GETTEXT
+ #
+ print "OK: checking for USE_GETTEXT without WITHOUT_NLS.\n" if ($verbose);
+ if ($whole =~ /\nUSE_GETTEXT/ && $whole !~ /def(?:ined)?\s*\(?WITHOUT_NLS\)?/) {
+ &perror("WARN: $file: Consider adding support for a WITHOUT_NLS ".
+ "knob to conditionally disable gettext support.");
+ }
+
+ #
# whole file: direct use of command names
#
my %cmdnames = ();
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 809b4852e6f..ee68a6f92ed 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.5.9
+PORTVERSION= 2.6.0
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index f89fc235205..74d0e4216c5 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.43 2004/03/21 07:31:33 marcus Exp $
+# $Id: portlint.pl,v 1.44 2004/03/26 20:42:32 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -39,8 +39,8 @@ $portdir = '.';
# version variables
my $major = 2;
-my $minor = 5;
-my $micro = 9;
+my $minor = 6;
+my $micro = 0;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -250,12 +250,13 @@ close(IN);
#
# check for files.
#
-my @checker = ($makevar{DESCR}, 'Makefile', $makevar{MD5_FILE});
+my @checker = ($makevar{DESCR}, 'Makefile', 'distinfo', $makevar{MD5_FILE});
my %checker = (
- $makevar{DESCR} => 'checkdescr',
- 'Makefile' => 'checkmakefile',
- $makevar{MD5_FILE} => 'TRUE'
- );
+ $makevar{DESCR} => 'checkdescr',
+ 'Makefile' => 'checkmakefile',
+ $makevar{MD5_FILE} => 'TRUE',
+ 'distinfo' => 'checkdistinfo',
+);
if ($extrafile) {
my @files = (
<$makevar{SCRIPTDIR}/*>,
@@ -493,6 +494,24 @@ if ($err || $warn) {
exit $err;
#
+# distinfo
+#
+sub checkdistinfo {
+ my($file) = @_;
+ my($sizefound) = 0;
+ open(IN, "< $file") || return 0;
+ while (<IN>) {
+ if ($_ =~ /^SIZE/) {
+ $sizefound = 1;
+ }
+ }
+ if (!$sizefound) {
+ &perror("WARN: $file: does not contain SIZE.");
+ }
+ close(IN);
+}
+
+#
# pkg-descr
#
sub checkdescr {
@@ -693,7 +712,7 @@ sub checkplist {
if ($_ =~ /^info\/dir$/) {
&perror("FATAL: $file [$.]: \"info/dir\" should not be listed.".
- "use install-info to add/remove ".
+ "Use install-info to add/remove ".
"an entry.");
$infooverwrite++;
}
@@ -1016,18 +1035,20 @@ sub checkmakefile {
print "OK: checking for USE_* used too late.\n" if ($verbose);
my @use_early = qw(
APACHE
+ BZIP2
GNUSTEP
IMAKE
JAVA
KDE(?:BASE|LIBS)_VER
- LIBRUBY
+ (?:LIB)?RUBY
LINUX_PREFIX
OPENSSL
+ PHP
PYTHON
QT2?
QT_VER
- RUBY
X_PREFIX
+ ZIP
);
my @other_early = qw(
@@ -1070,6 +1091,16 @@ sub checkmakefile {
}
#
+ # whole file: USE_SIZE
+ #
+ print "OK: checking USE_SIZE.\n" if ($verbose);
+ if ($whole =~ /\nUSE_SIZE/) {
+ my $lineno = &linenumber($`);
+ &perror("WARN: $file [$lineno]: use of USE_SIZE is no longer ".
+ "required.");
+ }
+
+ #
# whole file: MACHINE_ARCH
#
print "OK: checking MACHINE_ARCH.\n" if ($verbose);
@@ -1115,6 +1146,15 @@ sub checkmakefile {
}
#
+ # whole file: check for USE_GETTEXT
+ #
+ print "OK: checking for USE_GETTEXT without WITHOUT_NLS.\n" if ($verbose);
+ if ($whole =~ /\nUSE_GETTEXT/ && $whole !~ /def(?:ined)?\s*\(?WITHOUT_NLS\)?/) {
+ &perror("WARN: $file: Consider adding support for a WITHOUT_NLS ".
+ "knob to conditionally disable gettext support.");
+ }
+
+ #
# whole file: direct use of command names
#
my %cmdnames = ();
title='2002-04-22 07:47:50 +0800'>2002-04-2214-256/+576 * gettext upgrade uber-patch (stage 3)ade2002-04-132-2/+4 * Stage 1 of gettext update.ade2002-03-162-2/+2 * Add WWW.demon2001-12-282-0/+4 * Update to 2.2.2.demon2001-12-136-18/+32 * Upgrade to 2.2.1.demon2001-10-2712-52/+46 * Set DIST_SUBDIR=KDEdemon2001-09-114-2/+4 * MAINTAINER -> kde@FreeBSD.orgdemon2001-09-012-2/+2 * Fix installation in a slightly different way.demon2001-08-214-12/+16 * Remove two languages not presented in new version.demon2001-08-202-6/+2 * Forgot to remove debug comment.demon2001-08-162-2/+2 * Upgrade to 2.2.demon2001-08-16