aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-01-21 15:49:44 +0800
committerbf <bf@FreeBSD.org>2011-01-21 15:49:44 +0800
commit326039af1f47f3689996ba989ee41692a0f837a4 (patch)
tree2654ebde297782746779dbc91c170b5067587fde
parentd756e0c1eff4c2c3874fad9a37ab64dbf356f930 (diff)
downloadfreebsd-ports-graphics-326039af1f47f3689996ba989ee41692a0f837a4.tar.gz
freebsd-ports-graphics-326039af1f47f3689996ba989ee41692a0f837a4.tar.zst
freebsd-ports-graphics-326039af1f47f3689996ba989ee41692a0f837a4.zip
Chase a silent upstream distfile update
Approved by: makc, miwi (mentors, implicit) Feature safe: yes
-rw-r--r--devel/distorm/Makefile10
-rw-r--r--devel/distorm/distinfo4
-rw-r--r--devel/distorm/files/patch-Makefile23
-rw-r--r--devel/distorm/files/patch-examples__linux__main.c11
-rw-r--r--devel/distorm/files/patch-make__linux__Makefile26
5 files changed, 44 insertions, 30 deletions
diff --git a/devel/distorm/Makefile b/devel/distorm/Makefile
index eea9bd17f40..7d7f8a6c87b 100644
--- a/devel/distorm/Makefile
+++ b/devel/distorm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= distorm
PORTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
LOCAL/bf
@@ -22,16 +22,16 @@ USE_DOS2UNIX= yes
USE_ZIP= yes
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/distorm3/build/linux
+BUILD_WRKSRC= ${WRKSRC}/make/linux
ALL_TARGET= clib
PLIST_FILES= bin/disasm lib/libdistorm3.a lib/libdistorm3.so
post-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/disasm ${WRKSRC}/../../linuxproj/main.c \
- ${WRKSRC}/libdistorm3.a
+ ${CC} ${CFLAGS} -o ${BUILD_WRKSRC}/disasm ${WRKSRC}/examples/linux/main.c \
+ ${BUILD_WRKSRC}/libdistorm3.a
do-install:
- ( cd ${WRKSRC} && ${INSTALL_DATA} libdistorm3.a libdistorm3.so ${PREFIX}/lib \
+ ( cd ${BUILD_WRKSRC} && ${INSTALL_DATA} libdistorm3.a libdistorm3.so ${PREFIX}/lib \
&& ${INSTALL_PROGRAM} disasm ${PREFIX}/bin )
.include <bsd.port.mk>
diff --git a/devel/distorm/distinfo b/devel/distorm/distinfo
index b0c107e62be..6edbaf8947e 100644
--- a/devel/distorm/distinfo
+++ b/devel/distorm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (distorm3.zip) = 4a141f65f31d85463ddeb800d4e1473320bcb9a6c8713464ff303a3cfb20b7db
-SIZE (distorm3.zip) = 177379
+SHA256 (distorm3.zip) = 13f9b3f536e2325b2f91cb5fb467607b82fd2eb741f2aa622d5af9dd6675dccc
+SIZE (distorm3.zip) = 193204
diff --git a/devel/distorm/files/patch-Makefile b/devel/distorm/files/patch-Makefile
deleted file mode 100644
index ca9d9e9a625..00000000000
--- a/devel/distorm/files/patch-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./Makefile.orig 2010-10-04 23:38:43.000000000 -0400
-+++ ./Makefile 2010-10-04 23:41:25.000000000 -0400
-@@ -4,8 +4,7 @@
-
- TARGET = libdistorm3.so
- COBJS = ../../mnemonics.o ../../src/wstring.o ../../src/textdefs.o ../../src/x86defs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
--CC = gcc
--CFLAGS = -fPIC -O2 -Wall -DSUPPORT_64BIT_OFFSET -DLIBDISTORM
-+CFLAGS += -fPIC -DSUPPORT_64BIT_OFFSET -DLIBDISTORM
-
- all: clib
-
-@@ -13,8 +12,8 @@
- /bin/rm -rf ../../src/*.o ${TARGET} ../../distorm3.a ../../mnemonics.o
-
- clib: ${COBJS}
-- ${CC} ${CFLAGS} ${VERSION} ${COBJS} -shared -o ${TARGET}
-- ar rs ../../distorm3.a ${COBJS}
-+ ${CC} ${CFLAGS} ${LDFLAGS} ${COBJS} -shared -o ${TARGET}
-+ ${AR} rs libdistorm3.a ${COBJS}
-
- install: libdistorm3.so
- install -s ${TARGET} /usr/local/lib
diff --git a/devel/distorm/files/patch-examples__linux__main.c b/devel/distorm/files/patch-examples__linux__main.c
new file mode 100644
index 00000000000..84dc34f9e68
--- /dev/null
+++ b/devel/distorm/files/patch-examples__linux__main.c
@@ -0,0 +1,11 @@
+--- examples/linux/main.c.orig 2011-01-21 01:44:22.000000000 -0500
++++ examples/linux/main.c 2011-01-21 01:44:53.000000000 -0500
+@@ -29,7 +29,7 @@
+ #define EX_NOPERM 77
+ #define EX_CONFIG 78
+
+-#include "../include/distorm.h"
++#include "../../include/distorm.h"
+
+ // The number of the array of instructions the decoder function will use to return the disassembled instructions.
+ // Play with this value for performance...
diff --git a/devel/distorm/files/patch-make__linux__Makefile b/devel/distorm/files/patch-make__linux__Makefile
new file mode 100644
index 00000000000..20267d2bf81
--- /dev/null
+++ b/devel/distorm/files/patch-make__linux__Makefile
@@ -0,0 +1,26 @@
+--- make/linux/Makefile.orig 2011-01-21 01:11:45.000000000 -0500
++++ make/linux/Makefile 2011-01-21 01:18:16.000000000 -0500
+@@ -3,18 +3,17 @@
+ #
+
+ TARGET = libdistorm3.so
+-COBJS = ../../mnemonics.o ../../src/wstring.o ../../src/textdefs.o ../../src/x86defs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
+-CC = gcc
+-CFLAGS = -fPIC -O2 -Wall -DSUPPORT_64BIT_OFFSET -DLIBDISTORM
++COBJS = ../../include/mnemonics.o ../../src/wstring.o ../../src/textdefs.o ../../src/x86defs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
++CFLAGS += -fPIC -DSUPPORT_64BIT_OFFSET -DLIBDISTORM
+
+ all: clib
+
+ clean:
+- /bin/rm -rf ../../src/*.o ${TARGET} ../../distorm3.a ../../mnemonics.o ../../*.o
++ /bin/rm -rf ../../src/*.o ${TARGET} libdistorm3.a ../../include/mnemonics.o
+
+ clib: ${COBJS}
+- ${CC} ${CFLAGS} ${VERSION} ${COBJS} -shared -o ${TARGET}
+- ar rs ../../distorm3.a ${COBJS}
++ ${CC} ${CFLAGS} ${LDFLAGS} ${COBJS} -shared -o ${TARGET}
++ ${AR} rs libdistorm3.a ${COBJS}
+
+ install: libdistorm3.so
+ install -s ${TARGET} /usr/local/lib