aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1994-12-17 11:11:25 +0800
committerache <ache@FreeBSD.org>1994-12-17 11:11:25 +0800
commit33a313d162833772063f38d8937bae43e3f4c5f7 (patch)
treef81ddd5979504c63f28fd168c56c413ebe284075
parentffbf2c39d06879f144453298fdcfa1068d6308af (diff)
downloadfreebsd-ports-graphics-33a313d162833772063f38d8937bae43e3f4c5f7.tar.gz
freebsd-ports-graphics-33a313d162833772063f38d8937bae43e3f4c5f7.tar.zst
freebsd-ports-graphics-33a313d162833772063f38d8937bae43e3f4c5f7.zip
Don't touch makefile and use gmake instead
-rw-r--r--www/lynx-current/Makefile1
-rw-r--r--www/lynx/Makefile1
-rw-r--r--www/lynx/files/patch-aa27
3 files changed, 6 insertions, 23 deletions
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 7b06f38ebd9..6ffed41df85 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -10,5 +10,6 @@ DISTNAME= lynx2-3-6
EXTRACT_SUFX= .tar.Z
MASTER_SITES= ftp://ukanaix.cc.ukans.edu/pub/lynx/lynx2-3-6/
ALL_TARGET= freebsd
+DEPENDS= ${PORTSDIR}/devel/gmake
.include <bsd.port.mk>
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 7b06f38ebd9..6ffed41df85 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -10,5 +10,6 @@ DISTNAME= lynx2-3-6
EXTRACT_SUFX= .tar.Z
MASTER_SITES= ftp://ukanaix.cc.ukans.edu/pub/lynx/lynx2-3-6/
ALL_TARGET= freebsd
+DEPENDS= ${PORTSDIR}/devel/gmake
.include <bsd.port.mk>
diff --git a/www/lynx/files/patch-aa b/www/lynx/files/patch-aa
index 5f5a89a5aec..5ac00dc486a 100644
--- a/www/lynx/files/patch-aa
+++ b/www/lynx/files/patch-aa
@@ -30,25 +30,6 @@
strerror(errno));
#define ER_NO_TRANS_DONE
#endif
-*** WWW/Library/Implementation/CommonMakefile.orig Sun May 29 06:11:42 1994
---- WWW/Library/Implementation/CommonMakefile Thu Dec 15 06:43:22 1994
-***************
-*** 63,69 ****
- # in which this makefile is, not the pwd. This screws up the
- # recursive invocation
- # include $(CMN)Version.make
-! include $(ABS)$(WWW)/Library/Implementation/Version.make
-
- # XMOsAIC hack is only for server to cope with xmosaic kludge for mmedia
- #
---- 63,69 ----
- # in which this makefile is, not the pwd. This screws up the
- # recursive invocation
- # include $(CMN)Version.make
-! .include "$(ABS)$(WWW)/Library/Implementation/Version.make"
-
- # XMOsAIC hack is only for server to cope with xmosaic kludge for mmedia
- #
*** WWW/Library/Implementation/HTFile.c.orig Sat Dec 3 01:31:21 1994
--- WWW/Library/Implementation/HTFile.c Thu Dec 15 06:43:23 1994
***************
@@ -80,7 +61,7 @@
ASIS_MACH = i386/FreeBSD
-! CFLAGS += -DDEBUG
+! CFLAGS = -O2 -DDEBUG
LFLAGS =
CC = cc
@@ -478,7 +459,7 @@
WTMP = ../..
-! .include "$(WWW)/Library/Implementation/CommonMakefile"
+! include $(WWW)/Library/Implementation/CommonMakefile
*** src/LYMain.c.orig Sat Dec 3 01:31:17 1994
--- src/LYMain.c Thu Dec 15 06:43:24 1994
@@ -576,7 +557,7 @@
*** 149,156 ****
freebsd:
- cd WWW/Library/freebsd; make LYFLAGS="$(SITE_LYDEFS)"
+! cd WWW/Library/freebsd; make LYFLAGS="$(SITE_LYDEFS)"
! cd src; make all CC="cc" MCFLAGS="-O -DUNIX -DNO_KEYPAD -I../$(WWWINC) $(SITE_DEFS)"\
! LIBS="-lcurses -ltermcap $(WAISLIB)" \
WWWLIB="../WWW/Library/freebsd/libwww.a"
@@ -585,7 +566,7 @@
--- 149,158 ----
freebsd:
- cd WWW/Library/freebsd; make LYFLAGS="$(SITE_LYDEFS)"
+! cd WWW/Library/freebsd; gmake LYFLAGS="$(SITE_LYDEFS)"
! cd src; make all MCFLAGS="$(CFLAGS) -DNCURSES -DNO_TTYTYPE \
! -DFANCY_CURSES -DNO_CUSERID -DUNIX -I../$(WWWINC) \
! $(SITE_DEFS)" \
td>2004-08-092-2/+2 * Update to 0.8.1. Seemarcus2004-08-0914-182/+84 * - Fix build with gcc-3.4pav2004-08-091-0/+11 * Fix the Python bindings build on -CURRENT, and make sure the Pythonmarcus2004-08-094-7/+10 * - Update to 0.08vanilla2004-08-092-3/+3 * Update to 4.32.5sem2004-08-097-14/+14 * Update to version 0.0.17krion2004-08-092-4/+3 * Update to version 0.0.13krion2004-08-093-3/+7 * Fix build with gcc-3.4krion2004-08-093-10/+31 * Update to version 11.1krion2004-08-094-6/+6 * Fix build with gcc-3.4krion2004-08-091-6/+7 * Fix build with gcc-3.4krion2004-08-091-0/+12 * Fix build with gcc-3.4krion2004-08-093-6/+15 * Fix installkrion2004-08-092-2/+3 * Update to version 1.0.3krion2004-08-093-16/+12 * - Upgrade to 0.5 and chase OCaml;thierry2004-08-092-4/+5 * Update to version 2.5.0krion2004-08-095-118/+133 * Add graphics/epeg.vanilla2004-08-091-0/+1 * Add epeg, it's an immensely fast jpeg thumbnailer library API for Enlightenment.vanilla2004-08-095-0/+42 * fix build with gcc 3.4.2oliver2004-08-092-1/+11 * 1: Upgrade to 1.1.1.vanilla2004-08-096-135/+15 * 1: Upgrade to 1.1.1.vanilla2004-08-0910-313/+31 * Upgrade to 1.1.4.thierry2004-08-095-48/+21 * Hook up elmo-devel.adamw2004-08-082-0/+2 * Register conflicts between elmo and elmo-devel.adamw2004-08-082-0/+4 * 1: Upgrade to 1.0.5vanilla2004-08-083-18/+18 * remove USE_FREETYPE, in the fact, libast don't need freetype library.vanilla2004-08-082-2/+14 * Update to elmo-devel-1.3.1.adamw2004-08-084-7/+14 * - Reported by many, approved by maintainer:andreas2004-08-082-67/+9 * Add devel/eet and graphics/embryo.vanilla2004-08-081-0/+2 * Add embryo, it's a C like scripting language used in parts of the Enlightenment.vanilla2004-08-085-0/+52 * Reword to stress that each user must run the elmo configgerationadamw2004-08-081-2/+2 * Add eet, it's a data handling library for enlightenment.vanilla2004-08-086-0/+55 * respect CC/CFLAGS.sf2004-08-081-1/+5 * Upgrade to 0.1.7.thierry2004-08-088-192/+64 * - Convert to use Makefile.modules.3rdclement2004-08-082-12/+9 * - Add missing "post-install:"clement2004-08-081-0/+1 * - Add mod_macro 1.1.6 for apache2clement2004-08-085-0/+38 * Update to version 1.0.49demon2004-08-0824-148/+108 * Version 0.5 release.thierry2004-08-084-8/+34 * Update to version 2.0.15.demon2004-08-082-3/+3 * Update to version 1.05.demon2004-08-082-3/+3 * - Update to 0.75.1pav2004-08-082-3/+3 * sybase_ase --> ports/databases/sybase_asethierry2004-08-081-0/+1 * Add sybase_ase 11.0.3.3, Sybase ASE RDBM System 11.thierry2004-08-087-0/+1274 * Update to 0.15mat2004-08-082-3/+3 * ** Update to 0.7.8jeh2004-08-080-0/+0 * * Fix rc.subr use so the it works properly with both 4.x and 5.xjeh2004-08-083-19/+5 * Update to 2.0perky2004-08-083-5/+8 * Update to 0.3perky2004-08-083-28/+22 * Finally, there seems to be a bug with NO_BUILD and OPTIONSmat2004-08-081-0/+3 * Oh, I did let that through, bad memat2004-08-081-3/+0 * Update the website URL.joe2004-08-081-1/+1 * - We are no more forced to used libdbiclement2004-08-082-2/+52 * net/pdtpd was renamed to net/squall.kuriyama2004-08-085-43/+0 * Remove net/pdtpd.kuriyama2004-08-081-1/+0 * Add mod_auth_cookie_mysql2 0.3clement2004-08-085-0/+44 * - Update to 1.4clement2004-08-082-4/+11 * - Remove useless PHP modules dependencies.clement2004-08-081-1/+1 * - Update to ssmtp_2.60.12.clement2004-08-082-3/+3 * p5-Alzabo --> ports/devel/p5-Alzabomat2004-08-081-0/+1 * Add p5-Alzabo 0.83, a data modelling tool and RDBMS-OO mapper.mat2004-08-086-0/+187 * update to 4.0.7oliver2004-08-082-3/+3 * update to 3.0.7oliver2004-08-082-4/+4 * Drop maintainership.krion2004-08-0815-15/+15 * pdtpd has been renamed to squall.kuriyama2004-08-081-0/+1 * spamass-rules --> ports/mail/spamass-rulesmat2004-08-081-0/+1 * Add spamass-rules 20040807, custom rulesets for SpamAssassin.mat2004-08-086-0/+162 * squall --> ports/net/squallkuriyama2004-08-081-0/+1 * Add squall (renamed from pdtpd).kuriyama2004-08-08