aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-06-06 04:58:00 +0800
committergarga <garga@FreeBSD.org>2010-06-06 04:58:00 +0800
commit3403ceaa39af1fa25b2ea969ce558503a22eb84c (patch)
tree18648eebb419b30c97381bde87f6156335d7deec
parent99ee243efafef7ba021589cc92cd04759c2b4ae6 (diff)
downloadfreebsd-ports-graphics-3403ceaa39af1fa25b2ea969ce558503a22eb84c.tar.gz
freebsd-ports-graphics-3403ceaa39af1fa25b2ea969ce558503a22eb84c.tar.zst
freebsd-ports-graphics-3403ceaa39af1fa25b2ea969ce558503a22eb84c.zip
- Fix port because it was not installing php5-pdo_pgsql depend
- Add php5-pgsql as RUN_DEPEND to minimize PostgreSQL verisioning conflicts - Bump PORTREVISION PR: ports/146874 Submitted by: Patrick Tracanelli <eksffa@freebsdbrasil.com.br> (maintainer)
-rw-r--r--www/thundercache/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index a98735ee799..2f8fc0de6cd 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= thundercache
PORTVERSION= 4.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://www.bmsoftware.org/freebsd/ \
http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
@@ -57,16 +57,17 @@ WANT_PGSQL_VER= 84
RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.endif
+.if defined(WITH_PHP) && defined(WITH_PGSQL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pgsql.so:${PORTSDIR}/databases/php5-pgsql
+.endif
+
.if defined(WITH_PHP)
-USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql
+USE_PHP+= curl pcre bcmath pdo mcrypt mhash session
.endif
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl:install
-.if defined(APACHE+PHP) && defined(WITH_PGSQL)
-LIB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-.endif
-
SUB_FILES= pkg-message log.sh test-deps.sh
SUB_LIST= "GREP=${GREP}"