aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-08 02:01:24 +0800
committerpav <pav@FreeBSD.org>2005-07-08 02:01:24 +0800
commit3478b0aff72965ba0e69ec5f3d9ba08779ebe3cc (patch)
tree22d8c9e4987842073ec76c2f5038602d80bed72e
parentca80ef3117c044b2c9efe43b8cdb55aa7e55b968 (diff)
downloadfreebsd-ports-graphics-3478b0aff72965ba0e69ec5f3d9ba08779ebe3cc.tar.gz
freebsd-ports-graphics-3478b0aff72965ba0e69ec5f3d9ba08779ebe3cc.tar.zst
freebsd-ports-graphics-3478b0aff72965ba0e69ec5f3d9ba08779ebe3cc.zip
- Always use external gettext
- Bring in fresh makeinfo so HTML manual can be build [1] Reported by: krismail [1]
-rw-r--r--math/R/Makefile7
-rw-r--r--math/R/pkg-plist6
2 files changed, 12 insertions, 1 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 4090426a676..f2c6e60d329 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -8,6 +8,7 @@
PORTNAME= R
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
ftp://cran.r-project.org/pub/R/src/base/R-2/ \
@@ -48,6 +49,7 @@ CONFIGURE_ARGS= --with-lapack="-llapack" --with-blas="-lblas"
MAN1= R.1
GNU_CONFIGURE= yes
+USE_GETTEXT= yes
USE_XLIB= yes
USE_PERL5= yes
CONFIGURE_ENV= FFLAGS="${FFLAGS}" \
@@ -79,4 +81,9 @@ check-all: build
CONFIGURE_ARGS+= --disable-mbcs
.endif
+.if ${OSVERSION} < 600000
+CONFIGURE_ENV+= MAKEINFO_CMD=${LOCALBASE}/bin/makeinfo
+BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
+.endif
+
.include <bsd.port.post.mk>
diff --git a/math/R/pkg-plist b/math/R/pkg-plist
index e3e5a353d91..f2c4b95d8a5 100644
--- a/math/R/pkg-plist
+++ b/math/R/pkg-plist
@@ -58,11 +58,15 @@ lib/R/doc/html/search/index.txt
lib/R/doc/html/template.html
lib/R/doc/html/thanks.html
lib/R/doc/html/up.jpg
+lib/R/doc/manual/R-FAQ.html
lib/R/doc/manual/R-admin.html
+lib/R/doc/manual/R-data.html
+lib/R/doc/manual/R-exts.html
+lib/R/doc/manual/R-intro.html
+lib/R/doc/manual/R-lang.html
lib/R/etc/Makeconf
lib/R/etc/Renviron
lib/R/etc/repositories
-lib/R/include/libintl.h
lib/R/include/R.h
lib/R/include/R_ext/Applic.h
lib/R/include/R_ext/Arith.h