aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-08-11 18:56:12 +0800
committerwen <wen@FreeBSD.org>2011-08-11 18:56:12 +0800
commit36c3ed5c63aaa62a7ff13e1931f4a307c5577ae0 (patch)
tree380fcfbff02956473809f1869fc2289e8e807f3f
parentd8633531c31cc1c88767363b6f03f3be7e8ed3fa (diff)
downloadfreebsd-ports-graphics-36c3ed5c63aaa62a7ff13e1931f4a307c5577ae0.tar.gz
freebsd-ports-graphics-36c3ed5c63aaa62a7ff13e1931f4a307c5577ae0.tar.zst
freebsd-ports-graphics-36c3ed5c63aaa62a7ff13e1931f4a307c5577ae0.zip
File::ShareDir::PathClass is just a wrapper around File::ShareDir
functions, transforming their return value to Path::Class objects. This allows for easier usage of the value. WWW: http://search.cpan.org/dist/File-ShareDir-PathClass/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-ShareDir-PathClass/Makefile26
-rw-r--r--devel/p5-File-ShareDir-PathClass/distinfo2
-rw-r--r--devel/p5-File-ShareDir-PathClass/pkg-descr5
-rw-r--r--devel/p5-File-ShareDir-PathClass/pkg-plist3
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f1aab752e62..fc191cb6505 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1705,6 +1705,7 @@
SUBDIR += p5-File-ShareDir
SUBDIR += p5-File-ShareDir-Install
SUBDIR += p5-File-ShareDir-PAR
+ SUBDIR += p5-File-ShareDir-PathClass
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Slurp-Tree
SUBDIR += p5-File-Stream
diff --git a/devel/p5-File-ShareDir-PathClass/Makefile b/devel/p5-File-ShareDir-PathClass/Makefile
new file mode 100644
index 00000000000..60bcb91581b
--- /dev/null
+++ b/devel/p5-File-ShareDir-PathClass/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-File-ShareDir-PathClass
+# Date created: Aug 10, 2011
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ShareDir-PathClass
+PORTVERSION= 1.101620
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= File::ShareDir returning Path::Class objects
+
+BUILD_DEPENDS= p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= File::ShareDir::PathClass.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-ShareDir-PathClass/distinfo b/devel/p5-File-ShareDir-PathClass/distinfo
new file mode 100644
index 00000000000..872705ca3ca
--- /dev/null
+++ b/devel/p5-File-ShareDir-PathClass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-ShareDir-PathClass-1.101620.tar.gz) = 8163b3c1a273f655d9a1b96f0503a8467645e00439a9667168a8277c6179d4aa
+SIZE (File-ShareDir-PathClass-1.101620.tar.gz) = 14925
diff --git a/devel/p5-File-ShareDir-PathClass/pkg-descr b/devel/p5-File-ShareDir-PathClass/pkg-descr
new file mode 100644
index 00000000000..6e058288b41
--- /dev/null
+++ b/devel/p5-File-ShareDir-PathClass/pkg-descr
@@ -0,0 +1,5 @@
+File::ShareDir::PathClass is just a wrapper around File::ShareDir
+functions, transforming their return value to Path::Class objects.
+This allows for easier usage of the value.
+
+WWW: http://search.cpan.org/dist/File-ShareDir-PathClass/
diff --git a/devel/p5-File-ShareDir-PathClass/pkg-plist b/devel/p5-File-ShareDir-PathClass/pkg-plist
new file mode 100644
index 00000000000..6574fda23c3
--- /dev/null
+++ b/devel/p5-File-ShareDir-PathClass/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/File/ShareDir/PathClass.pm
+@dirrmtry %%SITE_PERL%%/File/ShareDir
+@dirrmtry %%SITE_PERL%%/File