aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2006-02-10 07:43:50 +0800
committerbrooks <brooks@FreeBSD.org>2006-02-10 07:43:50 +0800
commit37f1de635e29244a55c9e08a59dc564d7bf55b6b (patch)
tree8fe683cdf84adc37a31c2cc0083ec066e0341dd7
parent29bd08d443375bae5d9d2a9198dc0f1ad75c67f3 (diff)
downloadfreebsd-ports-graphics-37f1de635e29244a55c9e08a59dc564d7bf55b6b.tar.gz
freebsd-ports-graphics-37f1de635e29244a55c9e08a59dc564d7bf55b6b.tar.zst
freebsd-ports-graphics-37f1de635e29244a55c9e08a59dc564d7bf55b6b.zip
Actually compile on amd64. This required copying in the config.guess
replacement code from bsd.port.mk because pubcookie lives in a subdirectory of PREFIX and thus actually defining GNU_CONFIGURE won't work. Point hat: brooks
-rw-r--r--www/mod_pubcookie/Makefile11
-rw-r--r--www/pubcookie-login-server/Makefile11
2 files changed, 22 insertions, 0 deletions
diff --git a/www/mod_pubcookie/Makefile b/www/mod_pubcookie/Makefile
index 6b81b84cd7f..46de63b79e7 100644
--- a/www/mod_pubcookie/Makefile
+++ b/www/mod_pubcookie/Makefile
@@ -47,6 +47,17 @@ CONF_FILES+= ${PC_BASE}/config.sample:${PC_BASE}/config
# XXX Add Kerberos
+# XXX: more GNU_CONFIGURE hackery
+pre-configure:
+ @CONFIG_GUESS_DIRS=$$(${FIND} ${WRKDIR} -name config.guess -o -name config.sub \
+ | ${XARGS} -n 1 ${DIRNAME}); \
+ for _D in $${CONFIG_GUESS_DIRS}; do \
+ ${CP} -f ${TEMPLATES}/config.guess $${_D}/config.guess; \
+ ${CHMOD} a+rx $${_D}/config.guess; \
+ ${CP} -f ${TEMPLATES}/config.sub $${_D}/config.sub; \
+ ${CHMOD} a+rx $${_D}/config.sub; \
+ done
+
do-install:
${MKDIR} ${PC_DIR}/keys
${INSTALL_PROGRAM} ${WRKSRC}/keyclient ${PC_DIR}
diff --git a/www/pubcookie-login-server/Makefile b/www/pubcookie-login-server/Makefile
index cbf9d300a40..11675a79e63 100644
--- a/www/pubcookie-login-server/Makefile
+++ b/www/pubcookie-login-server/Makefile
@@ -59,6 +59,17 @@ LIB_DEPENDS+= fcgi.0:${PORTSDIR}/www/fcgi
CONFIGURE_ARGS+= --with-fcgi=${LOCALBASE}
.endif
+# XXX: more GNU_CONFIGURE hackery
+pre-configure:
+ @CONFIG_GUESS_DIRS=$$(${FIND} ${WRKDIR} -name config.guess -o -name config.sub \
+ | ${XARGS} -n 1 ${DIRNAME}); \
+ for _D in $${CONFIG_GUESS_DIRS}; do \
+ ${CP} -f ${TEMPLATES}/config.guess $${_D}/config.guess; \
+ ${CHMOD} a+rx $${_D}/config.guess; \
+ ${CP} -f ${TEMPLATES}/config.sub $${_D}/config.sub; \
+ ${CHMOD} a+rx $${_D}/config.sub; \
+ done
+
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL