aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-25 05:20:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-25 05:20:13 +0800
commit3843b73efe7b45bd41573db6849ebf43a4f33f51 (patch)
tree8f8de770eebb8861413f3a34f51f94cbd102e7a1
parent739c2fbe8e3136b0d926f37e1f6a4ded3c92195b (diff)
downloadfreebsd-ports-graphics-3843b73efe7b45bd41573db6849ebf43a4f33f51.tar.gz
freebsd-ports-graphics-3843b73efe7b45bd41573db6849ebf43a4f33f51.tar.zst
freebsd-ports-graphics-3843b73efe7b45bd41573db6849ebf43a4f33f51.zip
- Add LICENSE
- Drop 8.x support Approved by: portmgr blanket
-rw-r--r--devel/libdisorder/Makefile14
-rw-r--r--devel/libdisorder/files/extra-patch-disorder.c13
2 files changed, 3 insertions, 24 deletions
diff --git a/devel/libdisorder/Makefile b/devel/libdisorder/Makefile
index aea691a8c1b..6a63b79f109 100644
--- a/devel/libdisorder/Makefile
+++ b/devel/libdisorder/Makefile
@@ -9,22 +9,14 @@ MASTER_SITES= http://libdisorder.freshdefense.net/releases/
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Simple C library for entropy measurement
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 900027
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-disorder.c
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/src/Makefile
-do-build:
- cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${MAKE}
-
do-install:
${INSTALL_DATA} ${WRKSRC}/include/disorder.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/lib/libdisorder.a ${STAGEDIR}${PREFIX}/lib
@@ -33,4 +25,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tool/ropy ${STAGEDIR}${PREFIX}/bin
${LN} -sf ${PREFIX}/lib/libdisorder.so.1 ${STAGEDIR}${PREFIX}/lib/libdisorder.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libdisorder/files/extra-patch-disorder.c b/devel/libdisorder/files/extra-patch-disorder.c
deleted file mode 100644
index 4688ab9b59c..00000000000
--- a/devel/libdisorder/files/extra-patch-disorder.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/disorder.c.orig 2010-08-17 16:15:30.000000000 +0800
-+++ src/disorder.c 2010-08-17 16:22:27.000000000 +0800
-@@ -25,6 +25,10 @@
- #include <stdio.h> //for NULL
- #include "../include/disorder.h"
-
-+#if defined(__FreeBSD__)
-+#define log2(x) (log((x)) * (1./M_LN2))
-+#endif
-+
- /** Frequecies for each byte */
- static int m_token_freqs[LIBDO_MAX_BYTES]; //frequency of each token in sample
- static float m_token_probs[LIBDO_MAX_BYTES]; //P(each token appearing)