aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-02 02:15:28 +0800
committerbapt <bapt@FreeBSD.org>2013-05-02 02:15:28 +0800
commit3969e3713debb1e1328b184deacb63d23329d331 (patch)
tree30d58c458fecfa268a4fb9e31237ab7dd6c15d4c
parentf021f96baedbbcf3672600e3da08760dc7ba782e (diff)
downloadfreebsd-ports-graphics-3969e3713debb1e1328b184deacb63d23329d331.tar.gz
freebsd-ports-graphics-3969e3713debb1e1328b184deacb63d23329d331.tar.zst
freebsd-ports-graphics-3969e3713debb1e1328b184deacb63d23329d331.zip
Dramatically reduce the diskspace used for building bjam -- by extracting
only the tools/build/v2/engine subdirectory from the source tarball, instead of the whole thing. Plenty of time is saved too -- though the giant tarball still needs to be full read, most of the contents does not need to be written to disk Allow building the executable with any compiler from the gcc-family (such as gcc48) Submitted by: mi
-rw-r--r--devel/boost-jam/Makefile2
-rw-r--r--devel/boost-jam/files/patch-tools__build__v2__engine__build.sh14
2 files changed, 16 insertions, 0 deletions
diff --git a/devel/boost-jam/Makefile b/devel/boost-jam/Makefile
index 6ced417ad34..a54161cf54a 100644
--- a/devel/boost-jam/Makefile
+++ b/devel/boost-jam/Makefile
@@ -8,6 +8,8 @@ PORTREVISION= 1
PLIST_FILES= bin/bjam
+EXTRACT_AFTER_ARGS= ${DISTNAME}/tools/build/v2/engine
+
.include "${.CURDIR}/../boost-all/common.mk"
do-build:
diff --git a/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh b/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh
new file mode 100644
index 00000000000..f94d6007db3
--- /dev/null
+++ b/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh
@@ -0,0 +1,14 @@
+--- ./tools/build/v2/engine/build.sh.orig 2012-04-26 05:35:55.000000000 +0200
++++ ./tools/build/v2/engine/build.sh 2013-05-01 10:24:50.730247378 +0200
+@@ -128,8 +128,9 @@
+ BOOST_JAM_CC="gcc -DNT"
+ ;;
+
+- gcc)
+- BOOST_JAM_CC=gcc
++ gcc*)
++ BOOST_JAM_CC=$BOOST_JAM_TOOLSET
++ BOOST_JAM_TOOLSET=gcc
+ ;;
+
+ darwin)