aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-06-11 01:01:03 +0800
committerjkim <jkim@FreeBSD.org>2015-06-11 01:01:03 +0800
commit3aab2d391b7c68b7ebcf306bcf4270611b419fba (patch)
tree17c745a381e72dbdf0d6f0dcce57b6a33b658e2a
parentffa088ae53a4f31f122ba3b1de6f22c33fd52d1b (diff)
downloadfreebsd-ports-graphics-3aab2d391b7c68b7ebcf306bcf4270611b419fba.tar.gz
freebsd-ports-graphics-3aab2d391b7c68b7ebcf306bcf4270611b419fba.tar.zst
freebsd-ports-graphics-3aab2d391b7c68b7ebcf306bcf4270611b419fba.zip
Python binding for the lz4 compression library by Yann Collet.
WWW: https://github.com/steeve/python-lz4
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-lz4/Makefile20
-rw-r--r--archivers/py-lz4/distinfo2
-rw-r--r--archivers/py-lz4/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index fe6f10a7576..8146df2074d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -161,6 +161,7 @@
SUBDIR += pxz
SUBDIR += py-liblzma
SUBDIR += py-librtfcomp
+ SUBDIR += py-lz4
SUBDIR += py-lzma
SUBDIR += py-python-snappy
SUBDIR += qpress
diff --git a/archivers/py-lz4/Makefile b/archivers/py-lz4/Makefile
new file mode 100644
index 00000000000..1daf0c92b91
--- /dev/null
+++ b/archivers/py-lz4/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= lz4
+PORTVERSION= 0.7.0
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python binding for the LZ4 compression library
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON= autoplist distutils
+USES= python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/lz4.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-lz4/distinfo b/archivers/py-lz4/distinfo
new file mode 100644
index 00000000000..82d26708057
--- /dev/null
+++ b/archivers/py-lz4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lz4-0.7.0.tar.gz) = cd225744298568fd217577fc14a326a24835412374dadb5060db48f1af43eb48
+SIZE (lz4-0.7.0.tar.gz) = 26786
diff --git a/archivers/py-lz4/pkg-descr b/archivers/py-lz4/pkg-descr
new file mode 100644
index 00000000000..170126623e5
--- /dev/null
+++ b/archivers/py-lz4/pkg-descr
@@ -0,0 +1,3 @@
+Python binding for the lz4 compression library by Yann Collet.
+
+WWW: https://github.com/steeve/python-lz4