aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-07-05 00:48:15 +0800
committermatthew <matthew@FreeBSD.org>2016-07-05 00:48:15 +0800
commit3f9e24352268c52dbf77d45a76489fe2b9c69c23 (patch)
treec8fcfeaaeb822fb09c41c77f7efd70e2f753a7b8
parent45cd5274a35053ef5e43773b6db1f5544f7cfc9c (diff)
downloadfreebsd-ports-graphics-3f9e24352268c52dbf77d45a76489fe2b9c69c23.tar.gz
freebsd-ports-graphics-3f9e24352268c52dbf77d45a76489fe2b9c69c23.tar.zst
freebsd-ports-graphics-3f9e24352268c52dbf77d45a76489fe2b9c69c23.zip
csvkit is a suite of command-line tools for converting to and working
with CSV, the king of tabular file formats.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-csvkit/Makefile25
-rw-r--r--textproc/py-csvkit/distinfo3
-rw-r--r--textproc/py-csvkit/files/patch-csvkit.egg-info_requires.txt12
-rw-r--r--textproc/py-csvkit/files/patch-setup.py23
-rw-r--r--textproc/py-csvkit/pkg-descr2
6 files changed, 66 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 129a80e405a..bd165545b06 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1226,6 +1226,7 @@
SUBDIR += py-chardet
SUBDIR += py-cloud_sptheme
SUBDIR += py-creole
+ SUBDIR += py-csvkit
SUBDIR += py-dbf
SUBDIR += py-dbfread
SUBDIR += py-diff-match-patch
diff --git a/textproc/py-csvkit/Makefile b/textproc/py-csvkit/Makefile
new file mode 100644
index 00000000000..a15e6a84029
--- /dev/null
+++ b/textproc/py-csvkit/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= csvkit
+PORTVERSION= 0.9.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Command line tools for working with CSV
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}agate-dbf>=0.1.0:textproc/py-agate-dbf \
+ ${PYTHON_PKGNAMEPREFIX}agate-excel>=0.1.0:textproc/py-agate-excel \
+ ${PYTHON_PKGNAMEPREFIX}agate>=1.2.2:textproc/py-agate \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.2:devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}dbf>0.94.003:textproc/py-dbf \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy09>=0.9.3:databases/py-sqlalchemy09
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/textproc/py-csvkit/distinfo b/textproc/py-csvkit/distinfo
new file mode 100644
index 00000000000..ac6291d364b
--- /dev/null
+++ b/textproc/py-csvkit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463399029
+SHA256 (csvkit-0.9.1.tar.gz) = 92f8b8647becb5cb1dccb3af92a13a4e85702d42ba465ce8447881fb38c9f93a
+SIZE (csvkit-0.9.1.tar.gz) = 34170
diff --git a/textproc/py-csvkit/files/patch-csvkit.egg-info_requires.txt b/textproc/py-csvkit/files/patch-csvkit.egg-info_requires.txt
new file mode 100644
index 00000000000..59f39ab4502
--- /dev/null
+++ b/textproc/py-csvkit/files/patch-csvkit.egg-info_requires.txt
@@ -0,0 +1,12 @@
+--- csvkit.egg-info/requires.txt.orig 2015-03-31 02:06:59 UTC
++++ csvkit.egg-info/requires.txt
+@@ -1,6 +1,6 @@
+ xlrd>=0.7.1
+ sqlalchemy>=0.6.6
+-openpyxl==2.2.0-b1
++openpyxl>=2.2.0-b1
+ six>=1.6.1
+-python-dateutil==2.2
+-dbf==0.94.003
++python-dateutil>=2.2
++dbf>=0.94.003
diff --git a/textproc/py-csvkit/files/patch-setup.py b/textproc/py-csvkit/files/patch-setup.py
new file mode 100644
index 00000000000..dc018708900
--- /dev/null
+++ b/textproc/py-csvkit/files/patch-setup.py
@@ -0,0 +1,23 @@
+--- setup.py.orig 2015-03-31 01:07:39 UTC
++++ setup.py
+@@ -6,9 +6,9 @@ from setuptools import setup
+ install_requires = [
+ 'xlrd>=0.7.1',
+ 'sqlalchemy>=0.6.6',
+- 'openpyxl==2.2.0-b1',
++ 'openpyxl>=2.2.0-b1',
+ 'six>=1.6.1',
+- 'python-dateutil==2.2'
++ 'python-dateutil>=2.2'
+ ]
+
+ if sys.version_info < (2, 7):
+@@ -17,7 +17,7 @@ if sys.version_info < (2, 7):
+ install_requires.append('simplejson>=3.6.3')
+
+ if sys.version_info[0] == 2:
+- install_requires.append('dbf==0.94.003')
++ install_requires.append('dbf>=0.94.003')
+
+ setup(
+ name='csvkit',
diff --git a/textproc/py-csvkit/pkg-descr b/textproc/py-csvkit/pkg-descr
new file mode 100644
index 00000000000..0eadbd21190
--- /dev/null
+++ b/textproc/py-csvkit/pkg-descr
@@ -0,0 +1,2 @@
+csvkit is a suite of command-line tools for converting to and working
+with CSV, the king of tabular file formats.