aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-23 19:45:21 +0800
committerbapt <bapt@FreeBSD.org>2013-09-23 19:45:21 +0800
commit40e51ccd75c60c88e0c84ef8634a650775f32d8a (patch)
treeeb6cd08c9a92b5c2c11f79f7cc9664f09b9d4d49
parent6debbcde0652e4e0779564ba94ded707d5986b23 (diff)
downloadfreebsd-ports-graphics-40e51ccd75c60c88e0c84ef8634a650775f32d8a.tar.gz
freebsd-ports-graphics-40e51ccd75c60c88e0c84ef8634a650775f32d8a.tar.zst
freebsd-ports-graphics-40e51ccd75c60c88e0c84ef8634a650775f32d8a.zip
Use macro when possible
Reported by: ak
-rw-r--r--Mk/bsd.stage.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.stage.mk b/Mk/bsd.stage.mk
index 1be700668da..bb3c32d5ec4 100644
--- a/Mk/bsd.stage.mk
+++ b/Mk/bsd.stage.mk
@@ -82,12 +82,12 @@ makeplist: stage
[ -z "$${a}" ] && break ; \
${ECHO_CMD} $${a} >> ${WRKDIR}/.mtree ; \
done
- @${FIND} ${STAGEDIR} -type f -o -type l | sort | ${SED} -e "s,${STAGEDIR},,g" \
+ @${FIND} ${STAGEDIR} -type f -o -type l | ${SORT} | ${SED} -e "s,${STAGEDIR},,g" \
-e "s,${DOCSDIR},%%PORTDOCS%%%%DOCSDIR%%,g" \
-e "s,${EXAMPLESDIR},%%PORTEXAMPLES%%%%EXAMPLESDIR%%,g" \
-e "s,${DATADIR},%%DATADIR%%,g" \
- -e "s,${PREFIX}/,,g" | grep -v "^share/licenses" || ${TRUE}
- @${FIND} ${STAGEDIR} -type d | sed -e "s,${STAGEDIR},,g" \
+ -e "s,${PREFIX}/,,g" | ${GREP} -v "^share/licenses" || ${TRUE}
+ @${FIND} ${STAGEDIR} -type d | ${SED} -e "s,${STAGEDIR},,g" \
| while read line; do \
${GREP} -qw "^$${line}$$" ${WRKDIR}/.mtree || { \
[ -n "$${line}" ] && ${ECHO_CMD} "@dirrmtry $${line}"; \
@@ -96,5 +96,5 @@ makeplist: stage
-e "s,\(.*\)${DOCSDIR},%%PORTDOCS%%\1%%DOCSDIR%%,g" \
-e "s,\(.*\)${EXAMPLESDIR},%%PORTEXAMPLES%%\1%%EXAMPLESDIR%%,g" \
-e "s,${DATADIR},%%DATADIR%%,g" \
- -e "s,${PREFIX}/,,g" | grep -v "^@dirrmtry share/licenses" || ${TRUE}
+ -e "s,${PREFIX}/,,g" | ${GREP} -v "^@dirrmtry share/licenses" || ${TRUE}
.endif