aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2011-01-20 19:07:06 +0800
committerarved <arved@FreeBSD.org>2011-01-20 19:07:06 +0800
commit41a280366a58154ef16819f303bf5981c4ffe6d7 (patch)
treece83edeb0a899989e1c43d1f8cfb2ccb5a3c1299
parent71ea7c03d4bb914153373290f93f73479c2a50b4 (diff)
downloadfreebsd-ports-graphics-41a280366a58154ef16819f303bf5981c4ffe6d7.tar.gz
freebsd-ports-graphics-41a280366a58154ef16819f303bf5981c4ffe6d7.tar.zst
freebsd-ports-graphics-41a280366a58154ef16819f303bf5981c4ffe6d7.zip
Fix build on amd64
Feature safe: yes
-rw-r--r--games/battleball/Makefile4
-rw-r--r--games/battleball/files/patch-lib3d-bsppanel3d.C11
-rw-r--r--games/battleball/files/patch-lib3d-bspregion3d.C11
3 files changed, 22 insertions, 4 deletions
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index 7470c7f74ce..bf2f0c383ff 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -31,10 +31,6 @@ PORTDOCS= CHANGELOG README
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
-BROKEN= Does not compile
-.endif
-
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64 or sparc64
.endif
diff --git a/games/battleball/files/patch-lib3d-bsppanel3d.C b/games/battleball/files/patch-lib3d-bsppanel3d.C
new file mode 100644
index 00000000000..3067ce05d59
--- /dev/null
+++ b/games/battleball/files/patch-lib3d-bsppanel3d.C
@@ -0,0 +1,11 @@
+--- lib3d/bsppanel3d.C.orig 2011-01-20 12:02:35.000000000 +0100
++++ lib3d/bsppanel3d.C 2011-01-20 12:03:32.000000000 +0100
+@@ -42,7 +42,7 @@
+ }
+
+ pt3d2Vec3f(normal,poly.plane_normal);
+- poly.material_index= (int) this;
++ poly.material_index= (intptr_t) this;
+ return poly;
+ }
+
diff --git a/games/battleball/files/patch-lib3d-bspregion3d.C b/games/battleball/files/patch-lib3d-bspregion3d.C
new file mode 100644
index 00000000000..f9d74f42fe3
--- /dev/null
+++ b/games/battleball/files/patch-lib3d-bspregion3d.C
@@ -0,0 +1,11 @@
+--- lib3d/bspregion3d.C.orig 2011-01-20 12:04:50.000000000 +0100
++++ lib3d/bspregion3d.C 2011-01-20 12:05:08.000000000 +0100
+@@ -97,7 +97,7 @@
+ xpanel3d& panel= * (xpanel3d *) poly->material_index;
+
+ poly->material_index=
+- (int) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
++ (intptr_t) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
+ }
+ MakeBspTreePanels(bspt->negative);
+ MakeBspTreePanels(bspt->positive);