aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-07-05 23:02:56 +0800
committercpm <cpm@FreeBSD.org>2016-07-05 23:02:56 +0800
commit42c2259373861b40cd1b5ab2d317240c36e1a1eb (patch)
treee3d292f218828a2612d1d4c7368ca9145d0bc5f7
parentd393c3b6bd96ff2cd98175d8990b25dd13c51fbb (diff)
downloadfreebsd-ports-graphics-42c2259373861b40cd1b5ab2d317240c36e1a1eb.tar.gz
freebsd-ports-graphics-42c2259373861b40cd1b5ab2d317240c36e1a1eb.tar.zst
freebsd-ports-graphics-42c2259373861b40cd1b5ab2d317240c36e1a1eb.zip
New port: net/py-uritemplate.py
Simple python library to deal with URI Templates. WWW: https://uritemplate.readthedocs.org/ Reviewed by: amdmi3, junovitch, feld (mentors) Approved by: amdmi3, junovitch, feld (mentors) Differential Revision: D6730
-rw-r--r--net/Makefile1
-rw-r--r--net/py-uritemplate.py/Makefile23
-rw-r--r--net/py-uritemplate.py/distinfo3
-rw-r--r--net/py-uritemplate.py/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 077c7f5d4b4..68b778cc81b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1022,6 +1022,7 @@
SUBDIR += py-txamqp
SUBDIR += py-txrestapi
SUBDIR += py-uritemplate
+ SUBDIR += py-uritemplate.py
SUBDIR += py-urllib3
SUBDIR += py-wolframalpha
SUBDIR += py-xmlrpc
diff --git a/net/py-uritemplate.py/Makefile b/net/py-uritemplate.py/Makefile
new file mode 100644
index 00000000000..830b8532ab0
--- /dev/null
+++ b/net/py-uritemplate.py/Makefile
@@ -0,0 +1,23 @@
+# Created by: Carlos J. Puga Medina <cpm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= uritemplate.py
+PORTVERSION= 0.3.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cpm@FreeBSD.org
+COMMENT= Simple python library to deal with URI Templates
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= py*-uritemplate-[0-9]*
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-uritemplate.py/distinfo b/net/py-uritemplate.py/distinfo
new file mode 100644
index 00000000000..0d9c4aa6368
--- /dev/null
+++ b/net/py-uritemplate.py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465077405
+SHA256 (uritemplate.py-0.3.0.tar.gz) = fd79aa529a7968c62d96ac6731a94349c5a615dac74968526c573c65796c7b77
+SIZE (uritemplate.py-0.3.0.tar.gz) = 6916
diff --git a/net/py-uritemplate.py/pkg-descr b/net/py-uritemplate.py/pkg-descr
new file mode 100644
index 00000000000..aec31cf9908
--- /dev/null
+++ b/net/py-uritemplate.py/pkg-descr
@@ -0,0 +1,3 @@
+Simple python library to deal with URI Templates.
+
+WWW: https://uritemplate.readthedocs.org/