aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-02-13 14:50:09 +0800
committeredwin <edwin@FreeBSD.org>2004-02-13 14:50:09 +0800
commit42dc63befc9c79165f10b6e53d2a6a420bc2558d (patch)
tree8254da60d04b2a8a48618ffe920fb8335ff98f44
parentc1f1fd5d75c198788d62127daede81d351630473 (diff)
downloadfreebsd-ports-graphics-42dc63befc9c79165f10b6e53d2a6a420bc2558d.tar.gz
freebsd-ports-graphics-42dc63befc9c79165f10b6e53d2a6a420bc2558d.tar.zst
freebsd-ports-graphics-42dc63befc9c79165f10b6e53d2a6a420bc2558d.zip
New port: databases/postgresql-relay
postgresql-relay - multiplex all your databases to one point of origin postgresql-relay can be used to as a single point of origin for all your databases. Instead of having to remember (or modify in case of changes) all the names of your databases, on which machines and on which ports they are running, you only need to remember one machine and the name of the database. The postgresql-relay will then forward the connection to the proper database on the proper port of the proper server. No more changes in the hundreds of clients and scripts!
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-relay/Makefile24
-rw-r--r--databases/postgresql-relay/distinfo2
-rw-r--r--databases/postgresql-relay/pkg-descr13
4 files changed, 40 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3000fede387..4619c73adc2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -191,6 +191,7 @@
SUBDIR += postgresql-odbc
SUBDIR += postgresql-plruby
SUBDIR += postgresql-pltcl
+ SUBDIR += postgresql-relay
SUBDIR += postgresql-tcltk
SUBDIR += postgresql7
SUBDIR += postgresql72
diff --git a/databases/postgresql-relay/Makefile b/databases/postgresql-relay/Makefile
new file mode 100644
index 00000000000..411d443bc50
--- /dev/null
+++ b/databases/postgresql-relay/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: postgresql-relay
+# Date created: 14 February 2003
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql-relay
+PORTVERSION= 1.2
+CATEGORIES= databases net
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Multiplex multiple PostgreSQL databases to one relay
+
+MAN8= postgresql-relay.8
+PLIST_FILES= bin/postgresql-relay etc/postgresql-relay.conf-sample
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/postgresql-relay ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/postgresql-relay.conf ${PREFIX}/etc/postgresql-relay.conf-sample
+ ${INSTALL_MAN} ${WRKSRC}/postgresql-relay.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-relay/distinfo b/databases/postgresql-relay/distinfo
new file mode 100644
index 00000000000..dfc384aa72a
--- /dev/null
+++ b/databases/postgresql-relay/distinfo
@@ -0,0 +1,2 @@
+MD5 (postgresql-relay-1.2.tar.gz) = 4b2ceeb8fbab310acecb2a3aa407dee4
+SIZE (postgresql-relay-1.2.tar.gz) = 9248
diff --git a/databases/postgresql-relay/pkg-descr b/databases/postgresql-relay/pkg-descr
new file mode 100644
index 00000000000..d0dbd38e640
--- /dev/null
+++ b/databases/postgresql-relay/pkg-descr
@@ -0,0 +1,13 @@
+postgresql-relay can be used to as a single point of origin for all
+your databases. Instead of having to remember (or modify in case
+of changes) all the names of your databases, on which machines and
+on which ports they are running, you only need to remember one
+machine and the name of the database. The postgresql-relay will
+then forward the connection to the proper database on the proper
+port of the proper server. No more changes in the hundreds of clients
+and scripts!
+
+WWW: http://www.mavetju.org/unix/general.php
+
+- Edwin Groothuis
+edwin@mavetju.org