aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-24 21:14:23 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-24 21:14:23 +0800
commit43ee37726dcd505c6a2278cf6fb0f95f59e73fa7 (patch)
treeb0b7973c5394aa8a0beb0ccbbcdf6bd266c09cbe
parent13c613a32de5df148ea68ab3faa586a22a5eac81 (diff)
downloadfreebsd-ports-graphics-43ee37726dcd505c6a2278cf6fb0f95f59e73fa7.tar.gz
freebsd-ports-graphics-43ee37726dcd505c6a2278cf6fb0f95f59e73fa7.tar.zst
freebsd-ports-graphics-43ee37726dcd505c6a2278cf6fb0f95f59e73fa7.zip
add p5-Imager
A Perl module for manipulating gray, color and rgba format images
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Imager/Makefile35
-rw-r--r--graphics/p5-Imager/distinfo1
-rw-r--r--graphics/p5-Imager/files/patch-Makefile.PL27
-rw-r--r--graphics/p5-Imager/pkg-comment1
-rw-r--r--graphics/p5-Imager/pkg-descr7
-rw-r--r--graphics/p5-Imager/pkg-plist14
7 files changed, 86 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 64a67d2fa53..26b3bab0b53 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -177,6 +177,7 @@
SUBDIR += p5-Graphics-ColorNames
SUBDIR += p5-Image-Grab
SUBDIR += p5-Image-Size
+ SUBDIR += p5-Imager
SUBDIR += p5-Imlib2
SUBDIR += p5-chart
SUBDIR += panorama
diff --git a/graphics/p5-Imager/Makefile b/graphics/p5-Imager/Makefile
new file mode 100644
index 00000000000..488635b1e86
--- /dev/null
+++ b/graphics/p5-Imager/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# New ports collection makefile for: p5-Imager
+# Date created: Jul 24, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Imager
+PORTVERSION= 0.38
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.eecs.umich.edu/~addi/perl/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
+ tiff:${PORTSDIR}/graphics/tiff \
+ png:${PORTSDIR}/graphics/png \
+ ungif:${PORTSDIR}/graphics/libungif \
+ jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_FREETYPE= yes
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= IM_LIBPATH="${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Imager.3 Imager::Color.3 Imager::Expr.3 Imager::Expr::Assem.3 \
+ Imager::Font.3 Imager::Regops.3 Imager::regmach.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Imager/distinfo b/graphics/p5-Imager/distinfo
new file mode 100644
index 00000000000..bc6d205c06f
--- /dev/null
+++ b/graphics/p5-Imager/distinfo
@@ -0,0 +1 @@
+MD5 (Imager-0.38.tar.gz) = 44b037145f030edc44a344c05fa532c6
diff --git a/graphics/p5-Imager/files/patch-Makefile.PL b/graphics/p5-Imager/files/patch-Makefile.PL
new file mode 100644
index 00000000000..261126c82fd
--- /dev/null
+++ b/graphics/p5-Imager/files/patch-Makefile.PL
@@ -0,0 +1,27 @@
+--- Makefile.PL.orig Tue Jul 24 20:48:12 2001
++++ Makefile.PL Tue Jul 24 20:51:11 2001
+@@ -141,24 +141,6 @@
+ }
+
+ RETR:
+- if ($formats{'gif'} or $formats{'ungif'}) {
+- print <<EOFF;
+-
+-You have libgif or libungif installed. They are both known to have
+-bugs. Imager can crash or display other strange behaviour after
+-reading or writing gif images. Some of the gif tests can even fail
+-since they stress some parts of the buggy code.
+-
+-Do you want to remove gif support? [Y/n]
+-EOFF
+- my $resp = <STDIN>;
+- chomp($resp);
+- if ($resp ne "n") {
+- delete $formats{'gif'};
+- delete $formats{'ungif'};
+- return;
+- }
+- }
+
+ for my $frm (qw(gif ungif)) {
+ checkformat($frm) if ($MANUAL and $formats{$frm});
diff --git a/graphics/p5-Imager/pkg-comment b/graphics/p5-Imager/pkg-comment
new file mode 100644
index 00000000000..6ff97e7552f
--- /dev/null
+++ b/graphics/p5-Imager/pkg-comment
@@ -0,0 +1 @@
+A Perl module for manipulating gray, color and rgba format images
diff --git a/graphics/p5-Imager/pkg-descr b/graphics/p5-Imager/pkg-descr
new file mode 100644
index 00000000000..3c5872e2bae
--- /dev/null
+++ b/graphics/p5-Imager/pkg-descr
@@ -0,0 +1,7 @@
+Imager is a perl module for manipulating gray, color and rgba format images.
+It can read various file formats and has a builtin interpretered language for
+blends, fade and multiimage effects. It also has a plugin interface to write
+plugins in C. It also has drawing primitives and supports antialiased truetype
+and postscript fonts.
+
+WWW: http://www.eecs.umich.edu/~addi/perl/Imager/
diff --git a/graphics/p5-Imager/pkg-plist b/graphics/p5-Imager/pkg-plist
new file mode 100644
index 00000000000..6ac1a31a388
--- /dev/null
+++ b/graphics/p5-Imager/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Color.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Expr.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Font.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Regops.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Transform.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/regmach.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Expr/Assem.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Imager/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Imager/Imager.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Imager/Imager.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Imager
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager/Expr
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Imager