aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-11 03:46:03 +0800
committerwill <will@FreeBSD.org>2001-04-11 03:46:03 +0800
commit44ed55502184c1707921a360ce4e1162bf4399b9 (patch)
tree4b43d134294ddc0e59e068cfe971d341aa6a2e3d
parenta515b1918c6eb95e347fbd56454d57e2ea648041 (diff)
downloadfreebsd-ports-graphics-44ed55502184c1707921a360ce4e1162bf4399b9.tar.gz
freebsd-ports-graphics-44ed55502184c1707921a360ce4e1162bf4399b9.tar.zst
freebsd-ports-graphics-44ed55502184c1707921a360ce4e1162bf4399b9.zip
Add p5-Params-Validate 0.03, a perl module to validate method/function
parameters. PR: 26477 Submitted by: Denis Shaposhnikov <dsh@vlink.ru>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Params-Validate/Makefile22
-rw-r--r--devel/p5-Params-Validate/distinfo1
-rw-r--r--devel/p5-Params-Validate/pkg-comment1
-rw-r--r--devel/p5-Params-Validate/pkg-descr7
-rw-r--r--devel/p5-Params-Validate/pkg-plist7
6 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 400ae3ceb4a..dd7e884084e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -300,6 +300,7 @@
SUBDIR += p5-Make
SUBDIR += p5-ORBit
SUBDIR += p5-PV
+ SUBDIR += p5-Params-Validate
SUBDIR += p5-Parse-RecDescent
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
diff --git a/devel/p5-Params-Validate/Makefile b/devel/p5-Params-Validate/Makefile
new file mode 100644
index 00000000000..826d809415a
--- /dev/null
+++ b/devel/p5-Params-Validate/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Params::Validate
+# Date created: 10 April 2001
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Params-Validate
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel/DROLSKY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dsh@vlink.ru
+
+PERL_CONFIGURE= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Params::Validate.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Params-Validate/distinfo b/devel/p5-Params-Validate/distinfo
new file mode 100644
index 00000000000..ba6e4241519
--- /dev/null
+++ b/devel/p5-Params-Validate/distinfo
@@ -0,0 +1 @@
+MD5 (Params-Validate-0.03.tar.gz) = db1b96fdd4cb9905eb3e9c49726eb9d8
diff --git a/devel/p5-Params-Validate/pkg-comment b/devel/p5-Params-Validate/pkg-comment
new file mode 100644
index 00000000000..797bd86089f
--- /dev/null
+++ b/devel/p5-Params-Validate/pkg-comment
@@ -0,0 +1 @@
+Validate method/function parameters
diff --git a/devel/p5-Params-Validate/pkg-descr b/devel/p5-Params-Validate/pkg-descr
new file mode 100644
index 00000000000..b8dae24ed6e
--- /dev/null
+++ b/devel/p5-Params-Validate/pkg-descr
@@ -0,0 +1,7 @@
+The Params::Validate module allows you to validate method or function
+call parameters to an arbitrary level of specificity. At the simplest
+level, it is capable of validating the required parameters were given
+and that no unspecified additional parameters were passed in. It is
+also capable of determining that a parameter is of a specific type,
+that it is an object of a certain class hierarchy, that it possesses
+certain methods, or applying validation callbacks to arguments.
diff --git a/devel/p5-Params-Validate/pkg-plist b/devel/p5-Params-Validate/pkg-plist
new file mode 100644
index 00000000000..b378ee698c2
--- /dev/null
+++ b/devel/p5-Params-Validate/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/Params/Validate/Heavy.pm
+lib/perl5/site_perl/%%PERL_VER%%/Params/Validate.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Params/Validate/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Params/Validate
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Params
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Params/Validate
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Params