aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2006-04-21 04:32:32 +0800
committerjoerg <joerg@FreeBSD.org>2006-04-21 04:32:32 +0800
commit46502ce6a8a8462aa2d0dc1783b12f25a4c25df4 (patch)
tree39dd835ee0640baa664e2a1bad8f564b458a1cb8
parenta21d2fb3446ec8368612255b21354ad6d2f19463 (diff)
downloadfreebsd-ports-graphics-46502ce6a8a8462aa2d0dc1783b12f25a4c25df4.tar.gz
freebsd-ports-graphics-46502ce6a8a8462aa2d0dc1783b12f25a4c25df4.tar.zst
freebsd-ports-graphics-46502ce6a8a8462aa2d0dc1783b12f25a4c25df4.zip
Fix the link specification in the patch so ATmega*P devices will get
their correct -Tdata option passed down. Submitted by: Anatoly Sokolov
-rw-r--r--devel/avr-gcc-3/Makefile2
-rw-r--r--devel/avr-gcc-3/files/patch-newdevices2
-rw-r--r--devel/avr-gcc-devel/Makefile2
-rw-r--r--devel/avr-gcc-devel/files/patch-newdevices2
-rw-r--r--devel/avr-gcc/Makefile2
-rw-r--r--devel/avr-gcc/files/patch-newdevices2
6 files changed, 6 insertions, 6 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 3b1acd87cd5..a3f0908eecc 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc-3/files/patch-newdevices b/devel/avr-gcc-3/files/patch-newdevices
index 30f86a8a2bd..6a3954d0f27 100644
--- a/devel/avr-gcc-3/files/patch-newdevices
+++ b/devel/avr-gcc-3/files/patch-newdevices
@@ -88,7 +88,7 @@ diff -ur ../gcc-3.4.6.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega406|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at90usb*|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
++%{mmcu=atmega324*|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644*|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164*|mmcu=atmega165*|mmcu=atmega168|mmcu=atmega169*|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
+%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
/* A C string constant that tells the GCC driver program options to
diff --git a/devel/avr-gcc-devel/Makefile b/devel/avr-gcc-devel/Makefile
index 8c8599d27e5..35661db96bf 100644
--- a/devel/avr-gcc-devel/Makefile
+++ b/devel/avr-gcc-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc-devel/files/patch-newdevices b/devel/avr-gcc-devel/files/patch-newdevices
index 8cc6cb00a2a..380b28108e7 100644
--- a/devel/avr-gcc-devel/files/patch-newdevices
+++ b/devel/avr-gcc-devel/files/patch-newdevices
@@ -82,7 +82,7 @@ diff -ur ../gcc-4.1.0.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega325|mmcu=atmega3250|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega128|mmcu=at90can128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega406|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at90usb*|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
++%{mmcu=atmega324*|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644*|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164*|mmcu=atmega165*|mmcu=atmega168|mmcu=atmega169*|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
+%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
#define LIB_SPEC \
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 3b1acd87cd5..a3f0908eecc 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc/files/patch-newdevices b/devel/avr-gcc/files/patch-newdevices
index 30f86a8a2bd..6a3954d0f27 100644
--- a/devel/avr-gcc/files/patch-newdevices
+++ b/devel/avr-gcc/files/patch-newdevices
@@ -88,7 +88,7 @@ diff -ur ../gcc-3.4.6.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega406|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at90usb*|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
++%{mmcu=atmega324*|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644*|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164*|mmcu=atmega165*|mmcu=atmega168|mmcu=atmega169*|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
+%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
/* A C string constant that tells the GCC driver program options to