aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2007-10-25 23:16:35 +0800
committertrasz <trasz@FreeBSD.org>2007-10-25 23:16:35 +0800
commit467a6f2d920b5ba0d8594798fa28572296f7b657 (patch)
treea24cafcc7f1eba49ce7348931e88fd80772b726c
parent4de3334b1b6ea4b0eb0d6cec902205e58d2913dd (diff)
downloadfreebsd-ports-graphics-467a6f2d920b5ba0d8594798fa28572296f7b657.tar.gz
freebsd-ports-graphics-467a6f2d920b5ba0d8594798fa28572296f7b657.tar.zst
freebsd-ports-graphics-467a6f2d920b5ba0d8594798fa28572296f7b657.zip
- Really fix build on RELENG_7/i386, and build with gcc42 in general.
- Fix plist. Tested by: miwi Submitted by: pointyhat via droso and pav
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc4
-rw-r--r--audio/ardour/pkg-plist6
2 files changed, 2 insertions, 8 deletions
diff --git a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc b/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
index 2b54c7551c9..0afc91f5408 100644
--- a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
+++ b/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
@@ -6,8 +6,8 @@
- bool x_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
- bool y_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
-+ bool x_threshold_passed = (abs ((long long) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
-+ bool y_threshold_passed = (abs ((long long) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
++ bool x_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
++ bool y_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
drag_info.move_threshold_passed = (x_threshold_passed || y_threshold_passed);
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index 2dab535bd3b..a467b94d75d 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -138,9 +138,3 @@ share/locale/de_DE/LC_MESSAGES/gtk2_ardour.mo
@dirrmtry share/locale/ru_RU
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
-@dirrmtry share/locale/pt_PT/LC_MESSAGES
-@dirrmtry share/locale/pt_PT
-@dirrmtry share/locale/es_ES/LC_MESSAGES
-@dirrmtry share/locale/es_ES
-@dirrmtry share/locale/fr_FR/LC_MESSAGES
-@dirrmtry share/locale/fr_FR