aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-26 21:50:12 +0800
committerpav <pav@FreeBSD.org>2006-03-26 21:50:12 +0800
commit47401b589c98aae1cc6989f7da158b17f3c5e5cd (patch)
tree861d7931a9afd7ecf2539032d72b514ffe95750b
parenta72db092c176685a6cff88f12e8270976019aa6a (diff)
downloadfreebsd-ports-graphics-47401b589c98aae1cc6989f7da158b17f3c5e5cd.tar.gz
freebsd-ports-graphics-47401b589c98aae1cc6989f7da158b17f3c5e5cd.tar.zst
freebsd-ports-graphics-47401b589c98aae1cc6989f7da158b17f3c5e5cd.zip
- Fix problem with automatic creation of squirrelmail config file even when
there hasn't been one before PR: ports/94953 Submitted by: Alexander Wittig <alexander@wittig.name> (maintainer)
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/Makefile2
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/pkg-plist4
2 files changed, 4 insertions, 2 deletions
diff --git a/mail/squirrelmail-change_ldappass-plugin/Makefile b/mail/squirrelmail-change_ldappass-plugin/Makefile
index 5b00ab2acfa..a5f46f8f82e 100644
--- a/mail/squirrelmail-change_ldappass-plugin/Makefile
+++ b/mail/squirrelmail-change_ldappass-plugin/Makefile
@@ -61,8 +61,10 @@ do-install:
post-install:
.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
@${ECHO} "Activating plug-in in SquirrelMail"
${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
.else
@${ECHO} "To activate the plug-in in SquirrelMail use"
@${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
diff --git a/mail/squirrelmail-change_ldappass-plugin/pkg-plist b/mail/squirrelmail-change_ldappass-plugin/pkg-plist
index 9c84c0d0ce3..222197d619f 100644
--- a/mail/squirrelmail-change_ldappass-plugin/pkg-plist
+++ b/mail/squirrelmail-change_ldappass-plugin/pkg-plist
@@ -1,4 +1,4 @@
-@unexec %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin change_ldappass
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin change_ldappass; fi
%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR/LC_MESSAGES/change_ldappass.mo
%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR/LC_MESSAGES/change_ldappass.po
%%SQUIRRELDIR%%/plugins/change_ldappass/locale/pl/LC_MESSAGES/change_ldappass.mo
@@ -42,4 +42,4 @@
@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/el_GR
@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale
@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/
-@exec %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin change_ldappass
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin change_ldappass; fi