aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-16 07:09:13 +0800
committermarino <marino@FreeBSD.org>2015-03-16 07:09:13 +0800
commit49fb683f4ea1a450ee58c2a5d00073424521ddef (patch)
tree6426b9a8b0272705b49a18b8dc5b522508149de4
parent11870ad5725c5b9c57c5b0070a0a64820bfce7f5 (diff)
downloadfreebsd-ports-graphics-49fb683f4ea1a450ee58c2a5d00073424521ddef.tar.gz
freebsd-ports-graphics-49fb683f4ea1a450ee58c2a5d00073424521ddef.tar.zst
freebsd-ports-graphics-49fb683f4ea1a450ee58c2a5d00073424521ddef.zip
lang/gcc5-aux: Fix ada hardlink
The code to create a hardlink of gcc5-aux/bin/ada to gcc5-aux/bin/gcc did not work. It appears that the "-" in front of the "if" condition isn't working in this context. However, it's really not needed at all, so just remove it so the hardlink gets created. All Ada ports use gcc5-aux/bin/ada, so it was a critical problem.
-rw-r--r--lang/gcc5-aux/Makefile.version2
-rw-r--r--lang/gcc5-aux/files/diff-core2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/gcc5-aux/Makefile.version b/lang/gcc5-aux/Makefile.version
index a2f7b3c88ab..7606df690f1 100644
--- a/lang/gcc5-aux/Makefile.version
+++ b/lang/gcc5-aux/Makefile.version
@@ -5,7 +5,7 @@ GCC_POINT= 0.0
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
SNAPSHOT= 20150308
BUILD_RELEASE= no
-MAIN_PR= 0
+MAIN_PR= 1
UTIL_PR= 0
ARMV7_PR= 0
diff --git a/lang/gcc5-aux/files/diff-core b/lang/gcc5-aux/files/diff-core
index 04cf9e73227..f632d2db469 100644
--- a/lang/gcc5-aux/files/diff-core
+++ b/lang/gcc5-aux/files/diff-core
@@ -327,7 +327,7 @@
( cd $(DESTDIR)$(bindir) && \
$(LN) $(GCC_INSTALL_NAME)$(exeext) $(FULL_DRIVER_NAME) ); \
fi; \
-+ -if [ -f gnat1$(exeext) ] ; then \
++ if [ -f gnat1$(exeext) ] ; then \
+ ( cd $(DESTDIR)$(bindir) && $(LN) $(GCC_INSTALL_NAME)$(exeext) ada$(exeext) ) \
+ fi; \
if [ ! -f gcc-cross$(exeext) ] \