aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-09 03:29:09 +0800
committerpav <pav@FreeBSD.org>2004-12-09 03:29:09 +0800
commit4a55e7acf6a81097e54303fd853ccf740538afb8 (patch)
tree5bc7a951750859d60464acd185df05f66c1c92fa
parentaa0d1257c81346e9add4f0612a98a8cf6ba358b0 (diff)
downloadfreebsd-ports-graphics-4a55e7acf6a81097e54303fd853ccf740538afb8.tar.gz
freebsd-ports-graphics-4a55e7acf6a81097e54303fd853ccf740538afb8.tar.zst
freebsd-ports-graphics-4a55e7acf6a81097e54303fd853ccf740538afb8.zip
- Make the library actually usable on gcc 3.4 systems:
/usr/local/lib/libfame.so: undefined reference to `_mmx_one' PR: ports/74806 Submitted by: Hendrik Scholz <hendrik@scholz.net> Obtained from: http://www.linuxfromscratch.org/blfs/downloads/svn/libfame-0.9.1-gcc34-1.patch
-rw-r--r--multimedia/libfame/Makefile1
-rw-r--r--multimedia/libfame/files/patch-mmx_one-gcc3422
2 files changed, 23 insertions, 0 deletions
diff --git a/multimedia/libfame/Makefile b/multimedia/libfame/Makefile
index e1e361321d4..2f5828e6a93 100644
--- a/multimedia/libfame/Makefile
+++ b/multimedia/libfame/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libfame
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fame
diff --git a/multimedia/libfame/files/patch-mmx_one-gcc34 b/multimedia/libfame/files/patch-mmx_one-gcc34
new file mode 100644
index 00000000000..114cb9a1da3
--- /dev/null
+++ b/multimedia/libfame/files/patch-mmx_one-gcc34
@@ -0,0 +1,22 @@
+--- src/half_sse.h.orig Tue Dec 7 10:24:14 2004
++++ src/half_sse.h Tue Dec 7 10:24:29 2004
+@@ -19,7 +19,7 @@
+ */
+ /**************************** half-pixel interpolation ***********************/
+
+-static short const _mmx_one[] = { 1, 1, 1, 1 };
++const _mmx_one[] = { 1, 1, 1, 1 };
+ static unsigned char const _mmx_one_byte[] = {1,1,1,1,1,1,1,1};
+
+
+--- src/half_mmx.h.orig Tue Dec 7 10:23:21 2004
++++ src/half_mmx.h Tue Dec 7 10:23:32 2004
+@@ -18,7 +18,7 @@
+ */
+ /**************************** half-pixel interpolation ***********************/
+
+-static short const _mmx_one[] = { 1, 1, 1, 1 };
++const _mmx_one[] = { 1, 1, 1, 1 };
+
+ static void inline mmx_interpolate(unsigned char **ref,
+ int pitch,