aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2016-07-03 13:18:09 +0800
committermi <mi@FreeBSD.org>2016-07-03 13:18:09 +0800
commit4b2999a25a1cc1bdfeed37a528e6b9ede5d30907 (patch)
tree9086c5d1ef207843d93a7f28d6683d70c0f5f910
parent83274f414df91ac85f8e9cdde090b5ae6cbad214 (diff)
downloadfreebsd-ports-graphics-4b2999a25a1cc1bdfeed37a528e6b9ede5d30907.tar.gz
freebsd-ports-graphics-4b2999a25a1cc1bdfeed37a528e6b9ede5d30907.tar.zst
freebsd-ports-graphics-4b2999a25a1cc1bdfeed37a528e6b9ede5d30907.zip
Fix compiler-warnings. Add LICENSE-declaration.
Approved by: maintainer
-rw-r--r--x11/wmctrl/Makefile2
-rw-r--r--x11/wmctrl/files/patch-main.c53
2 files changed, 53 insertions, 2 deletions
diff --git a/x11/wmctrl/Makefile b/x11/wmctrl/Makefile
index 7aad6b044cd..0cd019782b9 100644
--- a/x11/wmctrl/Makefile
+++ b/x11/wmctrl/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://sweb.cz/tripie/utils/wmctrl/dist/
MAINTAINER= flz@FreeBSD.org
COMMENT= Command line tool to interact with an EWMH/NetWM compatible X managers
+LICENSE= GPLv2
+
USES= pkgconfig
GNU_CONFIGURE= yes
USE_XORG= x11 xmu xext xt
diff --git a/x11/wmctrl/files/patch-main.c b/x11/wmctrl/files/patch-main.c
index 4af039d3cd0..23504856211 100644
--- a/x11/wmctrl/files/patch-main.c
+++ b/x11/wmctrl/files/patch-main.c
@@ -1,5 +1,54 @@
---- main.c.orig 2005-01-29 03:31:33.000000000 +0000
-+++ main.c 2010-12-20 11:09:11.000000000 +0000
+--- main.c 2005-01-29 03:31:33.000000000 +0000
++++ main.c 2016-07-01 20:14:55.443662000 +0000
+@@ -210,14 +210,14 @@
+ static int close_window (Display *disp, Window win);
+ static int longest_str (gchar **strv);
+ static int window_to_desktop (Display *disp, Window win, int desktop);
+-static void window_set_title (Display *disp, Window win, char *str, char mode);
++static void window_set_title (Display *disp, Window win, const char *str, char mode);
+ static gchar *get_window_title (Display *disp, Window win);
+ static gchar *get_window_class (Display *disp, Window win);
+ static gchar *get_property (Display *disp, Window win,
+ Atom xa_prop_type, gchar *prop_name, unsigned long *size);
+ static void init_charset(void);
+-static int window_move_resize (Display *disp, Window win, char *arg);
+-static int window_state (Display *disp, Window win, char *arg);
++static int window_move_resize (Display *disp, Window win, const char *arg);
++static int window_state (Display *disp, Window win, const char *arg);
+ static Window Select_Window(Display *dpy);
+ static Window get_active_window(Display *dpy);
+
+@@ -629,9 +629,9 @@
+ }/*}}}*/
+
+ static void window_set_title (Display *disp, Window win, /* {{{ */
+- char *title, char mode) {
+- gchar *title_utf8;
+- gchar *title_local;
++ const char *title, char mode) {
++ void *title_utf8;
++ void *title_local;
+
+ if (envir_utf8) {
+ title_utf8 = g_strdup(title);
+@@ -734,7 +734,7 @@
+ 0, 0, 0, 0, 0);
+ }/*}}}*/
+
+-static int window_state (Display *disp, Window win, char *arg) {/*{{{*/
++static int window_state (Display *disp, Window win, const char *arg) {/*{{{*/
+ unsigned long action;
+ Atom prop1 = 0;
+ Atom prop2 = 0;
+@@ -827,7 +827,7 @@
+ return FALSE;
+ }/*}}}*/
+
+-static int window_move_resize (Display *disp, Window win, char *arg) {/*{{{*/
++static int window_move_resize (Display *disp, Window win, const char *arg) {/*{{{*/
+ signed long grav, x, y, w, h;
+ unsigned long grflags;
+ const char *argerr = "The -e option expects a list of comma separated integers: \"gravity,X,Y,width,height\"\n";
@@ -1441,6 +1441,9 @@
/* null terminate the result to make string handling easier */