aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2003-12-07 22:56:17 +0800
committerlofi <lofi@FreeBSD.org>2003-12-07 22:56:17 +0800
commit4cf8cad928ffa077abc49fb676cf489fa8b5dfad (patch)
tree03b1dd9b849439af3767df7afffd8a1234b6d24b
parent6a3f7ca526ec283f379816115cffac9f0c12f016 (diff)
downloadfreebsd-ports-graphics-4cf8cad928ffa077abc49fb676cf489fa8b5dfad.tar.gz
freebsd-ports-graphics-4cf8cad928ffa077abc49fb676cf489fa8b5dfad.tar.zst
freebsd-ports-graphics-4cf8cad928ffa077abc49fb676cf489fa8b5dfad.zip
Readd cludge for ldconfig which got accidentally removed in the previous
commit.
-rw-r--r--audio/portaudio/Makefile6
-rw-r--r--audio/portaudio2/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
index 21a4e82fab3..0d746a803c7 100644
--- a/audio/portaudio/Makefile
+++ b/audio/portaudio/Makefile
@@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS=yes
+SHLIB_VERSION= 0
+
pre-everything::
.if !defined(WITH_PATESTS)
@${ECHO_MSG}
@@ -50,9 +52,11 @@ post-configure:
@${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
.endif
-.if defined(WITH_PATESTS)
post-install:
+.if defined(WITH_PATESTS)
@${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
.endif
+ @${LN} -sf libportaudio.so \
+ ${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
.include <bsd.port.mk>
diff --git a/audio/portaudio2/Makefile b/audio/portaudio2/Makefile
index 21a4e82fab3..0d746a803c7 100644
--- a/audio/portaudio2/Makefile
+++ b/audio/portaudio2/Makefile
@@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS=yes
+SHLIB_VERSION= 0
+
pre-everything::
.if !defined(WITH_PATESTS)
@${ECHO_MSG}
@@ -50,9 +52,11 @@ post-configure:
@${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
.endif
-.if defined(WITH_PATESTS)
post-install:
+.if defined(WITH_PATESTS)
@${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
.endif
+ @${LN} -sf libportaudio.so \
+ ${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
.include <bsd.port.mk>